1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Battery Bug

Discussion in 'Bug Reports' started by Marvis157, Nov 18, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Marvis157

    Marvis157 Trainee Engineer

    Messages:
    2
    Hello, i have little problem with batteries, i have 21 solar panels and they have 2.1MW ouput (all solars). And in battery description window (right down edge) is current input: 2.1MW and on output is zero, but batteries don't charge. That's happen after i join on my dedicated server, before that were all ok. I was try reinstall the game, but didn't work and i was tried game on 2 PC. Do you need some logs ?
     
  2. waterlimon

    waterlimon Senior Engineer

    Messages:
    1,499
    Yeah I observed similar issues with batteries in a dedicated server. Solar panels were producing power but batteries just displayed constant charge (even though they had input)
     
  3. Anthropy

    Anthropy Trainee Engineer

    Messages:
    91
    Can confirm, batteries have to be in recharge mode in order to take power from the solar panels.. in most conditions. some discharging + some recharging mode batteries also ignores the solar panels, single battery plus single solar panel in normal mode also charges fine.. it's hard to exactly pinpoint what's going on, but it's bugged for sure.
     
  4. Telquel

    Telquel Trainee Engineer

    Messages:
    45
    Yep, same problem. Home lan DS.
     
  5. [KuT]Sabbie

    [KuT]Sabbie Trainee Engineer

    Messages:
    15
    We're having the same problems on our dedicated server.

    My station has 4 solar panels and one battery. The battery never charges as discussed here. Another person on the server has the same issues.

    I did some testing today with space masters creative mode:

    I created a new station. Just some blocks, with a solar panel and a battery, close to our bases. The battery showed input from the solar panel, but was DISCHARGING, even though the 'station' was using no power.

    Sun went under, so I've repeated the experiment on the other side of the planet. Here the battery suddenly started to charge.

    I've repeated it at yet another place and it still worked.

    I have the feeling this has something to do with the Atmospheric Lander bug. (Where, when you convert it to a station via a merge block, it will start to consume 12MW for no reason.) We did have one parked nearby from an offline buddy.

    I've blueprinted the lander and spawned one near my test setup, but nothing changed. It was happily charging.
     
  6. shmafoozius

    shmafoozius Trainee Engineer

    Messages:
    60
    It's not just happening on dedicated servers. I have this issue on my local game I opened for a friend. I'm the host and he's the only other client. Still, we always have to switch batteries to recharge mode.
     
  7. Dereknor

    Dereknor Trainee Engineer

    Messages:
    81
    I have problems with my batteries on a dedicated server too. My battery just doesnt charge correctly. It got an input of about 600 kW out of the Solar units. That should charge the Battery with 166 W per Second. But each second, I just gain about 1 W. So it takes 160 Minutes to charge enough power into the battery to have an output of 600 kW for just 1 Minute. Thats veeeeery inefficient.
     
  8. Kielm

    Kielm Junior Engineer

    Messages:
    508
    Batteries are still not charging from Solar Panels in 1.09.
     
  9. Natebluehooves

    Natebluehooves Trainee Engineer

    Messages:
    35
    i'd just like to point out that as far as i'm aware, the devs still haven't even mentioned that this is a problem they know about, and the problem is still happening.... this is forcing me to not play space engineers in survival, which is the only way i'm currently interested in playing. anyone know of a fix?
     
  10. [uRxP] Inverse

    [uRxP] Inverse Trainee Engineer

    Messages:
    11
    There isn't a fix and the devs should be reading the bug reports from the player more often.
     
  11. Dereknor

    Dereknor Trainee Engineer

    Messages:
    81
    I still got that problem. I cant play on any dedicated server. Everywhere I built, my solar panels doesnt charge my batteries at all. The batteries even discharge, while having 600 kW input and 7 kW output.

    I got that problem on several dedicated servers now, making online game impossible for me. I couldnt find any problem at all in the savegames. When I download them and run them locally, everything works fine. When I upload it again on the server, the battery is not charging anymore. So it is a problem with the dedicated server somehow. And it is linked to the character. no matter where or what I built, the batteries doesnt charge. So its not a problem of a special grid.

    I really cant think of a logical reason for that. Even when I give ownership of my batteries and solarpanels to another player, they dont charge. There is no strange entry about it in the sbc file, everything is just fine.
    It is just like the dedicated server somehow drains power from every grid that is created by a special account.

    This bug is reaaaally annoying, making online game impossible for players that experiance this.
     
  12. [uRxP] Inverse

    [uRxP] Inverse Trainee Engineer

    Messages:
    11
    Welcome to "Early Access"
     
  13. Varangian

    Varangian Trainee Engineer

    Messages:
    10
    I had to use one of the myriad of stone->ore mods to bypass this by producing uranium and just skipping solar panels.
     
  14. TheDuke540

    TheDuke540 Apprentice Engineer

    Messages:
    201
    Not sure if I'm alone here, but the battery/solar recharge/discharge seems to have been fixed for SP survival. Just tested on my easy start survival base. Was able to charge multiple batteries with solar. The batteries also no longer default to discharge like they were for me. I can't speak for DS players, however.
     
  15. kcjunkbox

    kcjunkbox Senior Engineer

    Messages:
    1,132
    They charge sometimes but it depends on what a other equipment is running. I'm playing single player survival offline.i have 8 panels pointed directly at sun on the atmosphere lander in the solar system start. If I'm not running anything or just the uograded refinery and arc furnace I added to the ship the batteries will charge with the left over solar power. If I run the assember at the same time, the solar power is ignored, 0 percent output, and power is just pulled from batteries with no charging by excess power from panels. Panels are useless. If I want them to output I have to turn batteries off and use reactor, then panels start outputting again and reactor makes up difference and batteries are useless. So something is bugged with electricity.
     
  16. Varangian

    Varangian Trainee Engineer

    Messages:
    10
    Just tested it on single-player survival, cannot charge batteries while outputting from them, no matter what I do.

    In addition, even with everything turned off except batteries and panels on my small ship rover, I can only charge the batteries by connecting to my solar farm station. The panels onboard the rover will not charge the batteries, no matter what I do.
     
  17. Gnarles

    Gnarles Trainee Engineer

    Messages:
    39
    TLDR: Unless there is a lot of manual intervention batteries won't charge and the power grid just stops working.

    I'm here to add my findings to this one too, not just batteries but the entire power grid seems to be a little messed up. All of this is on a dedicated server which has proven more than difficult to get started on due to the myriad of bugs we have encountered.

    Batteries

    What should happen:
    1. When all of the options are unchecked (recharge, discharge and semi-auto), from what I've read, this should output what the grid needs while also taking in any surplus from energy producers on the grid.
    2. When on recharge it should pull any surplus from the energy producers and not out put at all.
    3. When on discharge it should not pull any surplus from the grid and should output to the grid when needed.
    4. When in semi-auto it should recharge till full then switch to discharge till empty then back again.
    What is happening:
    1. When all options are unchecked it sometimes recharges but most of my observations have been that it will slowly discharge even when receiving an input much higher than it's output. (For example, one battery had an input of ~900kW an output of ~100kW and it was still losing stored power. Even with the 20% efficiency loss it should have been gaining power)
    2. Again this sometimes works but more often than not the battery will charge very slowly for a little while and then slow down and stop.
    3. This seems to work if you can get power into the battery in the first place
    4. Not really played with this one much. It takes too long to charge a battery because of the above and to be honest I can't think of a scenario where semi-auto would work as you'd just end up dumping power into another battery and losing 20% of it.
    All of this together makes it very difficult to get your power grid working without a lot of manual switching of recharge \ discharge.

    Solar Panels

    What should happen:

    I was under the impression that solar panels should be the first thing on the grid used if they are outputting enough power. Any excess power should then be picked up by batteries that are either on recharge or with nothing ticked.

    What is happening:

    When something, like the assembler, is running and there is more than enough power coming from the solar panels I still see it drawing power from the batteries as well. Last night I also hit a weird bug where if the batteries had all options unchecked the solar panels were all reporting 0kW output, when I switched my batteries to recharge the solar panels suddenly started outputting again.

    Power Consumers

    What should happen:

    If there is enough power coming from solar panels or batteries with either nothing ticked or discharge ticked then things like the assembler should run fine.

    What is happening:

    The assembler won't assemble or disassemble unless the batteries are set to discharge. I had 1.2MW coming from 21 solar panels and the assembler wouldn't run as there was "Insufficient Power".


    The bugs above make it very difficult to get your base set up and running, we have lost an outpost to the recharging and power bugs as the med-bay lost power and is currently sitting un-powered on a grid with 18 solar panels. Along with the constant loss of materials from losing vehicles to glitches and various other mechanical related bugs it is making it very difficult to even get off the first planet.
     
    • Agree Agree x 3
  18. Jas

    Jas Apprentice Engineer

    Messages:
    443
    it seems that batteries have higer priority than solar panels and this should be viceversa to work as intended in default mode (all box unchecked) and this is why panels input is not used (output 0) if it is lower than grid load, plus the only way to run an assembler is to set batteries in discharge mode. +1 confirmed
     
    • Agree Agree x 1
  19. Teladion

    Teladion Trainee Engineer

    Messages:
    6
    confirmed, this issue makes playing survival on DS pretty much impossible
    you can`t let the batteries charge while nobody is on the server.
     
  20. Dereknor

    Dereknor Trainee Engineer

    Messages:
    81
    we still got this problem on our dedicated server, not just one but a few people. While others can load just fine. I really hate this bug, its killing our server for 3 month already :( We changed server, we made a new world, we tried everything. Somehow, this bug seems to be linked to players, no matter where they play. The worst bug I have ever seen in SE in all this years.
     
Thread Status:
This last post in this thread was made more than 31 days old.