1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. The forum will be closing soon permanently. Please read the announcement here

    Note: User registration has been closed. We do not accept any new accounts.

[01.112.010] Crashiness -AddVoxelMap resulting in error

Discussion in 'Bug Reports' started by YtramX, Dec 10, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. YtramX

    YtramX Apprentice Engineer

    Messages:
    238
    This is happening to me every few minutes while playing. I'm not entirely sure what it's related to, as I'm doing a variety of things, but most commonly I'm working with cameras, antennas, and remote control. This is single player, creative, DX11, planet surface.

    Below is the whole log, but this is the stack trace I'm seeing every time:
    Code:
    Exception occured: System.ArgumentException: An item with the same key has already been added.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at Sandbox.Game.World.MyWorldGenerator.AddVoxelMap(String storageName, MyStorageBase storage, MatrixD worldMatrix, Int64 entityId, Boolean lazyPhysics)
       at Sandbox.Game.Entities.MyPlanetEnvironmentSector.AddVoxelMap(String prefabName, Vector3D position, MatrixD rotation, String name, Int32 id, Int64 entityId, Byte[] modifierFrom, Byte[] modifierTo)
       at Sandbox.Game.Entities.MyPlanetEnvironmentSector.EndDetailPlacement()
       at Sandbox.Game.Entities.MyPlanetEnvironmentSector.DoSerialWork(Boolean queuedWork)
       at Sandbox.Game.Entities.MyPlanet.SerialWorkCallback()
       at ParallelTasks.Parallel.RunCallbacks()
       at Sandbox.Game.World.MySession.Update(MyTimeSpan updateTime)
       at Sandbox.MySandboxGame.Update()
       at Sandbox.Engine.Platform.Game.UpdateInternal()
       at Sandbox.Engine.Platform.FixedLoop.<>c__DisplayClass2.<Run>b__1()
       at Sandbox.Engine.Platform.GenericLoop.Run(VoidAction tickCallback)
       at Sandbox.Engine.Platform.Game.RunLoop()
       at Sandbox.MySandboxGame.Run(Boolean customRenderLoop, Action disposeSplashScreen)
       at SpaceEngineers.MyProgram.RunInternal(String[] args)
       at SpaceEngineers.MyProgram.Main(String[] args)
    Here's the whole log
     
    Last edited: Dec 10, 2015
  2. WhiteWorlB

    WhiteWorlB Trainee Engineer

    Messages:
    90
    Hello I have a similar problem

    Idk what its related to. it occurs after 5 to 15 minutes into the game. had this 5 times now.

    Log

     
    Last edited: Dec 10, 2015
  3. YtramX

    YtramX Apprentice Engineer

    Messages:
    238
    It looks like it's a race condition with the call to AddVoxelMap, as it's occurring within a Parallel call. It's one of those luck of the draw things that'll happen 5-15 minutes after starting. Probably doesn't matter what you're doing.
     
  4. WhiteWorlB

    WhiteWorlB Trainee Engineer

    Messages:
    90
    reading the logs. seems to be the same issue...

    if take i wild guess, id say its connected to the falling through planet issue... the planet voxels are a bit buggy atm.
    unfortunate. but well... hope they┬┤ll fix it tomorrow at least partially... i think this will take a while to polish...
     
  5. Eliza Azile

    Eliza Azile Trainee Engineer

    Messages:
    1
    My server was crashing in the same way, I disabled the "Enable Flora" button on my dedicated server and it seems to have stopped crashing. Fingers crossed of course.
     
  6. DiggaTron

    DiggaTron Trainee Engineer

    Messages:
    44
    +1 for a crash on DS also... after 2 hours of up time. Only crash to report thus far. 15 or so players at the time. Also, call me crazy but maaaayyyybbeeee (wild i know) the new voxel attributes of them thar rocks in them thar hills. Patch should be quick.
     
  7. WhiteWorlB

    WhiteWorlB Trainee Engineer

    Messages:
    90
    Ill try this!!!!

    Edit: Nope still crashed.
     
    Last edited: Dec 10, 2015
  8. DiggaTron

    DiggaTron Trainee Engineer

    Messages:
    44
    I am now seeing what is essentially rolling resets with only this error showing in the logs, it seems whatever client aggravated the bug is causing it to happen again on their reconnecting to the server..... keen, is there a safe place to dump world saves for you guys?
     
  9. MarlDaeSu

    MarlDaeSu Trainee Engineer

    Messages:
    58
    Getting same issue on my DS, same log errors. Trying disabling flora, will report back.
     
  10. CCCP_Punk 2

    CCCP_Punk 2 Trainee Engineer

    Messages:
    48
    https://forum.keenswh.com/threads/1-112-dx11-sp-survival-crash-when-flying.7376206/#post-1286904934 - the same tread

    8 same crashes by 2,5 hours! It's not funny!!! :mad:

    10.12.2015 22:52:02. Server crash. Restart
    10.12.2015 23:09:13. Server crash. Restart
    10.12.2015 23:35:04. Server crash. Restart
    10.12.2015 23:58:45. Server crash. Restart
    11.12.2015 0:11:36. Server crash. Restart
    11.12.2015 0:22:17. Server crash. Restart
    11.12.2015 0:30:48. Server crash. Restart
    11.12.2015 1:29:51. Server crash. Restart
     
    • Funny Funny x 1
  11. WhiteWorlB

    WhiteWorlB Trainee Engineer

    Messages:
    90

    Hmm... sadly it will prolly persist until hotfix tomorrow(at least)
    running a server will be a pain atm.
     
  12. MarlDaeSu

    MarlDaeSu Trainee Engineer

    Messages:
    58
    Yeah server is essentially dead until hotfix.
     
  13. DiggaTron

    DiggaTron Trainee Engineer

    Messages:
    44

    *giggle*

    *serious face* my server has seen 5... think the client that aggravated the bug got sick of re-logging \o/. Don't worry about it, its a big problem and big problems get sorted fast.
     
    • Agree Agree x 1
  14. Amerikanovich

    Amerikanovich Apprentice Engineer

    Messages:
    323

    Same exact thing happening to me, first time loading after the update and it crashed after taking 2 steps forward, second time loading I was able to run towards the ship I was building and look at the part I was working on before it happened, both times within a minute after the world loads.
    Log has the exact same message at the end.
    Code:
    2015-12-11 00:15:16.465 - Thread:   1 ->  Exception occured: System.ArgumentException: An item with the same key has already been added.
       at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at VRage.MyEntityIdentifier.AddEntityWithId(IMyEntity entity)
       at Sandbox.Game.Entities.MyPlanetEnvironmentSector.EndDetailPlacement()
       at Sandbox.Game.Entities.MyPlanetEnvironmentSector.DoSerialWork(Boolean queuedWork)
       at Sandbox.Game.Entities.MyPlanet.SerialWorkCallback()
       at Sandbox.Game.Entities.MyPlanet.UpdateFloraAndPhysics(Boolean serial)
       at Sandbox.Game.Entities.MyPlanet.UpdateAfterSimulation10()
       at Sandbox.Game.Entities.MyEntities.UpdateAfterSimulation()
       at Sandbox.Game.World.MySector.UpdateAfterSimulation()
       at Sandbox.Game.World.MySession.UpdateComponents()
       at Sandbox.Game.World.MySession.Update(MyTimeSpan updateTime)
       at Sandbox.MySandboxGame.Update()
       at Sandbox.Engine.Platform.Game.UpdateInternal()
       at Sandbox.Engine.Platform.FixedLoop.<>c__DisplayClass2.<Run>b__1()
       at Sandbox.Engine.Platform.GenericLoop.Run(VoidAction tickCallback)
       at Sandbox.MySandboxGame.Run(Boolean customRenderLoop, Action disposeSplashScreen)
       at SpaceEngineers.MyProgram.RunInternal(String[] args)
       at SpaceEngineers.MyProgram.Main(String[] args)
    2015-12-11 00:15:16.467 - Thread:   1 ->  Hiding window
    2015-12-11 00:15:16.473 - Thread:   1 ->  Network readers disposed
    2015-12-11 00:15:17.671 - Thread:   1 ->  Hiding window done
    2015-12-11 00:15:17.671 - Thread:   1 ->  Showing message
    2015-12-11 00:15:17.723 - Thread:   1 ->  ERROR: branch name cannot be resolved, services=
    2015-12-11 00:15:17.723 - Thread:   1 ->  ERROR: branch name cannot be resolved, services=
    2015-12-11 00:15:17.723 - Thread:   1 ->  ERROR: branch name cannot be resolved, services=
     
  15. MarlDaeSu

    MarlDaeSu Trainee Engineer

    Messages:
    58
    Tested server with flora off and it works and I can connect successfully. Tried re-enabling flora and right enough, it crashed again when I tried to connect. Temporary fix may be to turn flora off, although there is clearly some sort of mad issue going on behind the scenes so I don't know if this will work for every one.
     
    • Like Like x 1
  16. demolish50

    demolish50 Senior Engineer

    Messages:
    1,434
    confirmed
     
  17. firebomb

    firebomb Trainee Engineer

    Messages:
    10
    Tested our Dedicated server with everything turned off/on, mods and no mods, and we keep crashing. Funny thing is when we made the new world connecting eventually crashed the server. Just now, I crashed and the server is all green in its stats menu. I'm guessing this is a client side problem.
     
    • Like Like x 1
  18. CCCP_Punk 2

    CCCP_Punk 2 Trainee Engineer

    Messages:
    48
    Looks like it's working! Thanks! :tu:
     
  19. Phand

    Phand Master Engineer

    Messages:
    9,650
    Hi,

    we will fix this crash today. Sorry for any inconvenience caused. :(
     
    • Like Like x 6
  20. Baconfist

    Baconfist Apprentice Engineer

    Messages:
    175
    Same crash here

     
  21. MarlDaeSu

    MarlDaeSu Trainee Engineer

    Messages:
    58
    Thanks Phand, we had faith the old Friday hotfix would do the job :D
     
  22. WhiteWorlB

    WhiteWorlB Trainee Engineer

    Messages:
    90
    running like a charm atm. singleplayer offline that is.
    no crashes since an hour.
    ill report if something changes for me.
     
Thread Status:
This last post in this thread was made more than 31 days old.