1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Issue running server with 4096 resolution highmap.

Discussion in 'Bug Reports' started by Regnilse, Feb 10, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Regnilse

    Regnilse Trainee Engineer

    Messages:
    29
    As the title states we are running a server with a custom world using heightmaps that are 4096x4096, from previous experience I know that ME is optimized for heightmaps divisible by 8 and a power of 4 ie. 2048 or 8192 and that other resolutions can cause issues. However while testing the planet in single player I found none of the crashes related to the 4096 resolution that I had previously and assumed that the bug was fixed and we could use 4096 as our resolution safely even if it wasn't optimized.

    But the bug is back and in multiplayer.
    This is a snippit of the crash report.

    2017-02-09 23:26:12.530 - Thread: 1 -> Error: Cannot build prunning tree for heightmap face 857946189.sbm:RPmap_front!
    2017-02-09 23:26:12.530 - Thread: 1 -> Error: Heightmap resolution must be divisible by 8, and after that a power of 4. Failing to achieve so will disable several important optimizations!!

    The same issue I ran in to before.

    I know that having our resolution at 4096 is not ideal but would it be causing our crashing, *Edit: this doesn't seem to me the main issue as Cog has mentioned.*
    What does prunning tree do btw? I'm interested to know.

    Server Log
    https://www.dropbox.com/s/sjwr6z7jtzotp80/MedievalEngineersDedicated.log?dl=0
     
    Last edited: Feb 10, 2017
  2. Coggernaut

    Coggernaut Trainee Engineer

    Messages:
    71
    2017-02-10 00:45:47.959 - Thread: 1 -> MyGuiScreenBase.UnloadContent - END
    2017-02-10 00:45:50.511 - Thread: 9 -> Error: Item saved or coming from server has a growth step that is out of bounds. The item was locally calculated as Gatherable:Schematic_Berries.
    2017-02-10 00:45:50.511 - Thread: 9 -> Error: Item saved or coming from server has a growth step that is out of bounds. The item was locally calculated as Gatherable:Schematic_Berries.
    2017-02-10 00:45:55.483 - Thread: 1 -> MyGuiScreenCubeBuilder.ctor START


    Any idea what this means?
     
  3. CptTwinkie

    CptTwinkie Master Engineer

    Messages:
    4,458
    It means your berry bushes saved incorrectly. Not related to heightmaps at all
     
  4. Coggernaut

    Coggernaut Trainee Engineer

    Messages:
    71

    I see... And what would cause that?

    Currently I have all plants cycling back to the "Dead" stage. I did this because I was unsure if normal plants respawned. Show you the line of code if you'ed like.

    I also changed growth stages post-world creation, but I dont think thats an issue...

    Though, does this require a world wipe to fix the issue with the bush not being saved correctly? Or is it a data issue?


    PS: Thank you very much for taking the time to read this! I'm generally stumped on this error
     
  5. CptTwinkie

    CptTwinkie Master Engineer

    Messages:
    4,458
    You have to define the growth steps and only use the ones you have defined. If you try to use growth step 4, as an example, and you've only defined 0-3, then you will get unpredictable behavior and warnings when loading the save. As far as I'm aware, the growth step is saved as an integer.

    The other problem is that the environment system is supposed to work by triggered actions only. You want to be very careful of that because any other way of changing stages will certainly desync MP and could cause other problems. One of the problems that it could cause is if you change the growth step before an action does the same you can end up with exactly the problem where you are out of range. I would say your issue is a modding problem rather than a bug and we are discussing it on Regnilse's bug report. Please start a thread somewhere else for this.
     
  6. Coggernaut

    Coggernaut Trainee Engineer

    Messages:
    71
    Thank you so much, now that we know the issue, I'll be able to fix this! And yes, I'll write posts like these in the correct area from now on. My apologies for derailing the original post.
     
Thread Status:
This last post in this thread was made more than 31 days old.