1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

[1.184.7] Small Grid Thrusters do not damage blocks on the same grid...

Discussion in 'Bug Reports' started by suicideneil, Nov 2, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. suicideneil

    suicideneil Apprentice Engineer

    Messages:
    223
    Yeah, that's a thing now.

    No matter how close you place them, blocks do not take damage from Ion or Hydrogen thrusters when the blocks are on the same grid and in the exhaust plume. The moment you severe the blocks however, they take damage and disappear/deform within a few seconds.

    Also, Hydrogen tanks run out of fuel in creative mode, still ( since previous update ).

    There are other issues with inconsistent thruster damage to the same block vs thruster configurations on large vs small grids, but I haven't had time to test all the variables yet- seems half blocks have a funky collision box, and small corner blocks on small grids take damage at a range that they don't on large grids. Damage distance seems to have been reduced again, we could do with an official word on this so that we don't have to worry about what range is safe and what isn't again.

    Please investigate and fix, cheers.
     
  2. Tigerstripe

    Tigerstripe Apprentice Engineer

    Messages:
    479
    This is probably a temporary fix for the thruster damage system, which Keen tinkered with last week, resulting in a lot of rage as everyone's previously-safe designs started to spontaneously combust.

    The devs have said they'll be working on thruster damage some more in the near future.
     
  3. suicideneil

    suicideneil Apprentice Engineer

    Messages:
    223
    How can that be a 'fix'- they stated in the patch notes that thruster damage was not working correctly under certain conditions, and now it doesn't work at all ( on small grids )? Huh... o_O
     
  4. Tigerstripe

    Tigerstripe Apprentice Engineer

    Messages:
    479
    They probably decided that last week's changes were causing too much trouble, so they may have simply disabled part of the feature as a workaround to placate the angry players... which gives them time to return to tinkering with thruster damage without the whole community of players crying for blood.

    Ignoring the current grid, but still affecting other grids, would be a good way to stop breaking people's builds, while still retaining some damage effects. So that makes perfect sense.

    Like I said: "temporary". Next week, we might get a new damage model (hopefully, one that works better and is more sensible).
     
    • Disagree Disagree x 1
  5. suicideneil

    suicideneil Apprentice Engineer

    Messages:
    223
    No, that doesn't make any sense to me- you can't design or build a ship if you have no clue how close you can place other blocks to the thruster, your only option is to have no blocks behind the thruster at all for essentially infinite distance, which might make it impossible to work on the ship until the issue is fixed.

    It used to be 3 blocks for small hydrogen thrusters and 2 or 3 for small ions- what it ends up being is anyone's guess.
     
  6. Wicorel

    Wicorel Senior Engineer

    Messages:
    1,263
  7. Arcturus

    Arcturus Senior Engineer

    Messages:
    1,649
    Peeking at the current thuster code, it looks more like an unintentional issue. Perhaps the thruster cylinder physics shape can't collide with shapes that have the same parent due to some deeper Havok magic or such.

    What are we looking at there? Seems like a Rexxar bot posted something.
     
  8. Zhiila

    Zhiila Tester Staff

    Messages:
    487
    We are aware of this bug. It´s caused by locked landing gear. We are still looking for all cases where it happens and working on a fix.
     
    • Like Like x 2
  9. Arcturus

    Arcturus Senior Engineer

    Messages:
    1,649
    I could reproduce the bug by building a ship with a thruster pointing at the ship. There were NO landing gear involved.
     
  10. Zhiila

    Zhiila Tester Staff

    Messages:
    487
    Can you send the blueprint?
     
  11. Arcturus

    Arcturus Senior Engineer

    Messages:
    1,649
    It was just this, but when I retested it today the damage started to happen after a few seconds. Sorry, I guess this doesn't prove anything.
    [​IMG]
    The red block does take damage now if the thruster on the front is pushing for several seconds.
     
Thread Status:
This last post in this thread was made more than 31 days old.