1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Update 1.195 - Sparks of the Future

Discussion in 'Change Log' started by Drui, Jun 24, 2020.

  1. KissSh0t

    KissSh0t Master Engineer

    Messages:
    3,782
    Space Engineers in a nutshell.

     
    • Funny Funny x 1
  2. Capt.SkuLL

    Capt.SkuLL Apprentice Engineer

    Messages:
    152
    is there a way you can make the hinges work on item slots the same way the advance rotor does ?
    like can we have the Hinge be in a single slot and when we use voxel hand and it snaps to a LARGE grid it automatically uses the LARGE HINGE 3x3 and when it snaps to a SMALL grid it automatically changes into a SMALL HINGE ?

    currently it is treated separate.
     
    Last edited: Jul 5, 2020
  3. mojomann71

    mojomann71 Senior Engineer

    Messages:
    2,005
    Would anyone care to show me a picture of said notch? When using the 1x1 hinge I am not seeing a notch so I am still in a crap shoot of if I am placing it correctly on first try.
     
  4. PandaTv

    PandaTv Trainee Engineer

    Messages:
    18
    would like to start a round of questions. who has this problem that when you die the skin is reset by the astronaut or often the tools skin don't apply. I paid a lot of money for skins that don't work properly, do you?
     
  5. Capt.SkuLL

    Capt.SkuLL Apprentice Engineer

    Messages:
    152
    the skin reset to default when you die i think is part of the game. ( not quite sure if you get your skin back once you retrieve your body because i always revert to last SAVE when dead. )

    the tool skins resetting to default - ohhhh dont get me started on this. i even have the one where the main character skin reverts to the default when entering or exiting a cockpit.

    the way i think about this is that it has something to do with this game's reliance on steam servers. this game needed to connect to steam to find out what DLCs we purchased or if we have that skin in our inventory.

    my bet is that every time this said connection/session fails to connect to steam by even just a few seconds it will leave you with the default skins instead.

    the way i figured is because whenever you switch your tools back and fort it refreshes until it finally gets your skins.

    the sad part is, despite these brutal methods keen use against piracy, there are others who were able to pirate the game and with the skins included ANYWAY !

    so in the end its HURTING US who paid for all the DLCs instead of the pirates it intended to hurt.
     
    • Like Like x 1
  6. ButterToads

    ButterToads Trainee Engineer

    Messages:
    5
    Player/tool skins should persist upon death. I mainly play multiplayer on Keen servers and this is how it's always been. However, this has been broken since the last update. Now I am the default red forever. This seems to happen on server disconnect as well.
     
  7. Capt.SkuLL

    Capt.SkuLL Apprentice Engineer

    Messages:
    152
    hmm... i thought it was some sort of DIABLO II mechanic where you lose your items and skins and have to pick em up. anyway i never play MP because i couldn't join any servers ( another game feature )
    so i can verify that its not just the previous update, its been like this since i bought the game 3 months ago. whenever i die i respawn with default skin.
     
  8. PandaTv

    PandaTv Trainee Engineer

    Messages:
    18
    [QUOTE = "ButterToads, Beitrag: 1287116654, Mitglied: 3987092"] Spieler- / Werkzeug-Skins sollten nach dem Tod bestehen bleiben. Ich spiele hauptsächlich Multiplayer auf Keen-Servern und so war es schon immer. Dies ist jedoch seit dem letzten Update nicht mehr möglich. Jetzt bin ich für immer das Standardrot. Dies scheint auch beim Trennen der Serververbindung zu passieren. [/ QUOTE]

    Ök this is a bug
     
  9. PandaTv

    PandaTv Trainee Engineer

    Messages:
    18
    09/07/2020
    Hotfix 195.023

    • Fixed a crash at MySectorWeatherComponent.UpdateWeathersOnClients
    • Fixed a crash at MySectorWeatherComponent.EffectLightning
    • Fixed a crash at MySectorWeatherComponent.ApplySound
    • Fixed a crash at Entities.Blocks.MyPistonBase.UpdatePosition
    • Fixed a crash when loading a world with larger planets
    • Fixed a crash and disappearance of local blueprints when renaming a BP with a "
    • Added functionality where admins with "Untargettable" enabled will not be struck by lightning
    • Updated lightning rod functionality for decoys (Range of protection 50m, changed info and good.bot)
    • Fixed lightning being too agressive and too damaging on DS
    • Fixed the Sun being dimmer and emitting less light when rotation is turned off
    • Fixed Neon Tubes not being emissive on sub-grids



    Do you want to take me in your arms? no fix for astrnout skins ?? but you take money.
     
  10. Ronin1973

    Ronin1973 Master Engineer

    Messages:
    4,964
    They haven't fixed the dead engineers despawning once they are liberated from grids they are attached to. So I keep showing up to the location of the Mayday wreck and seeing this. THIS! :)
    [​IMG]
     
    • Funny Funny x 1
  11. MrBeeMonster

    MrBeeMonster Trainee Engineer

    Messages:
    16
    *Fixed lightning being too aggressive and too damaging on DS

    Thank you so much, maybe make it strike the highest points that way we have to build lighting rods?
     
  12. mojomann71

    mojomann71 Senior Engineer

    Messages:
    2,005
    @MrBeeMonster that is why they state to use Decoy blocks...aka new lightning rod... :D
     
  13. EdwardG

    EdwardG Trainee Engineer

    Messages:
    3
    Hi,
    My programmable blocks were working fine until the Frostbite update and they quit working, the buttons when you went into the console were not being recognized as buttons and did nothing. Then the Sparks update came along and they worked again. NOW with yesterday's update (Hotfix 195.023) you managed to break them again and they no longer work.
     
  14. AndreyKl

    AndreyKl Trainee Engineer

    Messages:
    25
    Thanks!

    They actually weren't fixed. They sometimes work, sometimes they don't. There is a workaround to make them work, quote from here: "If I press and hold one mouse button on a button, then click the other MB, focus is removed from the textbox and the buttons work again normally"

    There were complains about this issue, but it doesn't seem to be worked at:
    https://support.keenswh.com/spaceengineers/pc/topic/stuck-in-editor-of-programmable-block
    https://support.keenswh.com/spaceengineers/pc/topic/programable-block-editor-hangs-hotfix-1-194-082
     
  15. Ronin1973

    Ronin1973 Master Engineer

    Messages:
    4,964
    The console block is now showing full-sized projections rather than mini-projections. I noticed this while on a 100% vanilla server.
     
  16. DLR

    DLR Trainee Engineer

    Messages:
    9
    After the silent update a couple days ago Many of my spot lights are on with maxed setting yet produce No light depending which way I turn my head.
     
  17. KissSh0t

    KissSh0t Master Engineer

    Messages:
    3,782
    Out of curiosity what was actually causing this?

    If any of the devs could comment on this that would be really cool,
     
    Last edited: Jul 14, 2020
  18. Sarekh

    Sarekh Senior Engineer

    Messages:
    1,200
    Dunno what you guys did there but I have been able to play for the first time since the Frostbite Update without the game freezing to hell and back. I am delighted!
     
  19. Roxette

    Roxette Senior Engineer

    Messages:
    1,546
    That may need to wait until the next update: "Frostbite 2 - Hell Freezes Over" :D
     
    • Funny Funny x 1
  20. KissSh0t

    KissSh0t Master Engineer

    Messages:
    3,782
    [​IMG]
     
  21. TuxHomer

    TuxHomer Trainee Engineer

    Messages:
    1
    Hi,
    since the last patch(195.024) i got performance issues.

    My dedicated server, no player connected:
    [​IMG]

    and on my PC i got "Scene too complex" and "Performance issues" warnings.
     
    Last edited: Jul 14, 2020
  22. KissSh0t

    KissSh0t Master Engineer

    Messages:
    3,782
    Report this over here : https://support.keenswh.com/
     
  23. SileniusFF

    SileniusFF Apprentice Engineer

    Messages:
    116
    Yay! Been waiting this for a long time. After quick testing no more freezes.
    Happy engineer here :pbjt:
     
  24. EdwardG

    EdwardG Trainee Engineer

    Messages:
    3
    Is there an ETA to fix the issue with fog inside an airtight space on a foggy day??
     
  25. Spaceman Spiff

    Spaceman Spiff Senior Engineer

    Messages:
    2,029
    Just imagine your ship or station being at the center of some horror movie. Or maybe someone burned the pizza that was in the oven. Or not.
     
    • Funny Funny x 1
  26. mojomann71

    mojomann71 Senior Engineer

    Messages:
    2,005
    SOONTM
     
  27. EdwardG

    EdwardG Trainee Engineer

    Messages:
    3
    I could just go with my wife was cooking again.
     
    • Funny Funny x 1
  28. OMGvert

    OMGvert Trainee Engineer

    Messages:
    5
    Large Hinge...


    Small Hinge...
     
    • Agree Agree x 1
  29. mojomann71

    mojomann71 Senior Engineer

    Messages:
    2,005
    @OMGvert Thanks! :beer:

    For a little while there I was just over looking the ones on the 1x1's *facepalm*
     
    • Like Like x 1
  30. smokingwreck

    smokingwreck Trainee Engineer

    Messages:
    7
    alrighty id like to say AMD player here , NEVER had freezing issue

    UNTILL the patch to fix AMD's freezing , and now I desync/Freeze 1-4 times an hour ........

    only entier reboot-full closing and restart of game connects me again , many times i can stay ingame and chat , I just cannot interact with anything or move ..