Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[0.6.3] Player spawn and ghost problem

Discussion in 'Bug Reports' started by B1ackBoX, Jun 3, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. B1ackBoX Trainee Engineer

    Messages:
    7
    On DS I've got a player that has encountered a bug after he once died in the woods.
    He started to be respawned several times in an area were he's not got stuck with 8 ghosts of himself. (area Levos B1, J10)
    Every time after that, first time he joins game he spawns there without inventory and unable to more, even though he logged of at a completely different area in kingdom. and has to re-logon to world a 2nd or 3rd time to spawn at home/were he last logged of, with his inventory intact and able to play normally.
    He can travel all over the planet, but as soon as he comes near to walk across into the border of the area Levos C2, he suddenly spawns with no inventory at Levos C2, D3. looking at another ghost of himself (wich everyone else can see even if he isn't logged on) but we can't se the verion of him he controls end sees himself and he's unable to interact with anything. a few moments later his client crashes and he gets the "send crashlog" box.
    Next time he logs on, same procedure happends...

    I've tried to delete his player profile file in the saves restart server and when he logs on, he's still stuck going throught the process. Only change is that now he is without the researchprogress and inventory that was saved in the player profile file.
    He also gets an error message that pops up when he joins, but it's too fast for the screendump to catch, so he made a photo with camera instead, will add it as soon as I get it.


    I've got his logs from last time he tried to travel to the area Levos C2,
    and I add server log and world save and his player savefile from server as well.
    His logs:
    https://docs.google.com/document/d/1xXWCikjJ4lkLKr2eZC7ghEOlvLy4mnBAOKFNz2yWF60/edit?usp=sharing
    https://docs.google.com/document/d/1yx1ulvC_2VLF22J9gIeH8szzpPIyrsqThwXukUS6dgE/edit?usp=sharing
    Server World
    Log:
    https://www.dropbox.com/s/5l6m6w3dgzkpuvi/MedievalEngineersDedicated - 20180603 -RegardingPlayerGhost.log?dl=0
    Player savefile: https://www.dropbox.com/s/00orn0gylr3npv9/76561198441509801.player?dl=0
    World: https://www.dropbox.com/s/5vhz2tvdqp6hc1k/2018-06-03 201112.7z?dl=0

    Pictures:
    One of the ghosts, at Levos C2, D3 still standing and unable to be killed even after server restart and user hasn't logged on https://cdn.discordapp.com/attachments/441339265763377159/452907338060267530/unknown.png
    In forest at Levos B1, J10 I can only see 4 ghosts, but he sees all 8 when he logs on
    https://cdn.discordapp.com/attachments/441339265763377159/452908657483448331/unknown.png
    Picture of errormessage he gets on screen when he logs on (he forgot to turn of flash, but should be somewhat readable):
    https://photos.google.com/share/AF1...?key=bGVIcXFzYnJIeFJ1cXptMGRudW14bk1iOFpncFJB
     
    Last edited: Jun 3, 2018
  2. I23I7 ME Tester

    Messages:
    3,827
    Does the issue happen as well without the mods there seem to be around 51 mods so i was wondering if the issue could be caused by one of them since this is the first time i hear about an issue like this.
     
  3. B1ackBoX Trainee Engineer

    Messages:
    7
    Have not tried the server without the mods as it would break lots of things built.
    And for everyone else it seems to be no problems at all, I tried myself to provoke same error to happen for myself when playing, and was unable to recreate it.

    Server runs (all things considered) smoothly at usual 1.0 sim, with the usual drops at joins/exits and backups, and barely any cpu load (5-10% load with 7-14 people on), and ram use varies but has been stable at max ~17gigs with 14 people on.

    He's the only user that has happened with. The first time this happened to him, the death that made all this issues he's been having, happened about a week and a half ago.
    He said he was in area around Levos C2, D3 hunting deer, when he just out of nowere died and the respawning/ghosting started.
    I've been trying since, everything I could possibly think of to find out what's cousing this.
    I'm no expert, but I've even been reading through the save file section by section to see if there was anything wrong, but couldn't see anything out of the ordinary regarding his user id compared to other user id's.
    Last night, after another wipe of his playerprofile save file even all the copies from all backups on world also, he got a normal spawn in world when he entered, but the ghosts are still there.
    But now his claims won't recognize him as owner somehow, as if his user id has changed somehow.
     
    • Informative Informative x 1
  4. I23I7 ME Tester

    Messages:
    3,827
    @CptTwinkie Anything like ever happened to you?
     
  5. CptTwinkie Master Engineer

    Messages:
    4,458
    Yeah....that's a mod. Only a modder would catch an exception and write it to the screen
     
  6. B1ackBoX Trainee Engineer

    Messages:
    7
    Wouldn't such an exception show up in the savefile with multiple simultanous spawnpoints/ghosts/shaddows (not sure what to call it), for that user id?
    if so, would deleting those fix the problem?

    Strange is that only one user is affected by it, while other users have died from falling trees and falling down from buildings and cliffs and other things, and his user just died for no apparent reason..
     
Thread Status:
This last post in this thread was made more than 31 days old.