Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.035.009]Merge block causes CTD and stops Dedicated Server

Discussion in 'Bug Reports' started by Andon, Jun 20, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Andon Senior Engineer

    Messages:
    1,305
    Went in to my server after updating it, to see if the fix for the "Y" crash bug actually worked. Apparently now it's worse, because simply merging caused both the client to Crash to Desktop and the server to shut itself down.

    I haven't done any testing, but this is the entirety of what I did:

    1: Log into Dedicated Server
    2: Jump into cockpit of ship docked to station.
    3: Undock ship from station.
    4: Pull ship back about 3m from station
    5: Turn Merge Block back on.
    6: Turn off Inertial Dampeners (I find this leads to a smoother docking, plus it doesn't torch things around the ship)
    7: Push ship into merge block
    8: Enjoy the crash!
    9: Go check Dedicated Server, see it's shut itself off (Press Any Key to close window).
     
  2. TheMap Trainee Engineer

    Messages:
    87
    Confirmed
     
  3. Kienata Apprentice Engineer

    Messages:
    118
    Confirmed.
     
  4. D4rk4ng31 Junior Engineer

    Messages:
    526
    Yep, confirmed. Not possible to merge large ships.
     
  5. Anthropy Trainee Engineer

    Messages:
    91
    Confirmed; can't dock my welding/grinding module to my small ship without crashing all clients to desktop, and the dedicated server.
     
  6. Hasbinbad Apprentice Engineer

    Messages:
    205
    i have been getting crazy crashes .. came here looking for a reason.. i'll ask players if this preceded crashing.
     
  7. garisat Trainee Engineer

    Messages:
    31
    Confirmed
     
  8. fused Trainee Engineer

    Messages:
    92
    Confirmed. Made a report about this for Offline mode as well.
     
  9. Kielm Junior Engineer

    Messages:
    507
    Ooooh Yes. CTD for all clients and server crash on first use of merge block.
     
  10. The Voivode Trainee Engineer

    Messages:
    35
    Confirmed.
     
  11. Sibz Apprentice Engineer

    Messages:
    361
    Yup had this on my server also
     
  12. duckylam Trainee Engineer

    Messages:
    5
    Confirmed on my server as well.
     
  13. stonefisher Trainee Engineer

    Messages:
    11
    Tested and Confirmed. Same results in both single and multiplayer in creative and survival mode.

    Small ship to small ship merge = no crash

    Large ship to Large ship merge = no crash

    Small ship unmerge from small ship = no crash

    Large ship unmerge from Large ship = no crash

    Large ship unmerge from station = no crash

    Convert station to large ship = no crash

    Large ship merge with station = CRASH TO DESKTOP



    Looks like its the act of converting a ship to a station that makes it go splat.
     
  14. Raelsmar Trainee Engineer

    Messages:
    48
    This happens in single player as well with small ship to small ship merges (certain ones). I can get one small ship to merge to another but cannot get those merged ships to connect to a third small ship.
     
  15. Andon Senior Engineer

    Messages:
    1,305
    I haven't had any issues with small merge blocks in single player, but haven't done extensive testing
     
  16. Phand Master Engineer

    Messages:
    9,650
    Hi,

    thank you for very nicely done report. I will check it right now. :)
     
  17. NovusNecrontyr Trainee Engineer

    Messages:
    72
    Phand is here to the rescue! <3
     
  18. eldarstorm Junior Engineer

    Messages:
    725
    Ships previously Merged to station are able to undock and redock without crash.
    New ships that have not merged before does seem to crash every time.

    The three ships I have that can dock are starter ships that were docked before the update.
    The ship that crashes the server is a ship built from scratch that has grinders on it. (Ship was build before the update, but never had a merger block)
     
  19. Andon Senior Engineer

    Messages:
    1,305
    Original report was with a ship I undocked then immediately tried to redock. Scratchbuilt small utility ship
     
  20. Phand Master Engineer

    Messages:
    9,650
    Hi,

    thanks to another player I was able to reproduce merge block crash, but it was crash during merging ship to ship. It is fixed internally and it may also solve this issue. But I am NOT SURE. So please do not take my word for granted. If you could provide world file right before the crash I would be able to check whether it is the same issue or not. If not it may be fixed right away in such world. ;)
     
  21. Andon Senior Engineer

    Messages:
    1,305
    In making sure this was reproduceable on my world, I came across another bug. I turned off the merge block to undock the ship... and the now-separated ship vanished. Just, gone. THIS was a reproduceable thing - Every thing on my station that I turned off merge blocks for simply disappeared. I'll PM you the world file and some instructions on how to reproduce that.
     
  22. Peter Bauer Trainee Engineer

    Messages:
    3
    I've been getting this bug also, on my own server. I can unmerge small and large ships just fine. As soon as I merge any ships, the game crashes and I get the Steam Error Reporting window.
     
  23. Phand Master Engineer

    Messages:
    9,650
    Hi,

    I am not a super human it is in the que.
     
  24. Andon Senior Engineer

    Messages:
    1,305
    I haven't seen that issue in 1.036, so I THINK it's resolved
     
  25. D4rk4ng31 Junior Engineer

    Messages:
    526
    Hey :)

    Bug not solved. Still persist.

    Took a Respawnship, docked it to a station. No problems. Grinded the two merge blocks.

    Took another respawnship and tried to dock at the first one (not longer a ship, cause docked to a station before)

    .. result: Crash.
     
  26. Andon Senior Engineer

    Messages:
    1,305
    That's an issue related to grinding down active merge blocks, I think. Not quite the same as the original posting, although it can be similar. Does it persist if you turn off the merge blocks first?
     
  27. D4rk4ng31 Junior Engineer

    Messages:
    526
    You're right Andon,

    - Built a stationblock with merger.
    - Docked the Respawnship (works)
    - turned off the merger
    - grinded the merger
    - Took another respawnship and built a merger on it.
    - Docked to the first respawnship, now station (works)
    - grindet the merger without turning off
    - Took a third ship
    - Built the merger
    - Docked
    - CRASH
     
Thread Status:
This last post in this thread was made more than 31 days old.