Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.100.024]-[1.102.009] Autopilot does not trigger functions on last checkpoint (One Way)

Discussion in 'Bug Reports' started by VenomBG, Sep 20, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. VenomBG Trainee Engineer

    Messages:
    31
    The issue occurs when the Autopilot (flight mode set to 'One Way') reaches its final checkpoin.

    When an autopilot guided ship reaches it's final destination and its 'Flight mode' has been set to One way, it can be noticed that the commands set to be activated on the final checkpoint will not be executed.

    Note 1: Upon reaching its final destination the ship will start spinning out of control.

    Note 2: The issue occurs for both small and large ships.

    Note 3: The Autopilot Turns Off upon reaching its final checkpoint (As it should be).

    Note 4: The issue DOES NOT occur when the 'Flight mode' has been set to 'Patrol' or 'Circle' and the commands on each checkpoint are executed properly.


    Note 5: The issue occurs in both 'Survival' and 'Creative' modes.

    Note 6: Reinstalling the application DOES NOT fix the issue.

    Note 7: Tested only on Win 7 and 8.1 for now - occurs on both.


    Repro Rate: 100%
    (At least for me)

    I've tried it on several different worlds including a new, empty world (no mods), after creating a small and large ships from scratch.

    Reproduction steps:


    1.Set up a simple ship with a remote control.

    2.Set the Flight Mode to 'One Way'

    3.Create 1 or more checkpoints and add them to the Remote Control block.

    4.Set up an action/actions on the last checkpoint.

    5.Notice that upon reaching the last checkpoint the commands will not be executed and the ship will start spinning out of control.



    Here is an example world:
    https://www.dropbox.com/s/nl3ol9mtci7uroe/Auto Pilot Bug.zip?dl=0


    Here is an example video:

    I've made a simple set up with a Remote Control going through 3 Checkpoints - A, B, C as follows:

    A - Spotlight On
    B - Spotlight Off
    C - Spotlight On

    As you can see, the commands on A and B are activated properly, but as soon as the ship reaches C, it goes out of control and the Spotlight is never switched On.



    PP

    I didn't find anyone that has reported this bug yet, so hopefully it's not a dup.

    Cheers!
     
    Last edited: Sep 21, 2015
  2. jhorro Trainee Engineer

    Messages:
    63
    Yes it happend to me too. It must be a bug.
     
  3. VenomBG Trainee Engineer

    Messages:
    31
    Can anyone else confirm if it's happening to them as well? If it happens only to us 2, I will try reinstalling the game after i come back from work and see if it fixes it.
     
  4. jhorro Trainee Engineer

    Messages:
    63
    If it happens only to us it's going to be Bulgarian problem. :)
     
    • Like Like x 1
  5. izak Trainee Engineer

    Messages:
    2
    Hi, From South Africa not just an Bulgarian issue ;)

    Same issue, is annoying when you trying to dock and it starts spinning and smashes every thing to bits.

    Does the same in Survival.

    Over View of my problem.

    Two Remote Block
    1. To Dock (RD)
    2. Away from Dock (RA)

    On approach I have (RA) on 4 way points "one way" each of the way points it perform it's actions perfect at the last way point, it is set to lock the Connector and start Timer Block (1:00) that will Switch off Connector and start (RA).

    How ever at the end of all the way points just while in the magnetic area (Yellow) of the connectors, the auto pilot shut off does not connect the Connectors and start to make 360 degrees spins .

    I have tried this on Small and on Large ship with the same result.

    If I'm being stupid let me know I can upload the Large drilling ship if you want to look at the configurations.

    Kind Regards
    Izak Scheepers

    "Copied from steam forum"
     
  6. izak Trainee Engineer

    Messages:
    2
    I have to mention this happened just when the future (Auto Pilot) was released aswell not sure if them tampering with the setting messed it up.
     
  7. VenomBG Trainee Engineer

    Messages:
    31
    Hey Izak!

    Yes, i discovered the problem while i was testing my drone and got the exactly same result when it tried to dock.

    I presume it is a global issue but maybe not a lot of people discovered that it's a problem with the Autopilot, cause at first i thought that one of my Overdriven Gyros was causing it. And maybe the ones that did are not active on the forum.

    Anyway, I tried reinstalling the game today and it DID NOT fix it. So I'm guessing, it's either a global problem and we don't know it yet or a compatibility issue that we are having.
     
  8. xander.huter Trainee Engineer

    Messages:
    42
    Hi there,

    I guess the autopilot routine have to be completely reprogrammed. I checked out the new "improvements" but the autopilot function not works also in the official KSH example world -> docking small ships.

    I tried out the function the hole last weekend but overall the autopilot does in most of the time do what he want, and not what I'm ;-)

    -> Problem in precission Mode : the ship reaches a waypoint -> can't exact hit the waypoint and turning around rolling and so on for "ever". The autopilot can't continue because it hits never the waypoint. I check that out many times yesterday with multible waypoint setups but nothing changes.

    Also the autopilot flys every time with maximum ship speed (without precission and collision secure). Result -> often the ship flys many many miles to far and passes a waypoint (ship can't brake in time) . The Autopilot needs a speed limiter. That's a must have.

    -> The Autopilot must record the hole ship position from GPS (axis/roll and direction so on) not only XYZ. Until now a exact positioning of a autopilot remoted ship is not possible. -> Need for loading undloading processes.

    Overall until now I think the autopilot is not realy usefull. Too many basic Autopilot functions are not realized.

    Greets

    xander
     
  9. VenomBG Trainee Engineer

    Messages:
    31
    Yeah, there are a lot of issues with the Collision Avoidance function too, but Keen will get around to fixing them, no worries :) I'm sure they were just really in a hurry to release update 1.100 and surprise us :)
     
  10. xander.huter Trainee Engineer

    Messages:
    42
    Hi Venom,

    Yes I think also, that Keen will bring it to right way. It's to early to realize all sugesstions and have a look to fix the bugs. I think its better the Game-Kernel will run as stabel as possbile and then we could have a look for advances.
     
    • Like Like x 1
  11. jhorro Trainee Engineer

    Messages:
    63
    and here is the log
     
  12. VenomBG Trainee Engineer

    Messages:
    31
    I read in the update that the Autopilot's performance has been improved but i guess they haven't gotten to fixing this, cause it still happens to me :/
     
  13. xander.huter Trainee Engineer

    Messages:
    42
    Hi Again,

    I think about the remote functions as well it is more important as somebody think about, and I think it's a minor function for SE. It seems that SE will going to more and more PVP. That's could be a ballancing problem in survival mode.

    On one hand side, you have to create and build massive warships on the other hand you need many many resources to build them. Result: You have to create a functionally production logistic. If you haven't a big team (Online) you have problems.
     
  14. xander.huter Trainee Engineer

    Messages:
    42
    Hi Venom,

    autopilot is actually no longer a problem for me, because the new update brings many many new Problems, elemantary gameplay problems. That is what a absolutly hate. Means many spended hours of creating my world are for nothing :-(

    I won't creating a new game after each update. Long used mods not longer usable and so on. That's b**l s**t. Sorry.
     
  15. Azzzie Trainee Engineer

    Messages:
    3
    I am reporting and confirm this problem too. Update 01_101_020 didnĀ“t fix it. *thnx*
     
    • Like Like x 1
  16. VenomBG Trainee Engineer

    Messages:
    31
    waiting and wondering if it would be fixed in update 102 :)

    ***EDIT***

    Yeah, checked right after the update came out and confirm it's still happening in v 1.102.009
    At this point I consider that keen know about it and will fix it at some later point. Shame we can't get any drones working until then tho :p
     
    Last edited: Oct 2, 2015
  17. VenomBG Trainee Engineer

    Messages:
    31
Thread Status:
This last post in this thread was made more than 31 days old.