Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.125] hydrogen thrusters will not light

Discussion in 'Bug Reports' started by Tigerstripe, Mar 16, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Tigerstripe Apprentice Engineer

    Messages:
    479
    So... I was in creative mode, building a new large ship this evening... one with some hydrogen thrusters as boosters to improve performance.

    I built the ship frame, with batteries and reactors for power. Over 50 MW to start with...
    I built my thrusters, attached to the conveyor network; they turned off immediately. Okay, fine... they must need to be connected to filled hydrogen tanks, I figured.
    I built hydrogen tanks, with oxygen generators directly attached to their ports, and linked that to the thrusters with more conveyors. I watched the tanks fill up to 100%.
    Still, none of my thrusters would light.

    I made certain the tanks were full of hydrogen.
    I made certain there was plenty of power.
    I made certain the thrusters were properly conveyored to the tanks.
    I have active gyroscopes, and a Flight Seat set to control thrusters.

    I put all the hydrogen thrusters in a group, and toggled it on and off a few times.
    I waited a while to let them light... but they never lit up.
    I tried flying the ship, but still no hydrogen thrust.

    I attached two large reactors for massive power production. Nothing.

    I tried deleting some of them and replacing them, but the new ones just flicked off an instant after being placed too.
    I made certain the entire ship is owned by me.

    There are no scripts running on that ship. Nothing to constantly flick the thrusters off.
    Even the GUI says the thrusters are all on.

    So WHY won't any of them light?!?

    Try as I might, I could not get a single hydrogen thruster on this new ship to activate.
    Yet, just a hundred meters away, sits a ship I pasted in from the workshop, bristling with hydrogen thrusters, all lit and functioning normally.


    I can only conclude this is some sort of bug, affecting hydrogen thrusters when they're placed in creative mode. Maybe they'll light up when I load the world back up tomorrow after work... but I won't have the time to test that theory until then.
     
    Last edited: Mar 16, 2016
  2. Mannorot2015 Apprentice Engineer

    Messages:
    140
    ownership set on every block?
     
    • Agree Agree x 1
  3. EstebanLB Trainee Engineer

    Messages:
    62
    Try dismantling the thruster and building it again, but AFTER you have all connection already built. It happens to mee too
     
  4. kcjunkbox Senior Engineer

    Messages:
    1,130
    happened to me today as well, I cut and pasted the ship and the new ship lit up and stayed lit
     
  5. Tigerstripe Apprentice Engineer

    Messages:
    479
    Both are in the above list of things I tried, so yes & yes.
     
  6. Robotnik V Apprentice Engineer

    Messages:
    382
    From what you've said it looks like it’s not an issue with the world or game itself, but a bug with the ship. I would try merging the ship to a static grid and/or renaming the ship. Basically the bug is affecting that grid alone so changing the grid ID may fix it.
    Once upon a time I also had this bug but it just went away after a little while...
     
  7. Tigerstripe Apprentice Engineer

    Messages:
    479
    I'll try Cut and Paste next time I'm in the game. See if that reboots the engines, like kcjunkbox said fixed it.
    That was the next thing i was gonna try anyway, so good to hear I may be on the right track.

    But yeah, this probably shouldn't be an issue at all, so a ship bugging out like this is probably something Keen should look into sometime.
     
  8. kcjunkbox Senior Engineer

    Messages:
    1,130
    They certainly should among other things
     
    • Agree Agree x 1
  9. Mannorot2015 Apprentice Engineer

    Messages:
    140
    I had a very similiar problem long ago and here is the old thread http://forum.keenswh.com/threads/1-...problem-client-singleplayer-creative.7373788/
    perhaps related.
    In my old case the thrusters (iron at that time) behave as if they had no energy. It resolves by simply waiting or relaoding.

    Later i had a similar problem with hydrogen thrusters. In that later case the grid was soemhow interrupted. That means the hydrogen could not be transported via the conveyor to the thruster for they were two grinds somehow. I had to merge them and it worked. look for the conveyor system and see if it transport other things.
     
Thread Status:
This last post in this thread was made more than 31 days old.