Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version [Extra] --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.172 stable MP] Ship becomes invisible and uncontrollable after merge.

Discussion in 'Bug Reports' started by Roxette, Feb 14, 2017.

  1. Roxette

    Joined:
    Jul 18, 2014
    Messages:
    534
    Trophy Points:
    102
    Standard practice on MP servers to use a merge block to prevent spawnship loss. As soon as the ship is merged, it becomes invisible and uncontrollable. The same effect seen when mergeblocks are subsequently used to bond two ships.
     
  2. hlws Tester Developer

    Joined:
    Aug 1, 2016
    Messages:
    260
    Trophy Points:
    57
    Hi,
    I was not able to reproduce the issue. I was trying to merge big ship to the station, big ship to each other but the bug didn't occur. Please can you give me more info about circumstances when the bug is happening. Is it after relog?
    Thank you very much for your feedback :)
     
  3. Roxette

    Joined:
    Jul 18, 2014
    Messages:
    534
    Trophy Points:
    102
    I've experienced this on multiple mod-free servers now, when using the merge block on the spawnship for the first time as a new player to prevent spawnship deletion on disconnect. I've also seen it when merging two small ships. I will see if I can produce the same effect on a local game so I can generate logs and have a save available.
     
  4. hlws Tester Developer

    Joined:
    Aug 1, 2016
    Messages:
    260
    Trophy Points:
    57
    Thank you very much for additional info, I will try it more :)
     
  5. striker_lord

    Joined:
    Apr 22, 2014
    Messages:
    162
    Trophy Points:
    132
    We have experienced some situations where a ship became "uncontrollable" with different symptoms and requisites for the bug:
    1. small ship with landing gear on large ship (not seen since latest updates) - when the small ship is connected to a large ship the large ship is permanently uncontrolable, you are able to "slightly" move it with gyros, but it will always go back to the original postion.
    - unlocking the ship doesn't help
    - Server instance needs to be rebooted.

    2. Activating "Main cockpit" setting makes the ship go in to "Autopilot" mode, there would be no way to turn it off and only by a server restart was it gone, untick the main cockpit and it would never happen. It didn't matter if you didn't have a controll block on the ship :).

    you state they become invissible and uncontrollable, could you explain a bit more in detail?
    I have seen an asteroid become invisble in the last update, but it came back when i got it out of my view range and back (we had our base in that asteroid so i had to :))
     
  6. 1stBiker

    Joined:
    Feb 4, 2017
    Messages:
    11
    Trophy Points:
    1
    I can confirm what striker_lord has reported.
    My Ship has 3 Landingears but sometimes one of those cannot be controlled. Sometimes Ship also cant be controlled from the cockpit. And sometimes there's this "Autopilot" - Message on the screen.

    Loging off/on helped sometimes, but its really strange and its solution not reproducable.
    But, I also have a little mining Drone connected to the BigOne (Connectors not Mergeblocks) and I'm now going to check if this has any influence.

    EDIT:
    I also constantly face this "this Terminal is not connected to a ship" issue :\
    And there are others playing on my Server, the Autopilot +alittle Mousemove almost caused a heartattack

    EDIT2:
    the problem was not because of the second ship, but because I used a second panel to unlock the landing-gears - this caused the "Autopilot activated" .. well .. not everytime
    -> unlocking the Gears from the MainConsole worked instead
     
    Last edited: Feb 27, 2017
  7. Ronin1973

    Joined:
    Feb 17, 2015
    Messages:
    3,986
    Trophy Points:
    207
    Was there an admin present while you were trying to merge? I've had a bug where when checking players activities via Space Master, my POV gets latched to their flight seat and nothing could be done until they exited the flight seat.
     
  8. 1stBiker

    Joined:
    Feb 4, 2017
    Messages:
    11
    Trophy Points:
    1
    nope, I am the Admin on my Server
    and there was possibly just one more person playing at this time .. as mentioned, if I do the actions (unlock gears) from the main-console, its working .. almost .. at least I never read the "autopilot active" ever again since then

    +thanks for your input
     
  9. Roxette

    Joined:
    Jul 18, 2014
    Messages:
    534
    Trophy Points:
    102
    Still happening on 01.178.3
     
  10. Roxette

    Joined:
    Jul 18, 2014
    Messages:
    534
    Trophy Points:
    102
    Still happening on 01.179.1
     
  11. Roxette

    Joined:
    Jul 18, 2014
    Messages:
    534
    Trophy Points:
    102
    Still happening on 01.180.0
     
  12. BlackColla

    Joined:
    Jan 18, 2017
    Messages:
    3
    Trophy Points:
    1
    i'm not sure where to post but this seems a bit similiar.
    i've build a big ship with 2 cockpits(i don't thinkt the rest matters).
    after a while with 2 players sitting in the cockpits we were facing some troubles where the main cockpit, where i'm as the builder was sitting in, becomes unavailable while the second player was in the secondary cockpit.
    i left the ship und reentered it immidiatly and the ships was telling me "the ship is already used by another"(a message like this^^).
    i kicked out my friend and NOW the ship is completely uncontrollable. in the first hour the ship was telling me that the autopilot was turned on(i've never installed one(and was installing one for removing proposals but it didn't solved the issue)) and i had no control.
    after welding it down, building it up again i got controll but soon my friend entered his cockpit i lost controll again. nothing helped. i'm playing currently on a open server soo i don't be able to restart just for testing.

    my question is: is it a known bug where you will loose the controll of your ship while 2 cockpits are in use?

    EDIT: i'm able to steer the ship directly via gyros and overriden controls... but still unable to fire the engines via wasd, so the cockpit seems kinda broken ...
     
    Last edited: Jul 24, 2017