Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.180.0 + 1.180.1] Eye adaption - Really messed up lighting

Discussion in 'Bug Reports' started by Syncaidius, Apr 14, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Syncaidius Junior Engineer

    Messages:
    824
    I'll let the video do the talking:



    Sun rotation is off. I have no idea what is going on but the lighting is really fudged in 1.180.

    Even on planets, it behaves in the same way.
     
    • Agree Agree x 3
  2. Xaaeon Trainee Engineer

    Messages:
    3
    I'm having the exact same issue. You have an AMD card?
     
    • Agree Agree x 2
  3. Syncaidius Junior Engineer

    Messages:
    824
    Yep. It's an XFX R9 390 DD black edition with 8GB VRAM.
     
  4. slader1997 Trainee Engineer

    Messages:
    86
    this is not unique to AMD. im running a msi gtx 770 oc edition and im having the same problem.
     
    • Informative Informative x 2
  5. wooley2000 Trainee Engineer

    Messages:
    5
    Hello I found out that it has to do with LCD's. If you delete all LCD's the lighting bug goes away. The developers know about it so I hope soon that there will be a fix.
    Im not playing right now until there is one. Sorry to let you know. Cheers
     
    • Informative Informative x 2
  6. Leonexis Trainee Engineer

    Messages:
    38
    This issue still exists with the .020 hotfix (RX-460 2GB)
     
  7. DopePope Trainee Engineer

    Messages:
    64
    RIP SE
    12 ft under
     
  8. GamerKhjin Trainee Engineer

    Messages:
    2
    I am having the same problem too. I am running windows 10, graphics cards are AMD Radeon HD 6530D and AMD Radeon HD 6570 running on Dual Graphics mode.
    I had to roll back my patch to 1.179 to get rid of the flickering. I have not tried removing all the LCDs though since I need them for my grids.

    Edit:
    Before I saw this thread, I tried reinstalling my drivers and updating them and windows to latest updates. I have also tried changing the graphics settings from low to high both in-game and directly on my cards and nothing worked.
     
  9. Syncaidius Junior Engineer

    Messages:
    824
    Seems the latest hotfix improved it a bit. Now it only happens if I zoom in close to the ship I'm flying.



    EDIT: Sometimes it doesn't happen at all. Big improvement, but still needs fixing... :p
     
    Last edited: Apr 15, 2017
    • Agree Agree x 1
  10. NameNumber2 Trainee Engineer

    Messages:
    6
    LCD panels are causing this bug, any LCD panel attached to a ship will make this MESS of a shadow... I'm not sure, but it might be linked to the light they give off. Removing them from the station will solve the problem.
     
    • Informative Informative x 1
  11. Scorpion_1 Trainee Engineer

    Messages:
    2
    If you dont want to remove LCDs you can try F12 -> render -> environmen ambient and reduce diffuse factor and specular factor to 0 or go to Program Files\Steam\steamapps\common\SpaceEngineers\Content\Data find Environment.sbc and do the same with <AmbientDiffuseFactor>1.0</AmbientDiffuseFactor> and <AmbientSpecularFactor>1.5</AmbientSpecularFactor>
     
    • Informative Informative x 1
  12. GamerKhjin Trainee Engineer

    Messages:
    2
    I can not access the F12 menu so I did the file change. It did not work for me as the problem came back a few minutes into the game.

    I have also tried removing the LCDs however the colors look washed and too metallic. The flickering is still there, only that this time there is only a light shadow being cast instead of the really dark shadow shown in the original post.

    I will be rolling back for now. =) Keep working on it devs! You can do it!
     
  13. Tigerstripe Apprentice Engineer

    Messages:
    479
    Also occurring for me as well.

    It happens continuously whenever outside cockpits, when viewing from inside the cockpits... but only once when in 3rd-person view from a cockpit.
     
  14. Syncaidius Junior Engineer

    Messages:
    824
    Bump. Just to make sure this isn't missed.

    As mentioned by others, LCDs seem to be the cause of the rave lighting. It gets pretty crazy.
     
  15. ClydeMcDoogle Trainee Engineer

    Messages:
    1
    Just wanted to mention, that I too have this problem, and, I can verify it is indeed with the LCD's because, when I place them down, shadows flash on and off. Bright to dark. Tried turning off shadows completely, but, lighting still goes dark, like, every second or so.

    The problem is also with corner LCDs, just to put that out there.
    I have some mod (clear LCDs) though, and they don't appear to cause this issue, strangely enough.
    Hope this can be fixed soon.
    Thanks in advance.
     
  16. Jawastew Trainee Engineer

    Messages:
    11
    I also have this problem. It is very irritating.
     
  17. Tigerstripe Apprentice Engineer

    Messages:
    479
    I can't confirm the issue is LCDs, because it's occurring for me even in places far from any LCD... particularly when I look around, or strafe my character to the RIGHT (but almost never when strafing to the LEFT, for some bizarre unknown reason).

    At night, the eye adaptation is not simply bright & dark, but faintly (but noticeably) shifts color from blue to green to black to normal gray, over and over.

    Standing still, indoors, even when LCDs are visible, the problem doesn't occur, unless I open the terminal or pause for the menu.
    If I have a view of the sky though, it happens continuously all night, even when standing perfectly still.
    But during the day, it usually only happens when moving, or looking from bright spots to shadows.

    I suspect the whole issue could be temporarily fixed by disabling eye adaptation, but I don't see any option for it in the settings. Does anyone know if eye adaptation can be disabled? Or maybe a mod that disables it?
     
    Last edited: Apr 20, 2017
    • Informative Informative x 1
  18. Syncaidius Junior Engineer

    Messages:
    824
    Bump. -Snip-

    EDIT: Just noticed a dev/tester replied to another similar thread. So at least Keen is aware.

    EDIT 2: Its fixed in update 1.180.1.

    EDIT 3: Nope. its worse now....
     
    Last edited: Apr 20, 2017
  19. Tippin Trainee Engineer

    Messages:
    36
    Lucky you, not fixed for me.
     
  20. Syncaidius Junior Engineer

    Messages:
    824
    Yeah. Finally got around to playing properly, only to be hit with this:


    It seems much worse now. Everything goes 100% black and blue.
     
  21. Fengist Trainee Engineer

    Messages:
    30
    Just started having this issue with this patch. And since most of what I do is writing scripts, it's REALLY annoying.
     
    • Agree Agree x 1
  22. hlws Tester Staff

    Messages:
    269
    Hi guys,
    Thank you very much, the issue has been reported to the programmers. Your feedback is making the game better, thanks and have a nice day :)
     
    • Like Like x 2
    • Friendly Friendly x 1
  23. Tigerstripe Apprentice Engineer

    Messages:
    479
    Saw this in the 1.180.1 update topic:

     
Thread Status:
This last post in this thread was made more than 31 days old.