Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186.5] Parachutes not behaving in survival

Discussion in 'Bug Reports' started by Burstar, Jun 20, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Burstar Apprentice Engineer

    Messages:
    463
    Created this blueprint in Creative mode. Works fine. Parachutes deploy and craft slows down to ~4.5m/s

    Pasted this blueprint into any survival game (modded/unmodded/mp/sp/ds) and when the parachutes 'deploy' you see the speed drop to ~40m/s, the chutes don't appear, and the craft behaves as if chutes are kinda dragging it (floats, rocks about etc...). Craft collides with ground, no survivors.

    Yes, they are loaded with canvas.

    To reproduce:

    Paste bp into a survival world,
    https://steamcommunity.com/sharedfiles/filedetails/?id=1417428214
    enter craft from rear,
    sit in flight seat
    press 9 to turn the craft on
    when you fall to an appropriate height, press 3 to deploy chutes
    grab your ankles and kiss your butt goodbye.
     
    Last edited: Jun 23, 2018
  2. HellBornSoldier Trainee Engineer

    Messages:
    13
    Tested Ship on Easy Start Mars; was able to replicate above conditions of craft reducing Speed (Very Slowly) as it approached 45m/s. Upon Further investigation, noticed that Inventories for Parachute blocks were not present in my loaded ship but the blocks them selves were located in the "Control Panel". Upon replacing the blocks in question on the ship and withing the timer block function, ship was able to decelerate in atmosphere when the parachute timer was called. Have repeated this fresh copies from the Blueprint Screen on Mars and Alien Plant to confer validity.
    --- Automerge ---
    Additionally; while testing, i took a copy of the descending craft when its parachutes where released and pasted beside it; expecting it to fall. It continued to gently float down beside the original but without graphics for its parachutes. This may have been the origin for this bug. Further testing may be required to see if "parachute persistence" extends to the workshop as reliability as this blueprint repeats.
     
    • Like Like x 1
    • Friendly Friendly x 1
  3. Zhiila Tester Staff

    Messages:
    487
    Hi,

    I just reproduced and reported the issue. :tu:

    I am not sure why it is happening, but if I tried to replace parachutes, it started to work, also copies and blueprints of the edited grid were working. So right now I would try to replace parachutes and it should be eventually fixed.

    Thank you!
     
Thread Status:
This last post in this thread was made more than 31 days old.