Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186] Huge memory leak - 14GB+ over 10-15 mins of play. No mods.

Discussion in 'Bug Reports' started by DarkDvr, Feb 3, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. DarkDvr Trainee Engineer

    Steam discussion link: http://steamcommunity.com/app/244850/discussions/0/1700541698690861772/
    Screenshot link: http://prntscr.com/i9d1tr

    Steps to reproduce:

    - Launch a brand new world, something like Easy Start Earth
    - Paste 3-4 large ships
    - Paste a small-grid buggy, drive around a little
    - Watch the game crash complaining about video driver not responding, where issue is most likely your RAM and pagefile are full.

    Just installed SE after watching the update stream, launched an Easy Start Earth (also tested on Eary Start Alien), no mods at all.
    SE RAM usage is climbing at an insane rate - after about 10 minutes of active play (5-6 small grids pasted, driving around on a planet), I run out of RAM (that's 14+ GB for SE process).

    Might want to check on that =)

    Win10 latest update
    GTX 980Ti, just updated driver today, no overclock
    i5 6600K no overlock
    Background processes - chrome with 2 light tabs, steam.
    Game res: 2560x1440
    Postprocessing ON
    Everything on High, AA is off.
    Game is on an SSD

    On a side note, SE is also filling up my VRAM (6GB) quickly. Not sure myself, but maybe it's leaking from VRAM into RAM?
    I'm also curious why SE needs 6GB VRAM, since without any mods it really doesn't have that many textures, does it? Perhaps it's justified. Perhaps it's a bug.
    • Agree Agree x 2
  2. Plongo Trainee Engineer

    I second this. i7 6700k and 980ti and 16gb ram. Ram filling up like crazy and followed by GPU VRAM. Becomes disgustingly laggy, choppy, freezing every few seconds when moving. NOT FUN and makes me sick with the new visuals added onto it. GPU is at around 60% load while that VRAM fills up way to fast to max.
    Feels like a 30%-60% loss in performance (excluding the memory leaks). No issues pre patch.
    • Agree Agree x 1
  3. DarkDvr Trainee Engineer

    Tried a new map (Solar System), was able to play for about 15 minutes, SE got up to 6GB RAM, but not higher. No crashes.
    In terms of grids - large grid planetary lander, small grid wheeled rover.

    Perhaps you need more objects (grids) to crash. Perhaps it's the Easy Start maps that have the leak.
  4. Plongo Trainee Engineer

    Yep, so a solar system start causes no major issues, FPS and performance still tad bad but better. Stuttering, lag and freezes are much less occurring. Looks like its related to Save files or files which contain pre existing grids.
    --- Automerge ---
    Memory starts to go up drastically when i add a grid (small or large). Then seems to fall apart from there. :(
  5. haibusa2005 Trainee Engineer

    I have similar issues - star system loads for about 5 min, about 11GB RAM consumed and everything stutters like crazy - every 3 or so seconds; CPU is maxed at 98%. i3 6100, gtx 980.
  6. Dr. Novikov Apprentice Engineer

    Deleting old shader cache folders in appdata makes the game run way smoother, and consume RAM slower. I was able to play for a while before the game crashed.
    • Like Like x 1
  7. Plongo Trainee Engineer

    Is it also a semi fix for the freezing and lag? FPS is not what it used to be pre patch.
    --- Automerge ---
    okay! soo if extreme settings are put to high (including a game restart) fixes fps issues and the extreme Memory leak, still goes up slowly however. THOUGH there still is a VRAM MEMORY LEAK. started at 2gb now used up all 6gb of VRAM after 10mins.
  8. Byzod Trainee Engineer

    All my settings are equal or lower than High, a vanilla Earth Easy Start still suffering huge memory leak.

    1. Create a Earth Easy Start without mod, creation mode
    2. Fly along the surface with your jetpack
    3. Watch your RAM usage increasing rapidly
    • Informative Informative x 1
  9. Plongo Trainee Engineer

    Dang. Well hopefully all the major issues get fixed soon.
    Also try starting a solar system start. Easy starts caused issues for me too.
  10. Ondřej Nahálka QA Lead Staff

    I have found the problem.

    There is a memory leak when moving around the voxel with grass.

    We are working on it.

    Please wait for the minor update 1.186.1.
    • Informative Informative x 2
    • Like Like x 1
  11. Byzod Trainee Engineer

    That should be the problem

    But there may have other leak points since my game still crash with high RAM usage after 10-30 minutes in space (no grass, no ground)
    It runs much longer than planet surface flyby (2-5 minutes crash), but still lead to crash in lesser than an hour
  12. silentknight Trainee Engineer

    I'm having this issue too! After about 5 minutes playing on Easy Earth I managed to blow through 8GB vRAM and 32GB system RAM! see https://ibin.co/3qx6zKVlRUWo.png
  13. Nova_Hawk Trainee Engineer

    I too can confirm the current Memory leak. The two minor 1.186.xxx updates have done nothing to fix this issue and to top it off, whichever planet file I build into saves with a longer and longer filename. This eventually leads to a "cannot save" error for too long of file name. Upon trying to load or rename and edit the SANDBOX.sbs results in the planet COMPLETELY disappearing.

    Seems to be related to Voxels in some way.

    Currently playing on Star System, creative.

    Last edited: Feb 11, 2018
Thread Status:
This last post in this thread was made more than 31 days old.