Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186][SP/MP] Piston phantom force cause

Discussion in 'Bug Reports' started by KingdomBragg, Dec 6, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. KingdomBragg Junior Engineer

    Messages:
    544
    Reproduction Rate: 5 out of 5
    Configuration: 1.185.2 - 1.186, SP and MP survival and creative
    Reproduction steps:

    1. Load test world: [BUG REPORT] Phantom Force Test World [BUG REPORT]
    2. Press button on green platform
    3. Press button on red platform
    4. Observe

    Observed behavior: The green platform spins during merge and stops after merging has finished. The red platform continues to spin after merging has finished.

    Expected behavior: The red platform should act like the green platform

    The two platforms are identical in every way except that on the red one a piston is rotated 90 degrees. If rotation in that axis were disabled somehow, all pistons would be placed with the same rotation and the phantom force would not occur.
     
    Last edited: Feb 4, 2018
  2. KingdomBragg Junior Engineer

    Messages:
    544
    Any devs seen this? It's still happening as of 1.186.
     
Thread Status:
This last post in this thread was made more than 31 days old.