Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

168.006 Dedicated Survival Multiplayer, "Downloading Mods Has Failed!"

Discussion in 'Bug Reports' started by JTConsortium, Jan 27, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. JTConsortium Apprentice Engineer

    Messages:
    289
    What gives here? Worked fine last night.

    Downloads a couple of the mods then stops for a moment then this.

    Nothing on my server has changed. No mods were added or removed. DS config file has not been altered in any way.

    [​IMG]
     
  2. Terik92 Trainee Engineer

    Messages:
    79
    Same here. A friend can't join my game with mods and we were able before last updates (main and hotfix)
     
  3. Roxette Junior Engineer

    Messages:
    865
    Obvious first step - check that all the mods configured in the world are still present on the steam workshop. People do sometimes delete mods they have published, for various reasons. Beyond that, more data (logfiles) would be required to establish what the problem may be.
     
  4. Terik92 Trainee Engineer

    Messages:
    79
    I've been removing all the mods one by one from the game till it was full vanila. Then he was able to join. All the mods are still in the workshop. Where could I find the logfile about the mod download failure?
     
  5. Roxette Junior Engineer

    Messages:
    865
    The file you're looking for would normally be C:\Users\<your username>\AppData\Roaming\SpaceEngineers\SpaceEngineers.log - The preferred method is to post log file to www.pastebin.com and share the link on forum, or to use the 'spoiler' function in the edit toolbar. You may be able to tell from the log if a specific mod is causing the issue, but it could even be a problem with the steam network..
     
  6. Dekarian Trainee Engineer

    Messages:
    90
    This is also happening to me in single player. Trying to create a new world, it "downloads" all the mods, then tells me it failed to download mods.
     
  7. Roxette Junior Engineer

    Messages:
    865
    OK, four reports in a short time today, on the stable version that's been out for a month, I suspect this is much more likely to be a steam problem than a game problem. I am also seeing frequent error pages on the steam workshop at this time. It is most likely a steam problem, and I suspect they will be aware of it.
     
  8. Darkminion Trainee Engineer

    Messages:
    4
    I am getting this as well. I checked the server log as it started and there is an issue with downloading them from steam. at first I thought the mods had been pulled from the workshop but this is not the case. In an effort to get the server started again I removed these mods. When I started up the server again it reported the same issue with a third mod that did not have any trouble before. The message is "Could not download mod: id= (MODID), url= http://cloud-3.steamusercontent.com/ugc/randomstring/randomstring."

    This is on the Dev build.
     
  9. FlakMagnet Senior Engineer

    Messages:
    1,551
    I am also getting an issue. For me...it was affecting all the custom planets I was trying to include in a solar system map start. All the mods are in the workshop, but they do not seem to be downloading.

    I checked in my mods file and none of the stuff I had chosen from the workshop today actually downloaded at all.

    Anything from existing mods I had already downloaded was fine.

    Now...I am playing offline single player, so I guess this is the issue for MP too. The players cannot download the mods when they join, so the startup fails
     
  10. k0ncept Trainee Engineer

    Messages:
    3
    I am getting the same error... Wont d/l any mods but will let me join vanilla and or create a vanilla game... I uninstalled, re-installed, nothing has worked.. only way I can play ATM is pure vanilla... If I load as much as 1 mod it wont work.. or try to join any modded servers.. I also deleted the %appdata% files and same...
     
  11. Telquel Trainee Engineer

    Messages:
    45
    Seems to be some larger problem. Also cant get most of mods working currently.
    Played whole evening and tried to set up TIM inventory manager but cant get it in to programmable block, nothing happens when selecting it from list.
    After that I deleted those all mod from %appdata% and cant download any of mods currently.

    Maybe it is something in steam...
     
  12. Skicek Trainee Engineer

    Messages:
    8
    Same here, today after the fix patch Im unable to download any mod from workshop.

    Code:
    title='Modules Multiplied'; tags='Mod,block,script,other'
    2017-01-27 23:11:47.817 - Thread:  1 ->  Obtained details: Id=837924716; Result=OK; ugcHandle=94974011265692446; title='Thrusters force 10x modification'; tags='Mod,block,script,other'
    2017-01-27 23:11:47.818 - Thread:  1 ->  Obtained details: Id=844624907; Result=OK; ugcHandle=94974011265689797; title='Max Ship Speed Modification'; tags='other,Mod,script'
    2017-01-27 23:11:53.188 - Thread:  1 ->  Error downloading file: FileNotFound
    2017-01-27 23:11:53.238 - Thread:  1 ->  Error downloading file: FileNotFound
    2017-01-27 23:11:53.238 - Thread:  18 ->    Failed to download mod: Id = 297134315, title = 'Civilian Bed (Sage)'
    2017-01-27 23:11:53.238 - Thread:  18 ->    Failed to download mod: Id = 297348674, title = '(DX11) Bunk Bed'
    2017-01-27 23:11:53.238 - Thread:  18 ->    Downloading mods failed
    2017-01-27 23:11:53.238 - Thread:  18 ->  Downloading world mods - END
    2017-01-27 23:11:53.255 - Thread:  1 ->  Error downloading mods
    2017-01-27 23:11:53.255 - Thread:  1 ->  Downloading mods has failed! Please check mods in world settings.
    2017-01-27 23:11:53.255 - Thread:  1 ->  LoadSession() - End
    I tested it by removing mods from appdata. Even my mods wont download. So for sure they exists in steam workshop.
    Not sure if this is fault of steam or Keen change something in recent fix update.
     
  13. FlakMagnet Senior Engineer

    Messages:
    1,551
    Yup...the mods will not download from Steam. Happened recently, and I have tried it on dev AND stable, and both are broken, so it is most likely a Steam issue, as stable has not been updated.
     
  14. k0ncept Trainee Engineer

    Messages:
    3
    I did the same as well, tried it on Dev and Stable... same results...
     
  15. Terik92 Trainee Engineer

    Messages:
    79
    Then there's no doubt, the issue comes from Steam's Workshop and not Space Engineers.
     
  16. Roxette Junior Engineer

    Messages:
    865
    One of the worst aspects of the Steam service is that they have no publicly visible status information, combined with the fact that their service has frequent sometimes prolonged outages due to internal system failures or external influences. There are third-party tools like https://www.issteamdown.com/ http://downdetector.com/status/steam and https://twitter.com/SteamStatus which are useful to check when there are problems like this, but they don't always give the whole story.
     
  17. FlakMagnet Senior Engineer

    Messages:
    1,551
    They finally got their act together and fixed it late last night for me, so I could download workshop content again. There were quite a few forum posts on the Steam forums about the problem, but they were not responded to at all by Steam. They just kept quiet. Not even annoujncing that there WAS a problem
     
Thread Status:
This last post in this thread was made more than 31 days old.