Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Bad optimization

Discussion in 'Bug Reports' started by Tralalakk, Feb 16, 2018.

?

Is this game Optimized ?

  1. yes

    0 vote(s)
    0.0%
  2. no

    100.0%
Thread Status:
This last post in this thread was made more than 31 days old.
  1. Tralalakk Trainee Engineer

    Messages:
    40
    So here is my spects
    Operating System: Windows 10 Home 64-bit
    Intel(R) Core(TM) i5-7600K CPU @ 3.80GHz (4 CPUs), ~3.8GHz
    Memory: 16384MB RAM
    Available OS Memory: 16344MB RAM
    DirectX Version: DirectX 12
    Card name: NVIDIA GeForce GTX 1050 Ti
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 1050 Ti
    Display Memory: 12189 MB
    Dedicated Memory: 4018 MB
    Shared Memory: 8171 MB
    Current Mode: 1920 x 1080 (32 bit) (60Hz)
    HDR Support: Not Supported
    Here are your Hardware requirements
    OS:Microsoft Windows 7 (latest SP) 64-bit
    Processor:Intel Quad Core i5 @ 3 GHz or higher (or AMD equivalent)
    Memory:16 GB RAM
    Graphics:Geforce 780 GTX or higher
    DirectX:Version 11
    + game is on SSD
    Now please tell me how is it posible that it runs around 20-28 fps on my pc ? with those specs and your HR ?
    yeah i play on world where i got station and two big ships but this should not happen, If i get even close to the planet the game will crash or freeze because the v ram goes to hell it has massive memory leak same with ram
    its horrible and im not the only one having this issue your forums are full of this problems so please fix it.
    If this still is not enought to convince you that the game went to toilet just look at the steam reviews they vent to shitter as soon as you added planets and did not optimize them.
    Would love to hear other people opinion on this and Thank you have a nice day
     
  2. Sinbad Senior Engineer

    Messages:
    2,788
    https://www.videocardbenchmark.net/high_end_gpus.html
    note where your video card is compared to the recommended.
    also, from the looks of it, your memory is shared. you have 4GB dedicated to the cpu only, and 12 that the gpu has access to. but, 8 of the gpu memory can also be given to the gpu.
    it makes the numbers look nice, but you actually end up with 4-12GB of CPU RAM, and 4-12 of GPU RAM. if one of those two is maxed to 12, the other suffers with 4.
    split the difference for a balanced performance, you only have 8GB of RAM. half the recommended. best case scenario you have 12, still less. and if your CPU is using 12, then your GPU is only using 4, which will drive its performance even lower.

    dont game with laptop hardware.

    that said:
    i7-4820K (8@3.7GHz)
    16GB RAM
    GTX 780Ti
    with the OS and game on a sata6 SSD
    still makes for bad frame rates in crowded worlds. not as bad as 20, but still noticeably not 60.
     
    Last edited: Feb 17, 2018
  3. Tralalakk Trainee Engineer

    Messages:
    40
    what you mean by dont game with laptop hardware ? i stil think its bad optimalization sorry but i paid around 1574.26 USD for my pc or 30k CZK that should fucking run everything and it does exept this game also changing the settings have no efect it does not matther if the game is set on extreme or low runs the same way and you have the balls to tell me its my pc thats just weird
    https://forum.keenswh.com/threads/1-186-101-current-issues.7400013/#post-1287087520
    this guy has 1080 and 32gb ram yet he has issues thats wierd right ?
     
    Last edited: Feb 17, 2018
  4. Katsura Trainee Engineer

    Messages:
    3
    I have the same problem. The game has extreme memory leak. Goes through my GPU and RAM in minutes. Usually starting with great fps but it degrades drastically in a few minutes and proceeds to crash.
    Might I add that it got worse with every update and crash "fix".
    Specs:
    Windows 10 Home 64-bit
    NVIDIA GeForce GTX 1080 8GB
    Intel Core i7-8700 (6CPUs 3.2GHz - 4.6GHz turbo)
    16GB RAM
     
  5. X_Wing_Ian Trainee Engineer

    Messages:
    61
    If it crashes upload the log file it might help keen find the memory leak.
     
  6. Sich Trainee Engineer

    Messages:
    89
    The game need to run on SSD drive...
    And I have recently switch from 16Gb memory to 32Gb and this make a good difference....

    And don't play on extreme, stay on medium, try to disable some advanced options... etc etc...
     
  7. Tau Trainee Engineer

    Messages:
    52
    I have not been having this issue, perhaps the developers would appreciate you sending them your world file on which it is happening and any mods the game may be using.
    as the above said, it would also be useful to them if you send them your log file.

    All of that ^^ Would probably help them help you.

    Otherwise it would be like finding a needle in a haystack.
    A 15 Gigabyte haystack.

     
    Last edited: Feb 17, 2018
  8. Tralalakk Trainee Engineer

    Messages:
    40
    and its hard to send a crash log if the game wont give me the option sometimes the game even causes my pc to reset which is not ok and before you ask yes this is the only game that does it
    --- Automerge ---
    got it on SSD and on low settings still runs like 90 year old hag after 2 strokes
     
  9. Katsura Trainee Engineer

    Messages:
    3
    I won't be buying another 16 gigs of RAM for this game... ffs 32 GB needed for this ? What is this.... Star Citizen ?
     
  10. Tralalakk Trainee Engineer

    Messages:
    40
    they will probably tell you next you gonna need 2 titans to run this and atleas 6Ghz cpu with 12cores
     
  11. Spaceman Spiff Senior Engineer

    Messages:
    1,479
    I have a dual-CPU Xeon workstation (16, 3.6GHz cores) with 72GB RAM, two SSDs, and an NVIDIA GTX 970 video card. My system lags if I do too much “digging in the dirt” (e.g., mining or digging conveyor shafts), or if I’m on a planet with too many critters, or if I have meteors set to anything above “safe” (or any combination of the above). I just accept it as the way it is.
     
  12. Tralalakk Trainee Engineer

    Messages:
    40
    this is not ok for any game if anybody will keep telling us that its not the game thats the problem after this then they are messed up in the head
     
  13. Spaceman Spiff Senior Engineer

    Messages:
    1,479
    I can decide to play or not play. If I’ve learned anything in life, when I buy something, whether a product (such as this game) or a service, there’s no guarantee (even if there is a “guarantee”) that I’ll be satisfied with the end result. As a real-life engineer, I’ve learned to adapt and overcome challenging circumstances. [OK, I’ll step off my philosophical soapbox now.]
     
    • Agree Agree x 1
  14. Tralalakk Trainee Engineer

    Messages:
    40
    well see the problem is since they ask full price basicaly you kinda expect it to atlest run well they are way cheaper sandbox games with lower budget then this and they run well this is just not ok they need to fix it. Look at the vote thing and the steam reviews you gonna find out people agree with me
     
  15. Tralalakk Trainee Engineer

    Messages:
    40
    this is how the game runs in empty world with 3 large ships massive fps drops from 120 to 20 not to mention the slow sim speed which i understand
     
  16. Katsura Trainee Engineer

    Messages:
    3
    What he shows is even worse if you play co-op. As a guest I experience the same fps drops (from 120 to 5) and sometimes the game just crashes. Usually it's the horrendous memory leak that this game has but few times it just ran 2 - 5 fps while RAM, CPU and GPU did not go above 50%. In some instances the game just freezes without putting any real strain on the HW.
     
  17. Syncaidius Junior Engineer

    Messages:
    824
    That honestly looks like it's running fine, given the size of those massive ships. Roll back the game 12 months and I doubt you'd get it to run that well, if at all.

    That said, like many here I have issues with constant stuttering and mini-freezes. The game also doesn't seem to scale up well on a CPU with more than 4 cores.
    My specs are:
    Ryzen 1600 (6-core, 12-thread)
    16GB DDR4 RAM
    AMD R9 390 8GB GDDR5
    Samsung 840 series 250GB SSD <--- SE is on this one
    Seagate 1TB HDD
    120GB Kingston SSD

    It doesn't appear to max out all of the cores it is using, so that rules out single-thread/core performance. I think it's just a matter of letting Keen get through all the optimizations they have in the pipeline. It's definitely improved since a year ago, but there's a lot more work to be done.
     
  18. Tralalakk Trainee Engineer

    Messages:
    40
    it does not run fine if it drops from 120-+fps to 20 on completly empty world with only 3 large grids on medium settins with my specs
     
Thread Status:
This last post in this thread was made more than 31 days old.