Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Black terrain

Discussion in 'Bug Reports' started by nimrod100, May 19, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. nimrod100 Trainee Engineer

    Messages:
    36
    When I load a world or create a new one it load's the terrain but instead of appear as grass and stone it appears black. Then when night falls it turns white. Returns no error. Version is 02.017.009.
    Has anybody got any solutions. If not, can KeenSWH please add a patch for it.
     
    Last edited: May 19, 2015
    • Like Like x 1
  2. Lukas Designer

    Messages:
    443
    Hello nimrod100,

    please first try to verify cache and reinstall graphics drivers. If these steps won't help. Post your system specifications, your render log and log here. Thank you for reporting bugs to us!
     
  3. nimrod100 Trainee Engineer

    Messages:
    36
    Sorry to ask but although I program I have no idea how to verify cache or reinstall drivers :p (yet I can do high level coding. Weird) can you tell me how. My windows specs are: windows 8.1, i3 processor, 8gb ram, x64based system
     
  4. nimrod100 Trainee Engineer

    Messages:
    36
    Never mind... figured out the verify cache bit... Did that but nothing changed
     
    Last edited: May 21, 2015
  5. nimrod100 Trainee Engineer

    Messages:
    36
    Just done the reinstalling of drivers too. Does updating them count as reinstalling?
    By the way the black terrain doesn't happen on space engineers. Oh and nothing happened when I updated video driver
     
    Last edited: May 21, 2015
  6. Thompa Trainee Engineer

    Messages:
    1
    it's exactly the same for me, and i guarantee it isn't my computer. literally just bought the game, not a good start i must say. it sometimes goes purple and green around the edges as well. :mad:
     
  7. sku08 Trainee Engineer

    Messages:
    54
    Do you two have SLI or crossfire enabled? ATM it is incompatible with ME. this can cause some problems
    Please post your hardware specifications.
     
  8. nimrod100 Trainee Engineer

    Messages:
    36
    I don't think that I do. I don't remember installing either of those. Also, what Thompa said, I get that as well. Could it just be medieval engineers?

    My specs:
    Windows 8.1
    8gb ram
    x64 based OS
    Intel core i3 processor


    The small patch they released didn't change anything either... Not happy. I have been following these games religiously.
     
  9. sku08 Trainee Engineer

    Messages:
    54

    does your gpu meet the minimum system requirements to run Medieval Engineers? http://www.medievalengineers.com/system-requirements.html

    Please refer to this thread on how to post your logs
    http://forums.keenswh.com/threads/bug-report-guide.7283766/
     
  10. nimrod100 Trainee Engineer

    Messages:
    36
  11. sku08 Trainee Engineer

    Messages:
    54
    Could you please post your logs, this is crucial for them to help fix the problem.
     
  12. nimrod100 Trainee Engineer

    Messages:
    36
    Where may I find these logs and which one?
     
  13. sku08 Trainee Engineer

    Messages:
    54
    As i said before in a previous post, here is the thread on how to post your logs.

     
  14. nimrod100 Trainee Engineer

    Messages:
    36
    Here you go, it is in two parts: this is the MedievalEngineers.txt file in two pArts:
    Www.pastebin.com/USmZuNNz
    Www.pastebin.com/u8bZN734
     
    Last edited: May 27, 2015
  15. nimrod100 Trainee Engineer

    Messages:
    36
    Ok new problem. With 02.018 it stays black when looking at the ground, black with a green outline of the mountains and blocks when looking at the horizon, and perfectly normal terrAin colour when looking at the sky.
     
  16. nimrod100 Trainee Engineer

    Messages:
    36
    Yeah I hVe posted my logs. What now!!!
     
  17. nimrod100 Trainee Engineer

    Messages:
    36
    Also if I put the game into windowed mode it goes black if the you stand still for a while, normal terrain if you don't, and sometimes redish
     
  18. Dan2D3D Moderator

    Messages:
    1,000
    Hi nimrod100,
    looking at your log I noticed that you don't have a video card you are using integrated 'Intel(R) HD Graphics 4000.
    I have a lot of friends trying to play with no video card using integrated 'Intel(R) HD Graphics 4000 and they all have issues they tried everything even playing at very low graphics settings and they still have issues.
    I know that the game was working before the last update but my friends were already having issues before this update they could play with low graphics settings only and in small world they can't create anything in a large world too much lag.
    You may be able to play games using 'Intel(R) HD Graphics 4000 but I don't see this graphics on Medieval Engineers Steam store page minimum requirements.
    • Graphics: AMD Radeon HD 5830 / NVIDIA GeForce GTS 450 with at least 1024 MB VRAM or better
    As a gamer I prefer to buy a good video card for my computer this way I don't have any issues. Wait to see if a DEV can help you.
     
  19. Lukas Designer

    Messages:
    443
    @nimrod100 we reproduced the problem on our computer with intel HD graphics card. We are working on a fix.
    Thank you for the report.
     
  20. nimrod100 Trainee Engineer

    Messages:
    36
    Thank you so much. My brother brought the game on Monday and I really wanted to connect but I couldn't see the terrain.
     
  21. Lukas Designer

    Messages:
    443
    Hello guys,

    we have updated drivers on our computer with intel hd 4000 GPU, where we reproduced your issue. Turns out it has fixed the issue on it. This will work for you too. Here is a guide how to update them:

    open control panel -> device manager -> display adapters -> right mouse button on intel(R) HD graphics xxxx (xxxx stands for number of graphics you are having) -> hit update driver software -> after update is done, restart the computer -> start the game -> let me know if that helped you guys, thanks.

    Always keep your drivers up to date. I recommend using Nvidia Experience/AMD GamingEvolved software.
     
  22. Aaron Maxwell-Realtor Trainee Engineer

    Messages:
    19
    Hey again Lucas, These guys have described exactly the problem I am having. However, like I said on the other thread, my driver does not have an update according to my device manager and Intel's website. If you could possibly provide the link to the update that worked on your computer I can try to manually install it.

    Thanks for your help man :)
     
  23. Lukas Designer

    Messages:
    443
  24. nimrod100 Trainee Engineer

    Messages:
    36
    T
    tried updating my drivers but it said they were already up to date and did nothing to ME
     
  25. Lukas Designer

    Messages:
    443
    @nimrod100, if you updated the drivers and it did not help, then you must be having a different issue that looks the same. There are 2 separate black terrain issues, that look the same, but have different causes.
    I am sorry for the inconvenience but we are going to need your render log as well in this case. (it is in the same place your log is)
     
  26. nimrod100 Trainee Engineer

    Messages:
    36
    The render log is here: www.pastebin.com/AqmFKGYz
     
  27. nimrod100 Trainee Engineer

    Messages:
    36
    This problem is now solved because of the "temporary intel fix". Thank you keenswh
     
Thread Status:
This last post in this thread was made more than 31 days old.