Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Can't connect to my server

Discussion in 'Bug Reports' started by JimTheSoundman, Nov 25, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. JimTheSoundman Trainee Engineer

    Messages:
    87
    I've been running a server for about 6 months. Everything usually runs smoothly but about three weeks ago, after the update, I couldn't connect.

    I was thinking maybe something got broken and it would be hotfixed... well nope.

    Then I though, I'll wait til the next update and see if that fixes it. Nope.

    So I've been through two updates, it's still broken.


    Here is the deal:

    Nothing has changed on the server computer. It's exactly the same as it was a month or six months ago. Every Thursday I make sure the Space Engineers Program has updated and restart the server. Perfectly normal.

    My client laptop is the same as always, nothing new there. It also has been updated every Thursday.

    I cannot connect through the internet, but what is really puzzling is that I cannot connect through the LAN either. Both computers are connected wirelessly to my WAP. Both have IP's assigned through DHCP, and I've checked them both to make sure they are squared away. I can move files from one computer to another. I can connect from my laptop to the server computer using Teamviewer, so I know the connection is possible.

    The server computer has an IP of 192.168.0.104 and that's what is on the Listen section of the Dedicated Server setup screen. (I've also tried 0.0.0.0 in that slot but it didn't make any difference.)

    Both computers are using the default port of 27016.

    The server shows its status as "RUNNING"

    When I choose Direct Connect, sitting in the same room as the server, and manually type in the same IP address 192.168.0.104:27016 and try to connect, it tells me "Server Is Not Responding"

    I have port forwarding set up on the WAP to forward any traffic on port 27016 to IP ending in 104.

    I don't get it. There is no reason they shouldn't be talking to one another. Anyone have any ideas?
     
  2. JimTheSoundman Trainee Engineer

    Messages:
    87
  3. JimTheSoundman Trainee Engineer

    Messages:
    87
    Tried uninstalling and reinstalling everything on the server computer, and it made no difference


    I'm stumped.
     
  4. kittle Senior Engineer

    Messages:
    1,086
    Does your server have a static IP? Most routers only do port forwarding to a static IP.
     
  5. JimTheSoundman Trainee Engineer

    Messages:
    87
    Yes, the server is setup with a static IP.
     
  6. Roxette Senior Engineer

    Messages:
    1,499
    I'm not sure on what planet anyone would think that setting up a game server on a wifi connection is a good idea... but have you checked the server log to see what is happening there? ... and perhaps try a wired connection between the client and server machines to see if the issue is just down to the wireless system ?
     
  7. JimTheSoundman Trainee Engineer

    Messages:
    87
    Well, I had been using it for about 6 months with no issues whatsoever, until this strange problem cropped up. So wireless wasn't an issue for me.

    I can ping the server from the laptop, I can ping the laptop from the server. There is no lag.

    I can certainly dig up a null modem cable and try it, but I don't think that will solve the problem. But I appreciate the suggestion.
     
Thread Status:
This last post in this thread was made more than 31 days old.