Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Can't find the ModSDK on Steam

Discussion in 'Modding' started by Arklight, Feb 22, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Arklight Trainee Engineer

    Messages:
    3
    I can't seem to find the "Medieval Engineers ModSDK" in my Tools on Steam. I have the SpaceEngineers one though, is that compatible with Medieval Engineers?

    And if it is indeed compatible, could someone tell me what the folder hierarchy is?

    Code:
    Data/Models/Cubes/Large/
    Is what I'm trying right now.
     
  2. DarkGhost Junior Engineer

    Messages:
    765
    Don't think they would have released the SDK yet, it's not even a week old.
     
  3. Arklight Trainee Engineer

    Messages:
    3
    I assumed they would have since http://www.medievalengineers.com/modding.html is talking about a "Medieval Engineers ModSDK"
     
  4. TotalMark Trainee Engineer

    Messages:
    5
    The folder hierarchy is the same as Space Engineers, as this is a fork of that game. I've been waiting for the SDK also.
     
  5. Arklight Trainee Engineer

    Messages:
    3
    So you've had no luck using the SpaceEngineers tools?
     
  6. MechanizedIT Apprentice Engineer

    Messages:
    354
    The SDK can be found in your steam library under tools.
     
  7. MechanizedIT Apprentice Engineer

    Messages:
    354
    I used the SE mwmbuilder to make a mod , and it worked up until a patch, the other day, now it seems when I try to add a custom model to the game, it crashes it as a local mod when you go to the G-menu, and if you upload to steam, the workshop version replaces the modded block with the slope block but with the collision mesh of the modded block. The MwmBuilder for ME seems bugged as well, it outputs files in weird places, even when I specify where.
     
  8. HongPong Trainee Engineer

    Messages:
    10
    It seems like the ME SDK was available and then got pulled later, the URLs stopped working.
     
  9. matth Trainee Engineer

    Messages:
    18
    I have not been able to find the sdk for either Medieval Engineers or Space Engineers in Steam. I bought Space Engineers a couple months ago.
     
  10. lodebeard Trainee Engineer

    Messages:
    33
    SE Mod SDK was missing for me as well when I went to install it yesterday. I found it on the steam database. If you install from here it will be added to your tools library:
    Space Engineers - Mod SDK:https://steamdb.info/app/326880/history/

    Be advised, it is currently missing files and VrageEditor/model viewer will not load properly. The only solution for that I have heard is to replace the missing files with those from the ME SDK.

    Unfortunately for you and I, it seems Keen has pulled the ME SDK off of steam for some reason...https://steamdb.info/app/349110/subs/

    It says it was updated 8 hours ago, but it has been missing for a couple days based on what people are saying. My best guess is they found something and needed to pull it while they fix it.

    Here is the relevant thread I started on this in the SE modding forum.
     
    Last edited by a moderator: Mar 2, 2015
  11. Takeshi Apprentice Engineer

    Messages:
    200
    i was searching the second time after new installation on my pc, to make the search easier for me (next time):
    in steam: go to library (not SHOP), submenue TOOLS, there you get a list, scroll down to Space Engineers - Mod SDK, right click: installation
    (attention: there is also a BETA Version available, like stable/dev branch at the game)
     
  12. Coggernaut Trainee Engineer

    Messages:
    71
    I can help you with that, look for my guide in my signature =)

    If not on steam, you can download it from google, I'm pretty sure keen has a download on their website... somewhere... I know I had to do this, and then I found it my library afterwords. But I think they fixed it and made it automatically show up in your "Tools" library under library
     
Thread Status:
This last post in this thread was made more than 31 days old.