Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Chrome loves Keen again (Updated)

Discussion in 'General' started by Thrak, Nov 16, 2018.

  1. Thrak Apprentice Engineer

    Messages:
    418
    The current version of Chrome (I am using Version 70.0.3538.102 (Official Build) (64-bit)) says forums.keenswh.com has an expired security ticket and makes it a pain to access. Just FYI. It says this site is "unsafe"... which I can't imagine is great for business....
     
  2. Roxette Senior Engineer

    Messages:
    1,067
    remove the s ... forum.keenswh.com does have a valid certificate. Keen don't limit their incompetence to game programming, they can't configure web services either.
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  3. AlfieUK4 Trainee Engineer

    Messages:
    62
    I'm also on the same version of Chrome and don't get a warning on forums.keenswh.com...it shows a valid certificate for *.keenswh.com (from 15/02/17) so forums.* or forum.* should be covered?
     
  4. Roxette Senior Engineer

    Messages:
    1,067
    Somebody must have spotted the thread and taken action, the certificate has been changed to a valid one.
     
    • Like Like x 2
  5. Thrak Apprentice Engineer

    Messages:
    418
    Perhaps, but I am still seeing it. One must have "safe browsing" activated in the Chrome>Advanced>Privacy and Security settings. When that is turned off, I don't get the challenge screen in Chrome, but I still get the "Not Secure" warning in the address bar (which I think is a new thing in Chrome, maybe not exclusive to this site). I don't get any of that, regardless of Safe Browsing, on the main SE landing page.
     
  6. AlfieUK4 Trainee Engineer

    Messages:
    62
    Strange, I have safe browsing enabled. Mine is pretty much a default install, haven't messed with the settings, and only 2 extensions that shouldn't be interfering (uBlock Origin: off for this domain, and Twitch Now).

    AFAIK the 'not secure' warning is connected to Chrome 'forcing' HTTPS by default around the end of this Summer, so anything without a TLS cert gets flagged up now, Any extensions? Can you see the cert in another browser?
     
    • Like Like x 1
  7. domingo Trainee Engineer

    Messages:
    19
    Maybe certificate cached at proxy server ?
     
    • Like Like x 1
  8. Thrak Apprentice Engineer

    Messages:
    418
    It's working for me in Chrome now. Thanks for the advice, all. I did an uber-cleanup of Chrome, and rebooted the PC. That seems to make whatever change they made, stick.

    The specific issue is about Chrome (other browsers will follow soon, I've read) shunning the use of older Symantec certificates. https://www.csoonline.com/article/3...-are-your-security-certificates-in-order.html

    Anyway, apologies for the clickbait post title... I only do that when it's for a good cause :p
     
    • Like Like x 1