Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Custom Importer/Editor tool - SEToolbox

Discussion in 'Modding Guides and Tools' started by midspace, Nov 24, 2013.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. KillBill Trainee Engineer

    Messages:
    12
    hm, SETOOLBOX dosnt work anymore?!

    Get these Error when i try to start

    [​IMG]

    Here is the EventLog:

    Code:
    2017-01-22 11:47:52,819 [1] FATAL SEToolbox.Support.DiagnosticsLogging [(null)] - Unhandled Exception
    Application: D:\Steam\steamapps\common\SpaceEngineers\Tools\SEToolbox-01.153.010.1\SEToolbox.exe
    CommandLine: "D:\Steam\steamapps\common\SpaceEngineers\Tools\SEToolbox-01.153.010.1\SEToolbox.exe"
    CurrentDirectory: D:\Steam\steamapps\common\SpaceEngineers\Tools\SEToolbox-01.153.010.1
    SEBinPath: D:\Steam\steamapps\common\SpaceEngineers\Bin64
    SEBinVersion: 1.171.3
    ProcessorCount: 8
    OSVersion: Microsoft Windows NT 6.2.9200.0
    Version: 4.0.30319.42000
    Is64BitOperatingSystem: True
    IntPtr.Size: 8
    IsAdmin: False
    CurrentUICulture: de-DE
    CurrentCulture: de-DE
    
    Files:
    2017-01-22T00:08:05.4948544+01:00	21.552.024		HavokWrapper.dll
    2016-01-11T08:42:57.2807547+01:00	498.176	2014.2.17.1	HelixToolkit.Wpf.dll
    2016-01-11T08:42:57.2827548+01:00	200.704	0.86.0.518	ICSharpCode.SharpZipLib.dll
    2016-01-11T08:42:57.2887551+01:00	301.056	1.2.13.0	log4net.dll
    2017-01-22T00:03:36.9268667+01:00	660.128	12.00.21005.1 built by: REL	msvcp120.dll
    2017-01-22T00:03:39.4904378+01:00	963.232	12.00.21005.1 built by: REL	msvcr120.dll
    2017-01-22T00:08:03.4785074+01:00	56.216	1.0.0.0	Sandbox.Common.dll
    2017-01-22T00:08:05.8117364+01:00	6.274.968	1.0.0.0	Sandbox.Game.dll
    2017-01-22T00:08:06.5183108+01:00	329.112	1.0.0.0	Sandbox.Graphics.dll
    2016-10-15T01:26:04.8651520+02:00	1.205.248	01.153.010.1	SEToolbox.exe
    2016-06-15T10:45:07.4287495+02:00	745		SEToolbox.exe.config
    2016-09-26T01:21:47.8933694+02:00	27.136	1.0.0.0	SEToolbox.ImageLibrary.dll
    2016-10-15T01:26:01.3991109+02:00	7.680	1.0.0.0	SEToolbox.ImageShaders.dll
    2016-10-15T01:26:04.8471512+02:00	2.043.392		SEToolbox.pdb
    2016-10-15T01:26:01.1057691+02:00	51.200	1.0.0.0	SEToolboxUpdate.exe
    2017-01-22T00:08:03.9790699+01:00	268.184	3.1.0	SharpDX.dll
    2017-01-22T00:08:03.9980937+01:00	357.784	1.0.0.0	SpaceEngineers.Game.dll
    2017-01-22T00:08:04.0588273+01:00	52.120	1.0.0.0	SpaceEngineers.ObjectBuilders.dll
    2017-01-22T00:08:06.7339897+01:00	10.861.464	1.0.0.0	SpaceEngineers.ObjectBuilders.XmlSerializers.dll
    2017-01-22T00:08:06.8087842+01:00	541.592		SteamSDK.dll
    2017-01-22T00:03:41.3105409+01:00	105.152	02.19.34.93	steam_api.dll
    2017-01-22T00:03:41.3105409+01:00	119.488	02.19.34.93	steam_api64.dll
    2016-01-11T08:42:57.2837548+01:00	39.936	2.0.20525.0	System.Windows.Interactivity.dll
    2017-01-22T00:08:04.0928602+01:00	70.040	1.0.0.0	VRage.Audio.dll
    2017-01-22T00:08:04.0928602+01:00	396.184	1.0.0.0	VRage.dll
    2017-01-22T00:08:04.1108782+01:00	930.200	1.0.0.0	VRage.Game.dll
    2017-01-22T00:08:04.1484175+01:00	3.126.168	1.0.0.0	VRage.Game.XmlSerializers.dll
    2017-01-22T00:08:04.1374054+01:00	95.128	1.0.0.0	VRage.Input.dll
    2017-01-22T00:08:04.1374054+01:00	662.424	1.0.0.0	VRage.Library.dll
    2017-01-22T00:08:04.1434130+01:00	513.432	1.0.0.0	VRage.Math.dll
    2017-01-22T00:08:04.1494185+01:00	76.696		VRage.Native.dll
    2017-01-22T00:08:06.7557330+01:00	103.320	1.0.0.0	VRage.OpenVRWrapper.dll
    2017-01-22T00:08:04.1594287+01:00	327.064	1.0.0.0	VRage.Render.dll
    2017-01-22T00:08:04.1594287+01:00	864.664	1.0.0.0	VRage.Render11.dll
    2016-01-11T08:42:57.2847549+01:00	64.512	2.2.0	WPFLocalizeExtension.dll
    2016-01-11T08:42:57.2857549+01:00	26.624	1.1.6.3	XAMLMarkupExtensions.dll
    
    System.TypeInitializationException: Der Typeninitialisierer für "SEToolbox.Interop.SpaceEngineersCore" hat eine Ausnahme verursacht. ---> System.IO.FileNotFoundException: Die Datei oder Assembly "InfinarioSDK, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.
      bei Sandbox.Engine.Analytics.MyInfinarioAnalytics..ctor(String accessToken, String gameVersion)
      bei Sandbox.Engine.Analytics.MyInfinarioAnalytics.GetOrCreateInstance(String accessToken, String gameVersion)
      bei SpaceEngineers.Game.SpaceEngineersGame.FillCredits()
      bei SpaceEngineers.Game.SpaceEngineersGame.SetupPerGameSettings()
      bei SEToolbox.Interop.SpaceEngineersCore..ctor() in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\Interop\SpaceEngineersCore.cs:Zeile 42.
      bei SEToolbox.Interop.SpaceEngineersCore..cctor() in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\Interop\SpaceEngineersCore.cs:Zeile 20.
      --- Ende der internen Ausnahmestapelüberwachung ---
      bei SEToolbox.Interop.SpaceEngineersCore.LoadDefinitions()
      bei SEToolbox.CoreToolbox.Load(String[] args) in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\CoreToolbox.cs:Zeile 181.
      bei SEToolbox.App.OnStartup(Object sender, StartupEventArgs e) in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\App.xaml.cs:Zeile 94.
      bei System.Windows.Application.OnStartup(StartupEventArgs e)
      bei System.Windows.Application.<.ctor>b__1_0(Object unused)
      bei System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
      bei System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
    
     
    • Informative Informative x 1
  2. CrazyEd Trainee Engineer

    Messages:
    87
    I can confirm, since Dev 171.002 I get the same error

     
    • Informative Informative x 1
  3. xpgx1 Trainee Engineer

    Messages:
    8
    I have exactly the same problem. SEToolbox is invaluable & essential for me ;D
    I will provide the logfile when I find it ;/
     
  4. Everwake Trainee Engineer

    Messages:
    60
    sometimes finding a relevant search hit in google is a bad thing, I have the exact samt issue
     
  5. midspace Senior Engineer

    Messages:
    2,224
    Thanks. I'll be looking at it tonight.

    It looks like Keen have made a hard dependency on another file, "InfinarioSDK.dll".
    At a guess, copying the "InfinarioSDK.dll" file from the game directory into the SEToolbox directory might get it working.
    I'll be looking at it regardless, as it might be more broken.
    --- Automerge ---
    Version 01.168.006 Release 1 is up. Download the latest from here.
    • Fixed issue working with current Develop branch. There are 2 new file dependencies from the Space Engineers runtime.
     
    • Like Like x 2
  6. CrazyEd Trainee Engineer

    Messages:
    87
    Thank you !
     
  7. KillBill Trainee Engineer

    Messages:
    12

    Hey, thanks! :) Great work !
     
  8. rexxar Senior Engineer

    Messages:
    1,530
    @midspace Better to just disable Infinario. Before you init Sandbox, set MyFakes.ENABLE_INFINARIO false, and it should take care of it.
     
  9. midspace Senior Engineer

    Messages:
    2,224
    Unfortunately it's a type dependency somewhere in the game, so it's needed even if it's turned off.
     
  10. rexxar Senior Engineer

    Messages:
    1,530
    Well that's dumb :p
     
  11. nonamefromuk Trainee Engineer

    Messages:
    1
    thanks mate let me try this out
     
  12. FlakMagnet Senior Engineer

    Messages:
    1,551
    Is there a current version of the game that this still works with?

    I really need to upload some models to convert to blocks, and all I can get is fails.
     
  13. Clanner Jake Apprentice Engineer

    Messages:
    197
    really hope the tool didn't die out- i rather enjoyed it. i used it to find my tools floating away after i died- no joke. :) but now i'd just like to try and align my blueprints with. unless keen adds a block that helps projectors place your BP properly, this is the best option for me i'd think. kinda sad its not working.
     
  14. CrazyEd Trainee Engineer

    Messages:
    87
    Seems to work just fine on the latest 179 version of the game, as long as you acknowledge the dialog stating that "the game version has changed, allow update"
    You can still do all the cool stuff, clearing out junk, locating stuff, importing stuff (including 3D models - though my mileage has varied depending on what I'm attempting to import.... )

     
  15. FlakMagnet Senior Engineer

    Messages:
    1,551
    Yeah....I get as far as that, then it crashes with an error when it tries to update. I'll give it another try maybe....but when I tried a couple of days ago....failure.
     
  16. Zinlu Trainee Engineer

    Messages:
    10
    I was having troubles getting it started as well. It would give the update prompt, clicking yes there would bring up the uac prompt. After clicking yes on the UAC prompt, it would work for a few seconds then pop back up the update notice. If I clicked no on the UAC prompt SE Toolbox would error out with a message (that I didn't think to copy, sorry!), or windows would bring up the "SE Toolbox has stopped working. Looking for a solution" window.

    I deleted all the files in my SE Toolbox folder (D:\SE Toolbox), redownloaded, reinstalled, and it works now.

    Hopefully others may have the same luck.
     
  17. FlakMagnet Senior Engineer

    Messages:
    1,551
    I will try uninstalling and re-installing a fresh version. If you guys can get it working...it MUST work :)

    HOOYAH!!!!

    Proper unionstall, and fresh download and reinstall...and it seems to have fired up OK :)
     
    Last edited: Mar 24, 2017
    • Like Like x 1
  18. midspace Senior Engineer

    Messages:
    2,224
    The current version of SEToolbox continues to work with 1.179 of Space Engineers.

    I really have had no time to work on it of late. Apart from a few minor patches to a couple of mods I haven't had any time.
    My employer moved the office and I have to travel a lot further now, and soon they'll be locking down the internet in the office, so I basically will not have access to SE stuff at work.
    I am practically at the stage I can not continue improving SEToolbox.
    At most I can fix small issues that Keen throw at it on my weekend, but I can no longer provide enhancements.

    If you know anyone who would like to work on SEToolbox, get them to send me a PM.
     
  19. FlakMagnet Senior Engineer

    Messages:
    1,551
    @midspace ..no worries. I just really appreciate what you HAVE done, and how much work you have put in on the tool to keep it alive through so many game changes. It's a great tool to place objects for scenarios, a great way to tidy up the mess in a scenario and add/remove stuff, and also handy for creating custom asteroids in odd shapes and importing meshes that are turned into blocks. I use that as an outline tool for largescale builds so I can get the scale and proportions in a 3D program and translate that outline to blocks. Wish I had thye skills to carry on the work.....but my programmimg ability is limited to very basic Java and that's it.
     
  20. Don Jacobs Junior Engineer

    Messages:
    657
    @midspace I've run into an issue with SEToolbox and my Anti-Virus. It doesn't like it, and slapped the .exe into quarenteen. Something about Trojan.GenericKD.4652852.

    Should I just ignore this? It hasn't been a problem before, and may be because of updated virus defs.
     
  21. midspace Senior Engineer

    Messages:
    2,224
  22. Don Jacobs Junior Engineer

    Messages:
    657
    My AV is Bitdefender. If Kaspersky is also having a false positive, then maybe that Trojan mentioned is using code similar to something inside SET :<
     
  23. midspace Senior Engineer

    Messages:
    2,224
    If I run the current SEToolbox.exe through https://www.virustotal.com, 17 products including Kaspersky list it as having a virus.

    If I recompile SEToolbox and run a newer SEToolbox.exe, only 9 products list it has having a virus. Kaspersky is not one of them this time.

    I'm not sure what to do.
    The code is open source, so it's open to inspection.
     
    • Like Like x 1
  24. Don Jacobs Junior Engineer

    Messages:
    657
    Yea, I agree, it's rather bizarre. Means the offending Trojan is using something, possibly a linked asset, that's the same as SET.

    To me, it's totally stupid for it to happen, but there you have it. :/
     
  25. CrazyEd Trainee Engineer

    Messages:
    87
    All good hacking tools are frowned upon by dim whitted anti virus apps, not really but it's a great tool, and so far my AV has no issues with it, I must be using a junk one
     
  26. midspace Senior Engineer

    Messages:
    2,224
    I got a response back from Symantec who have tested it, and are going to whitelist the app, but it will only be that specific version. I would need to follow up with later versions when they are released.
    I have had no response back from Kaspersky.
    A few of the other providers when I looked at logging a false positive by their product, their websites directed me to Kaspersky. :stare:
     
  27. midspace Senior Engineer

    Messages:
    2,224
    Version 01.179.001 Release 1 is up. Download the latest from here.

    This release only contains 2 superficial changes to the code, however it appears to raise zero false flags with the anti-virus applications.
    It has been suggested that maybe someone reported the previous SEToolbox.exe and it has gotten onto some bad lists.
     
  28. Azunai Trainee Engineer

    Messages:
    11
    Last edited: Apr 12, 2017
  29. midspace Senior Engineer

    Messages:
    2,224
    Sorry, dropbox removed the default public folder for all users recently.
    Any links to shared files need to be recreated, so here is the new link.
    https://www.dropbox.com/s/0cbk9y72o07xpis/SE-VoxelMaps-v59.zip?dl=1
     
    Last edited: Apr 19, 2017
    • Like Like x 2
  30. Omen964 Trainee Engineer

    Messages:
    16
    Code:
    2017-06-01 22:26:08,776 [1] FATAL SEToolbox.Support.DiagnosticsLogging [(null)] - Unhandled Exception
    Application: C:\Users\%USERNAME%\AppData\Roaming\SpaceEngineers\SEToolBox\SEToolbox.exe
    CommandLine: "C:\Users\%USERNAME%\AppData\Roaming\SpaceEngineers\SEToolBox\SEToolbox.exe" 
    CurrentDirectory: C:\Users\%USERNAME%\AppData\Roaming\SpaceEngineers\SEToolBox
    SEBinPath: E:\SteamLibrary\SteamApps\common\SpaceEngineers\Bin64
    SEBinVersion: 1.181.56
    ProcessorCount: 8
    OSVersion: Microsoft Windows NT 6.1.7601 Service Pack 1
    Version: 4.0.30319.42000
    Is64BitOperatingSystem: True
    IntPtr.Size: 8
    IsAdmin: False
    CurrentUICulture: en-US
    CurrentCulture: en-US
    
    Files:
    2017-06-01T20:04:18.0474452+02:00	21,905,968		HavokWrapper.dll
    2017-06-01T22:14:02.6466988+02:00	498,176	2014.2.17.1	HelixToolkit.Wpf.dll
    2017-06-01T22:14:02.6636998+02:00	200,704	0.86.0.518	ICSharpCode.SharpZipLib.dll
    2017-06-01T20:04:17.8174320+02:00	34,864	1.0.0.0	InfinarioSDK.dll
    2017-06-01T22:14:02.6937015+02:00	301,056	1.2.13.0	log4net.dll
    2015-05-01T00:12:33.3729419+02:00	660,128	12.00.21005.1 built by: REL	msvcp120.dll
    2015-05-01T00:12:32.9389171+02:00	963,232	12.00.21005.1 built by: REL	msvcr120.dll
    2017-06-01T20:04:17.9844416+02:00	68,144	1.0.0.0	Sandbox.Common.dll
    2017-06-01T20:04:18.0444450+02:00	6,558,768	1.0.0.0	Sandbox.Game.dll
    2017-06-01T20:04:18.0374446+02:00	342,064	1.0.0.0	Sandbox.Graphics.dll
    2017-06-01T22:14:02.7577052+02:00	1,184,256	01.179.001.1	SEToolbox.exe
    2017-06-01T22:14:02.7757062+02:00	745		SEToolbox.exe.config
    2017-06-01T22:14:02.8157085+02:00	27,136	1.0.0.0	SEToolbox.ImageLibrary.dll
    2017-06-01T22:14:02.8517105+02:00	7,680	1.0.0.0	SEToolbox.ImageShaders.dll
    2017-06-01T22:14:02.8917128+02:00	1,994,240		SEToolbox.pdb
    2017-06-01T22:14:02.9257148+02:00	51,200	1.0.0.0	SEToolboxUpdate.exe
    2017-06-01T20:04:18.0444450+02:00	269,872	3.1.0	SharpDX.dll
    2017-06-01T20:04:18.0524455+02:00	386,096	1.0.0.0	SpaceEngineers.Game.dll
    2017-06-01T20:04:18.0524455+02:00	53,808	1.0.0.0	SpaceEngineers.ObjectBuilders.dll
    2017-06-01T20:04:18.2224552+02:00	11,036,720	1.0.0.0	SpaceEngineers.ObjectBuilders.XmlSerializers.dll
    2017-06-01T20:04:18.1034484+02:00	549,936		SteamSDK.dll
    2015-03-19T21:45:30.0321742+01:00	105,152	02.19.34.93	steam_api.dll
    2015-03-19T21:45:32.0522897+01:00	119,488	02.19.34.93	steam_api64.dll
    2017-06-01T20:04:18.1034484+02:00	302,128	1.0.98.0	System.Data.SQLite.dll
    2017-06-01T22:14:02.9377155+02:00	39,936	2.0.20525.0	System.Windows.Interactivity.dll
    2017-06-01T20:04:18.1044485+02:00	72,240	1.0.0.0	VRage.Audio.dll
    2017-06-01T20:04:18.1044485+02:00	410,160	1.0.0.0	VRage.dll
    2017-06-01T20:04:18.1094488+02:00	980,528	1.0.0.0	VRage.Game.dll
    2017-06-01T20:04:18.1634518+02:00	3,290,672	1.0.0.0	VRage.Game.XmlSerializers.dll
    2017-06-01T20:04:18.1104488+02:00	96,816	1.0.0.0	VRage.Input.dll
    2017-06-01T20:04:18.1104488+02:00	667,184	1.0.0.0	VRage.Library.dll
    2017-06-01T20:04:18.1114489+02:00	517,168	1.0.0.0	VRage.Math.dll
    2017-06-01T20:04:18.1634518+02:00	78,384		VRage.Native.dll
    2017-06-01T20:04:18.1634518+02:00	105,008	1.0.0.0	VRage.OpenVRWrapper.dll
    2017-06-01T20:04:18.1654520+02:00	331,312	1.0.0.0	VRage.Render.dll
    2017-06-01T20:04:18.1654520+02:00	891,952	1.0.0.0	VRage.Render11.dll
    2017-06-01T22:14:02.9717174+02:00	64,512	2.2.0	WPFLocalizeExtension.dll
    2017-06-01T22:14:02.9837181+02:00	26,624	1.1.6.3	XAMLMarkupExtensions.dll
    
    System.TypeInitializationException: The type initializer for 'SEToolbox.Interop.SpaceEngineersCore' threw an exception. ---> System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
       at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
       at System.Reflection.Assembly.GetTypes()
       at VRage.ObjectBuilders.MyObjectFactory`2.RegisterFromAssembly(Assembly assembly)
       at VRage.Game.ObjectBuilder.MyGlobalTypeMetadata.RegisterAssembly(Assembly assembly)
       at VRage.Game.ObjectBuilder.MyGlobalTypeMetadata.Init()
       at Sandbox.MySandboxGame..ctor(VRageGameServices services, String[] commandlineArgs)
       at SEToolbox.Interop.SpaceEngineersCore..ctor() in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\Interop\SpaceEngineersCore.cs:line 49
       at SEToolbox.Interop.SpaceEngineersCore..cctor() in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\Interop\SpaceEngineersCore.cs:line 20
       --- End of inner exception stack trace ---
       at SEToolbox.Interop.SpaceEngineersCore.LoadDefinitions()
       at SEToolbox.CoreToolbox.Load(String[] args) in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\CoreToolbox.cs:line 181
       at SEToolbox.App.OnStartup(Object sender, StartupEventArgs e) in D:\Development\GitHub\SEToolbox\Main\SEToolbox\SEToolbox\App.xaml.cs:line 94
       at System.Windows.Application.OnStartup(StartupEventArgs e)
       at System.Windows.Application.<.ctor>b__1_0(Object unused)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
    
     
Thread Status:
This last post in this thread was made more than 31 days old.