Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Emissive and Collision model issues (mostly solved/updated thread)

Discussion in 'Modding' started by captainbladej52, Sep 30, 2019.

  1. captainbladej52 Apprentice Engineer

    Messages:
    374
    Got a couple issues I'm hoping my fellow modders will be able to help me out with. Working on a new model for a mod and running into some cosmetic issues as well as collision issues. A basic screenshot of the test model can be found here:

    The first issue involves the cylinders as I wanted all 4 of them to be emissive and display as green or red when the block is getting power. First is there a basic set of emissive materials that I can bs for this kind of stuff? The other issue that can be seen is the access for the terminal works but there is no holographic screen or keyboard that can be seen. The terminal functions but cosmetically I can't see the keyboard or screen for the control panel. Is there a specific thing I have to assign aside from an empty shape to make that appear?

    The last issue concerns the collision model. I had hoped it would be possible to step up onto that mini platform and access the terminal. However when I set the collision models in blender and rendered it out, the moment I touched the block it crashed to desktop. I've been approximating the shapes and using either box or cylinder for them since that's what most of the block consists of. Is there something I'm missing that's causing it to crash? Any and all help is much appreciated folks and thanks in advance.
     
  2. captainbladej52 Apprentice Engineer

    Messages:
    374
    So slight update after a little over a week. I was able to figure out the collision model issue and that is now working. Apparently I missed a few extra steps initially. I've also mostly figured out the issue with the cylinders being emissive and have gotten all 4 of them to light up. The one part of the emissive bits I've not been able to figure out is how to get it to show up as green instead of that odd yellow color. I don't mind it being yellow if I have to go that route, just doesn't look as good imo. Is there something simple I'm missing?

    The only major issue left with the model itself seems to be the terminal issue. As is right now I can access the terminal and it will work just fine. However cosmetically there is no keyboard/screen showing up. If I wanted the terminal to behave like the default vanilla ones and be able to display the default scripts, is there a way to do that, or is that not available for mods? First time attempting anything that had a terminal access so new territory if I'm asking noob questions :woot:.
     
  3. mojomann71 Senior Engineer

    Messages:
    1,706