Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Failed to publish on Steam Workshop. Make sure Steam user is logged in.

Discussion in 'General' started by ripchord, Feb 12, 2020 at 02:10.

  1. ripchord Trainee Engineer

    Messages:
    16
    Hi all,

    I'm unable to update one of my mods with the error reported as above. A few things I've checked:

    * Yeah it's my mod:
    * Thumbnail is under 0.5Mb
    * I am logged into Steam client and started SE from both shortcut and client, with restarts in between
    * Have tested with a DS instance both logged in and logged out of Steam, with restarts in between
    * Have tested with Enable Steam cloud both enabled and disabled, with restarts in between

    I have had a similar issue before but I thought killing the steam cloud thing fixed it; today I'm just out of ideas. Given I can browse all the mods, connect to servers, etc, obviously it's not actually that I'm logged out.

    Would greatly appreciate hearing the super-simple thing I've totally missed!!

    Cheers,

    jn
     
  2. mojomann71 Senior Engineer

    Messages:
    1,828
    Try verifying SE game files?

    It may fix the issue.
     
  3. Stardriver907 Master Engineer

    Messages:
    3,174
    That probably won't work. I think Steam is having issues. I'm having the same issues and nothing I do seems to matter. I haven't been able to publish blueprints or worlds for months now.
     
  4. ripchord Trainee Engineer

    Messages:
    16
    Thanks mojomann71,

    No resolution after verifying game cache unfortunately. I did find the following in the logfile:
    2020-02-13 08:09:19.932 - Thread: 1 -> Error during publishing: LimitExceeded
    2020-02-13 08:09:19.932 - Thread: 1 -> Info: Workshop item with id 1665511990 update finished. Result: k_EResultLimitExceeded

    This isn't enlightening as I've tried with and without the 319kb thumbnail (lots of reports of failed publishing due to 1Mb limit,) deleted a few of my other mods in case there's some undisclosed limit to mods, and the total package size is 4.5Mb uncompressed. While deleting I noticed several 0Mb untitled mods which are obviously failed attempts, so I deleted those too for good measure.

    Did a couple of extra things:
    * Started Steam in Administrator mode, same obviously with the client
    * Ensured no read-only access on the folders
    * Re-accepted steam agreement yet again
    * Double-checked the modinfo file was correct yet again

    I realise fully this is a steam workshop, not SE, issue. I also realise fully that steam support will tell me it's a SE issue so hoping someone else here has found a resolution :)

    It would be nice for the subscribers of my mod to get the fix as there's a bug which is a bit annoying.

    Cheers,

    jn
     
  5. mojomann71 Senior Engineer

    Messages:
    1,828
    @ripchord sorry to hear it did not help. It is the only thing I could think of. :(

    Maybe someone else out there can point you to a solution. *crosses fingers*
     
  6. SirConnery Apprentice Engineer

    Messages:
    236
    I've had that happen before. If you update many times in a short timespan that usually happens. It might be Steam's "safety trigger" so to say. So no one can spam upload and clog the servers.

    You just need to reupload under a different name.
     
  7. ripchord Trainee Engineer

    Messages:
    16
    Thanks SirConnery.

    I agree, likely to be some algorithm there. I contacted their support to confirm I didn't have any kind of account limitation or anything and got the usual "we don't offer technical support on steam workshop creations" which wasn't my issue, but anyway. As expected.

    Interestingly I managed to upload a new, unrelated mod yesterday, so just now I tried to upload a version under a different name and got exactly the same error. Also interestingly each time I try and fail a zero byte, hidden visibility mod appears. So not great. And of course I would like to update the original for anyone out there using it,

    <sigh>

    jn
     
  8. SirConnery Apprentice Engineer

    Messages:
    236
    You need to delete the metadata.mod and modinfo.sbmi files in the mod folder. One of those most likely contains the mods id. You can upload it after that under a new name.
     
  9. ripchord Trainee Engineer

    Messages:
    16
    OK,

    Resolved issue with the main mod I was concerned about, by deleting the thumbnail entirely and attempting republish. Thumbnail was identical to the one on the mod already, 319kb, but anyway.

    Unsure if other attempted publishings will keep resulting in zero byte mystery mods, or whether I won't be able to set to public again, but they're battles for another day.

    Thanks to everyone for suggestions, hopefully this thread might help someone else out. Updating with the same thumbnail = make sure steam user is logged in, apparently. Obviously.

    PS yeah thanks SirC, it's the .sbmi (actually .xml) which contains the mod name and author ID64. The metadata is just auto-generated to (I presume) make it easier to flag versions. I was pretty keen to update the existing mod as it has 1400-odd subscribers, plus I may need to update others shortly.