Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Game-breaking performance issues

Discussion in 'Gameplay Help' started by FrozenLiquidity, Jan 25, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. FrozenLiquidity Trainee Engineer

    Messages:
    4
    Hello all,

    I've been playing SE on a dedicated server with a number of friends and appear to be the only one encountering some game-stopping issues which don't appear to be related to the hardware at all. Let's get the system specs out of the way first.

    CPU: Intel Core i5 2500k @ 4.5 GHz
    RAM: 16 GB DDR 3
    GFX: 980ti
    Disk: Crucial MX300 SSD
    OS: Windows 7 x64

    I'm running at 1920x1080 with mostly medium settings - yeah, I can easily run max without an issue for the most part, but turned them down to see if there was an issue. Increased my FOV to a bit beyond 90, running in fullscreen windowed. I wasn't having any issue with the game up until recently.

    Here's the issue, every time I try to play, I get in the game and it runs fine for about 15-20 minutes 60fps, not a hitch in sight, etc. However, after about 20 minutes of gameplay, almost like clockwork, the performance tanks, the framerate appears to drop to about 10-15 fps while movement and actions stutter and hitch. No one else I am playing with is having this issue with this kind of regularity and the server performance is constant, so it's got to be a client issue. Furthermore, I can fix it (for 15-20 more minutes) simply by exiting to the main menu and rejoining the server. I've been wondering if something else I am doing was affecting it so I tried the following:

    • Restarting the Computer
    • Reinstalled the game
    • Installed the latest graphics drivers
    • Turned off secondary displays
    • Killed off the majority of background tasks
    • Played with different graphics settings
    Yet, after all of this, I can still time my sessions to about ~20 minutes each before it reaches this unplayable state. This isn't a slow degradation of performance over time, it's running fine one second, then it hitches for a second or two and becomes a slide show. I tried this on my laptop, an Asus GL551J; i7 2.6 GHz, 16gb RAM, same OS, SSD, and GTX 960M with the latest drivers and it didn't have this issue at all. Again, no one else in the same game and working in the same area is having this issue and I have not had any issues in ANY of the other games I play, but given that I'm the only one experiencing it, I'm a bit lost as to why I'm seeing these issues. Furthermore, when it occurs, it doesn't even look like my computer is having any problems with it's resources, see below:

    [​IMG]

    I made videos of the debug performance information both before and after, and from what I can see the Timings (CPU per frame (us) and CPU no sprites (us) both have more than doubled, while the FPS shows half of what it normally does. Most of the other statistics don't show any appreciable difference. On the last page, the UPS is still high (actually showed higher with the issue than without), but the FPS on this page shows a fraction of what it usually runs at, and the average frame time increases close to 10x! (~17ms to >120ms on average, and max looks like ~20ms usually, and after this occurs is over 425ms!) I can upload these videos if needed, but aside from exhibiting what it looks like with and without the issue there aren't a whole lot of differences in the actual statistics.

    This is pretty much a game-breaking and show-stopping issue which is preventing me from playing and enjoying the game - unfortunately it looks like I'm not the only one with these sorts of issues. I've gone through many of the suggested steps without anything to show for it in the way of improvements, so I am hoping someone can enlighten me or we can help identify an issue and work towards a resolution for it.

    Thanks.
     
  2. bigsteve Trainee Engineer

    Messages:
    90
    Post your spaceengineers.log pleas3

    Could it that the view distance is set a little to high?
    I have only had that sort of RAm usage when it was set to +30km.
     
  3. Ronin1973 Master Engineer

    Messages:
    4,841
    Are you running any mods on the server? Mods aren't guaranteed to be stable. Depending on the mods, the number of mods, adverse interactions between conflicting mods... you might have a nice witches brew of lag.
     
  4. FrozenLiquidity Trainee Engineer

    Messages:
    4
    Bigsteve - do you mean vegetation view distance? I have this set to minimal, and I don't see any other view distance settings. I have boosted my FOV to a bit above 90 though. I have avoided planets due to the performance issues they seem to create - I have been encountering my current situation the most on asteroids.

    See below for a log of the event.

    Ronin - Yes, I believe the server is running with mods, and I understand that these can be conflicting and have various unintended impacts on the gameplay. The fact that of the half dozen people on the server, that I am the only person who has this sort of issues with their client though, is fairly telling. The server admins have been very tight with settings to ensure good performance as well. I recall experiencing this same issue the last time I played the single player mode for any length of time too. I could probably replicate it offline without much effort.

    The issue started around 21:29 and I exited the game at 21:30
    Part 1:
    Part 2:

    I've been trying a few different things in order to isolate it though, and managed to have a session yesterday that didn't lag all night, but that's been the exception rather than the rule.
     
  5. bigsteve Trainee Engineer

    Messages:
    90
    View distance is a Server setting, it sets how much you are able to see, which mean how much data the server send to the client and keeps in memory.
     
  6. Forcedminer Senior Engineer

    Messages:
    2,227
    I second what steve says.....its at the same menu where you can add mods...before even starting the server.

    has all the checkboxes to turn on wolfs,pirates,spiders.
    theres like a drop-down menu one option is 5 "for low end machines" i think it says.
     
  7. FrozenLiquidity Trainee Engineer

    Messages:
    4
    So, just tried this again, clearly isn't the mods this time. I did the easy start on the planet and goofed around for about half an hour and saw the same behavior - after about 25 minutes or so it went from completely fine one moment to single-digit framerate the next and did not recover. Here's the tail end of that log, the drop was around 11:57-11:58

    I had an admin check the MP server and it was set to 15000 view distance. On my local game, I didn't change the option. I'll try lowering it the next time I give this a try - it was important to re-establish that this does indeed happen in single-player without mods as well.

     
  8. speedio Trainee Engineer

    Messages:
    4
    You are not alone.
    Came to the forums trying to find a solution to this exact same problem. Runs fine for 15 - 20 minutes then fps tanks to unplayable and reload the game solves it for another 15-20 minutes.
    Haven't done a lot of troubleshooting on this yet, but I'll throw in my system specs for now.
    Also, I'm playing singleplayer without mods. New game. It's been a month since you posted. I'm somewhat hopeful you have solved this and reply with a fix lol.

    cpu: intel i5 6600k / oc 4.5ghz
    mem: 16 gb ddr4
    gpu: asus 1070 gtx
    disk: 7200 rpm
    os: win10 64bit


    edit: Something a bit interesting. It happened again now and as a test I turned on vsync.
    This fixed the issue. At least temporary. Will troubleshoot more if I get the fps drop with vsync on.

    edit2: it was a temporary fix. but turning on and off vsync fixes it for another 20 minutes so the game is at least playable now.
     
    Last edited: Feb 20, 2017
  9. FrozenLiquidity Trainee Engineer

    Messages:
    4
    :D
    Well, it's good to know I'm not the only one having the issue - unfortunately I have not found any solutions for the problems I've encountered.

    I'm sad to report that I've pretty much given up on playing the game. Hopefully waiting for future patches will make the game more stable and playable, as in the sessions I've played so far there have been numerous other issues that go beyond simple lagging of this kind. This is quite unfortunate as the game shows definite promise and could be quite fun. Still, without a solution to this problem I have found other games to spend time on.

    Sorry I couldn't help you! I will try to see if I can reproduce what you saw with vsync. Not sure if I run with it on or off, but will try to throw some time at it and try toggling it when the issue occurs and report back.
     
  10. speedio Trainee Engineer

    Messages:
    4
    I suspect what gives me a temporary fix for the fps drops is just changing the graphics settings while ingame. Just toggling vsync on and off seems to fix it for a while. Performance is the same with or without vsync on.
    Haven't tried changing other graphic settings to see if that also fixes the problem temporary , but i suspect it will ;)
     
  11. bigsteve Trainee Engineer

    Messages:
    90
    Press shft+F11 three times, this bring up some client stats and a few server.
    Keep and eye on them at beginning of session then after it becomes uplayable.
     
Thread Status:
This last post in this thread was made more than 31 days old.