Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

game goes black on start

Discussion in 'Gameplay Help' started by bcrom, Jan 22, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. bcrom Trainee Engineer

    Messages:
    1
    Whenever I try to start space engineers, my laptop screen goes black after the "Space engineers now in beta" tab pops up. I can still hear game audio, and whenever I move my mouse over where buttons would be it makes the normal sounds. Steam also captures screenshots perfectly well whenever this happens.
    My laptop has an i7 6700hq and a gtx 960m, so graphics should not be the issue.
    I have reinstalled space engineers several times and the issue persists
    All my graphics card drivers are up to date
    The steam UI is disabled
    Help!
     
  2. bigsteve Trainee Engineer

    Messages:
    90
    Does your laptop have an integrated Intel graphics?
    If yes, but make sure it uses the GTX card.

    Post your spaceengineers.log too.
     
  3. Dr. Woo Trainee Engineer

    Messages:
    4
    I know what the problem is, it's easy to replicate it. If you set the came to use the integrated card it runs fine. However, if you switch it to the NVidia it doesn't load. The issue is with the mobile cards only. I've looked in the logs and it detects the card, however, if you look at the config file it doesn't populate it with the video information. You can start it using the integrated, and it will populate the config file correctly, but the second you switch it back to the NVidia in game, it will launch with the black screen again. You can force the game to load correctly, if you delete (rename) the config file, open your NVidia control panel, and switch the game to default to use the integrated. Granted it runs like crap... but does run.
     
  4. steve47antec2 Trainee Engineer

    Messages:
    55
    NVidia's latest drivers, cause problems with starmade and minecraft, they might also cause problems with SE, advise backtrack to earlier version
     
  5. Dr. Woo Trainee Engineer

    Messages:
    4
    I thought that as well. However I rolled my drivers back and still have the issue.
     
  6. steve47antec2 Trainee Engineer

    Messages:
    55
    just checked forums, found bug same as yours, it's windows scaling, display settings, set scaling to 100%
     
  7. Dr. Woo Trainee Engineer

    Messages:
    4
    What's the fix since it doesn't create the confit file correctly?
     
  8. steve47antec2 Trainee Engineer

    Messages:
    55
    windows desktop, not game config
     
  9. Dr. Woo Trainee Engineer

    Messages:
    4
    yeah, I understand that. What I'm saying is that because of this, it doesn't build the config file for the game. Once you switch to the integrated the config file is created properly. Editing it after the fact doesn't seem to help though. In short, how do we get around this so the game loads on the correct graphics card?
     
  10. steve47antec2 Trainee Engineer

    Messages:
    55
    see keen bug reports forum, screen is black on launch, workaround, this might help
     
  11. bigsteve Trainee Engineer

    Messages:
    90
    Is there a way to disable the integrated card in the motherboards bio?
     
  12. jandraelune Apprentice Engineer

    Messages:
    218
    On board chipsets can be disabled in the BIOS. On die video like APU's will disable/enable them self as needed.
     
Thread Status:
This last post in this thread was made more than 31 days old.