Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Game slowing down, also terrible costumer support

Discussion in 'Technical Help' started by blondishmist, Jul 17, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. blondishmist Trainee Engineer

    Messages:
    8
    Hello, well I am writing here because this seems to be the only place to get any support. My game is after some time of playing slows down, still 60FPS and more, but everything moves slower, which is incredibly frustrating. I experienced this bug (or what ever) few patches before and still no fix.

    Anyway I am not bothering contancting the support because it seems to ignore the emails. I've sent one some time back because of a problem my friend had (non-english speaker) and I never got a answer.

    Thanks anyone who will take time to help me. Because the dev team doesn't seem to.
     
  2. Mortisfire Apprentice Engineer

    Messages:
    148
    It's a common problem even on strong rigs. At the moment the game is extremely unoptimized. What does that mean exactly? Basically, the engine is rendering everything all the time despite whether you can see it or not. Thus, if you run the game for a while, or load map with many structures and/or asteroids it will slow down. Also, there is currently a bug where the server host will experience lag when trying to build on the grid.

    In a recent Q&A video posted here , one developer mentioned that a development version of the game was being tested which optimized the engine to render ONLY the things in view. So, hopefully we will be seeing this released soon!

    I haven't had any experience with the customer support before, but I would assume that they haven't responded to you yet because this is a general problem that all of us are experiencing. Not to mention they aren't a large team and probably receive many emails about this exact problem every day.

    At the moment all I can tell you is this is a known bug and the devs are working on it. I have heard that the use of the program Sandboxie will increase the allocated memory to the game, though I haven't used it before.

    Hope that answers a few questions.
     
  3. blondishmist Trainee Engineer

    Messages:
    8
    THANK YOU SO MUCH. What I submited was something else to the support.

    You are more helpful than this games subreddit. :D I'm gonna try the program, I was trying to turn off all my crap I have turn on (iTunes and bazillion tabs in chrome). I tried even running 720p, didn't help.

    But honestly thank you for making it clear for me :)
     
  4. Mortisfire Apprentice Engineer

    Messages:
    148
    Glad I could be of some help. Good luck with Sandboxie, but remember it's just a quick fix. The real solution will be when we get out of alpha. When all the features have been added and we have moved into beta. Thats when the real optimization can start.

    If you encounter another problem, I suggest using the search function on the Bug Reports page and see if anyone else is having the same issue as you.

    If you can't find any posts about your bug, be sure to create a new bug report post to make sure it's fixed as fast as possible. The developers check that area often.

    I hope you can still get some fun hours with your friends on space engineers. Remember, were all in this together!
     
  5. radam Senior Engineer

    Messages:
    1,207
    In the shift + f11 menu that you can get into ingame, what is your UPS (physics frames per second or updates per second) I think that under 60 it really starts to slowdown.

    The CPU does physics and some of the asteroid rendering in this game afaik, and it also doesnt seem to be as optimised for multicore cpus atm.

    As for Sandboxie, if you have a 64bit system then its not gonna matter. I have 4 gigs of ram and it uses up to 2.5, im upgrading to 8 to be safe.

    What are your PC specs?
     
Thread Status:
This last post in this thread was made more than 31 days old.