Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

HELP! I can't register at the new support tool.

Discussion in 'General' started by Lord Grey, Aug 15, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Lord Grey Apprentice Engineer

    Messages:
    354
    I tried to register for the new support tool offered by Keen, but I never got the registration E-Mail to confirm and I checkt the SPAM-Filter for it, no mail anywhere. Can someone help me getting registered for the support tool?
    I already tried two different E-Mail addresses, but nothing seems to happen. All I got was the "Sucsess. Activation mail was sent", but it never arrived.
     
    • Agree Agree x 1
  2. Malware Master Engineer

    Messages:
    9,601
    @Blitzzz333 Hi. I believe this support site registration issue is something you'd need to know about?
     
  3. Takeshi Apprentice Engineer

    Messages:
    200
    have the same issue and got no response from keen Support by using there Mail for nearly two weeks. Last response over Discord, use your google account. Didnt have a private google account (and will not have one).
    Waiting for: pleasse open a ticket on our new support page
    not funny
     
  4. AlfieUK4 Trainee Engineer

    Messages:
    65
    I had the same issue (not receiving an activation email to my personal domain) and reported it vie the old support email over 3 weeks ago, with no answer to date. I was able to get an activation email by using a throwaway email (I used guerillamail) and then changing the details once logged in, but it makes me wonder if I'm misisng other mail from Keen sites.
     
  5. Lord Grey Apprentice Engineer

    Messages:
    354
    Nice to see that I'm not complete stupid, just normal stupid. Have to try with anoter mail domain then all my GMX addresses didn't work.
     
  6. Dan2D3D Moderator

    Messages:
    1,000
    Guys!
    imo it is a bad Net passport problem.

    Some members fixed this problem by creating a Google account and regrouped all their Emails in ONE Google account to fix.


    I've tested my Google account and it worked without confirmation = Good Net Passport
     
  7. Lord Grey Apprentice Engineer

    Messages:
    354
    I don't have a Net passport, and I don't want one! Specialy not with Google. I like my private sphere. I have an Email account and this should be enought, at least that's what the register form suggests.I would be ready to use my Steam-account, but Google or Facebook are out of question.
     
    • Agree Agree x 2
  8. Blitzzz333 Keen PR Guy Staff

    Messages:
    479
    Hi Everyone,

    Thanks for reaching out to Keen and apologies for the inconvenience.

    We will investigate this issue and address it as soon as possible.

    ***In the meantime, please send support related messages to info@keenswh.com if you are currently unable to create an account for: https://support.keenswh.com/ and we will get back to you as soon as possible.

    Cheers,
     
    Last edited: Aug 16, 2018
  9. Takeshi Apprentice Engineer

    Messages:
    200
    and YES, i have checked my Spam folder.
    If you write to Keen because you didnt got the activatition Mail, please check your Spamfolder and write it also into the Mail that you have checked your Spamfolder to prevent from getting the response you should check your spam folder.
    (little bit pissed off, over two weeks login problems with the support page, somebody realy dont know how important support is?)
     
  10. Blitzzz333 Keen PR Guy Staff

    Messages:
    479
    Hi Takeshi,

    Thanks for emailing us. We have responded to your queries and are working to address this issue.

    Cheers,
     
Thread Status:
This last post in this thread was made more than 31 days old.