Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

I've not noticed an odd thing with atmo thrusters, not sure where to post about it :p

Discussion in 'General' started by DCam2016, Jun 22, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. DCam2016 Trainee Engineer

    Messages:
    33
    Hey all,

    I was trying out a few servers last night and noticed an odd thing happening. Take a look at the screen shot...

    https://steamuserimages-a.akamaihd....360/5527E69BC12E120B6533EB31D5999E299CD1E1D1/

    When accelerating the moving parts of the atmospheric thrusters are drifting out of position. The game overall was running great, nothing was lagging etc. I thought for a second that it might be a bit of desync but considering the moving parts of the thruster are purely aesthetic and the client was running perfecto I didn't see any reason for client/server comms to come into it. It's not something I've not seen before.

    This was yesterday in version 1.181.2 before today's update. I'll mess around again later with the new version and see if it's still happening.

    I didn't know if it was worth mentioning or not but hey, it doesn't hurt to pass on the info. :) If it turns out it's a bug, I can do a bit more digging and gather more relevant info for a bug report.
     
  2. Roxette Senior Engineer

    Messages:
    1,409
    Yep, it's a known issue, visual glitches like this occur in a number of situations, it's just a fairly low priority being only visual and not breaking anything other than immersion :)
     
  3. DCam2016 Trainee Engineer

    Messages:
    33
    Cool, thanks :) Yeah it didn't affect my game it all, just looked a bit bizarre :)
     
  4. Forcedminer Senior Engineer

    Messages:
    2,227
    although its only visual could it be somehow related to the way the engineer moves around in his cockpit when you accelerate?

    like when your flying machine stops do the insides of that thruster go back inside?
     
  5. DCam2016 Trainee Engineer

    Messages:
    33
    I'm not sure what you mean by 'the way the engineer moves around in his cockpit when you accelerate?' In that screenshot, it's a small ship so the only cockpit is a small grid one.

    The insides do go back inside when I stop accelerating though. It's a very fluid motion as the parts drift out of place. It's almost like the math used for the acceleration of the ship doesn't match what is used for the moving parts, like the acceleration factor is slightly behind that of the ships.
     
  6. Forcedminer Senior Engineer

    Messages:
    2,227

    yeah sorry. what i mean by engineer moving around the cockpit is when you start to fly in any direction the engineer in the first person camera view slight shifts in the opposite direction of movement due to the force.

    from what you explain about the parts is what i mean.
     
  7. Arcturus Senior Engineer

    Messages:
    1,649
    I think it is related to the other physics bugs with block subparts (i.e. exploding doors or killer doors). Atmo thrusters are just not an issue because the spinny propeller blade bits don't have collision properties.
     
  8. SilentShadow Apprentice Engineer

    Messages:
    286
    Oh good. If all my thrusters ever exploded at once...
     
  9. dispair Apprentice Engineer

    Messages:
    252
    I have seen this sort of thing before. It was a difference in code. Move the object then draw it. The other part called draw then move.

    The other explanation is that the fan is moving close to the speed of light and you are seeing a side effect of relativity... Oh wait...
     
Thread Status:
This last post in this thread was made more than 31 days old.