Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

JakeJud's Polygon Optimization Mod Project. (not currently being worked on)

Discussion in 'Released and WIP Mods' started by Jakejud, Jan 11, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Balmung Senior Engineer

    Messages:
    1,946
    You could test it, but i hope for fair play this is later not possible, because that way you could make a "wall hack" etc. (exchange blocks with "empty" one) and that is online cheating. :nono:

    And so fast could be a Post useless. ;)
     
  2. Tufst1.1 Trainee Engineer

    Messages:
    82
    Never mind, I'm not sure if it does anything with the heavy armour blocks, but as for my friends problem he did a dumb and had the settings on extreme it now works fine for him with graphics on low, and he can be around heavy armour blocks with little to no lose of fps loss compared to light armour now.
     
  3. Balmung Senior Engineer

    Messages:
    1,946
    Since this is an Alpha, a complete reinstall of the Game could do wonders. A other User had a Problem with the Motors, after reinstall they work now correct again. So it is no bad Idea to reinstall the Game from time to time (Memo: i should do that too :woot:).
     
  4. eecer Trainee Engineer

    Messages:
    11
    Could you provide some Screenshots of before and after with how everything works. My PC handles the game fairly well, but I would love to see the difference. Plus, if it still looks good, what's the point to worse performance for slightly better looks?
     
  5. Jakejud Apprentice Engineer

    Messages:
    114
    I will be working on this more when the final models are in the game.
    It just seems kind of pointless to create low poly models for things that might be replaced/changed, in the future.
     
  6. EvanBaxter52 Trainee Engineer

    Messages:
    20
    Last version of game not compatible with this mode(. I hope you fix this, dude, coz only your project made it possible- build large ships on laptops.
     
  7. Volthorne Apprentice Engineer

    Messages:
    487
    All you have to do is go into the modded polys folder (before copy/cut+pasting it to where it needs to go) and rename everything slightly.

    For example, large_antenna.mwm should now be Antenna.mwm and large_cover_wall_half.mwm should now be CoverWallHalf.mwm

    It's a bit of a tedious job, but it doesn't take very long. Also make sure to double check that you are in fact getting the names right.

    EDIT: NEVER MIND, this could take an hour minimum. I never realized there was so much crap to rename.
     
  8. EvanBaxter52 Trainee Engineer

    Messages:
    20
    haha. Thanks dude) its my fault, i did not notice that- difference in object names) nowever, thanks) Now i will continue building my ship without lags)
    EDIT. Not all blocks has been replaced even with this block rename. Coz some blocks have different names, and some of the names which are in old version, missing in new. For example, EdgeDiagonal.mwm in new version, has no analogue in the old version.
     
  9. Jakejud Apprentice Engineer

    Messages:
    114
    I promise that when a more final version of the game is release i will start over from the groud-up. I plan on making two version of this, A normal Low poly version. And A "performance at all costs" version, witch would include the lower poly collision objects. If i had all the time in the world i would make a low poly mod for ever update. But that's Unrealistic for just me, so i will keep an eye on the assets , when things look more stable I will Start work again. :D

    As far as spending an hour renaming things...... as a 3d modeler, and rigger, i have already spent MANY more hours than that JUST renaming objects. So if i find the time i shall do that.:D
     
  10. piddlefoot Senior Engineer

    Messages:
    1,182
    Thanks for all the effort you have put into this, you have made big builders in the game very happy and improved our game, cheers, your a champ.
     
  11. Xocliw Public Relations Staff

    Messages:
    2,615
    Does this still work?

    I have some friends who are using laptops and are struggling to play and this may help.
     
  12. warmachine2k Apprentice Engineer

    Messages:
    430
    does version 0.2 work with the latest version of SE? I recently converted all my stations blocks over to heavy armor but i am no longer able to achieve the low frame rate i was getting before.
     
  13. Tufst1.1 Trainee Engineer

    Messages:
    82
    The current version is now outdated with the latest updates sadly. :/ You planing on updating soon?
     
  14. trekfan42 Trainee Engineer

    Messages:
    44
    any news on a compatibility update?
     
  15. Borr Trainee Engineer

    Messages:
    2
    here is some renamed files (most of them): https://www.dropbox.com/s/watgp1awxcj5yfw/Models.zip
    should do the trick for now until Jakejud update it or devs release update with lover polys ;]
     
  16. Quark Trainee Engineer

    Messages:
    1
    When attempt to start a game with the new models i get an error saying "World file is corrupted and cannot be loaded.", does anyone have a solution?
     
  17. Xocliw Public Relations Staff

    Messages:
    2,615
    Welcome to the forums Quark :).

    This mod is outdated now, and is no longer in development because it was too much work to keep it working. This is because the game is being updated all the time so is changing continuously which makes mods go out of date very quickly. When the Devs slow down the updating process, it will become more feasible to keep mods like this running :thumb:.
     
  18. SexyPaysan Apprentice Engineer

    Messages:
    194
    You've done wonderful work Jakejud. I would like to have you permission to add your work to a common GameConfigurationTool when the modding API will be stable enough. So users could configure the game to use a selection or all of your blocks, this would be awesome to automate the process of replacing blocks!
     
  19. Micknator Trainee Engineer

    Messages:
    27
    Doesn't work with the latest (1.033) patch ... Whenever I try to load a world, it gives me an error saying that the world is corrupt and could not be loaded :(
     
  20. Xocliw Public Relations Staff

    Messages:
    2,615
    Welcome to the forums Micknator :)!

    My previous post is still valid. Unfortunately this mod is very outdated now so will not work with current version.
     
  21. Micknator Trainee Engineer

    Messages:
    27
    Thanks! :)

    Is there a way to just have some of the common blocks (armour, interior walls, ...) be more optimized without the savegames not loading? Those blocks aren't going to change anytime soon (I think).

    Or is there another way to optimize blocks/the game?
     
  22. Xocliw Public Relations Staff

    Messages:
    2,615
    The thing is, I don't actually know what's stopping it from working :(. There's a good chance that all the blocks or the structure of them has changed slightly.

    At some point, the Devs plan to optimise all the models, removing waste polygons and we will also hopefully see a "Low" option in the graphics settings :thumb:. But for now, there's nothing that can be done except start this mod from scratch.
     
  23. joebopie Apprentice Engineer

    Messages:
    296
    +1 to this
    really hoping this gets updated soon. I just wish I had the chance to see the improvements. Ive only just seen the thread.
    ether that or I hope the devs update soon.
    wouldn't changing the 3d models be the easiest thing to do within the game? I mean this guy did it, like he said with no programing knowledge (correct me if im wrong im no 3d artist or programmer)
     
  24. Jakejud Apprentice Engineer

    Messages:
    114
    Yep! I'm no programmer at all. what i remember from doing this project, is that had issues with blocks like containers. I couldn't get the terminals working. I Would like to start this one over again within the next couple of months. Have just been busy as of late. A lot of blocks have terminals now... so I'm not sure how to work around that, or if it was just something super easy i missed last time. Oh well, I will have to do some research and testing when I start.
     
  25. voicesdark Senior Engineer

    Messages:
    2,208
    You could always just get a program like the "Razer Game Booster" that shuts down all non-essential processes while you have it in gaming mode to get some better performance out of an older/slower system.
     
  26. Xocliw Public Relations Staff

    Messages:
    2,615
    Good to hear from you Jakejud :). You only have to look at the last few pages to see how much people have missed you and your mod ;)!
     
  27. joebopie Apprentice Engineer

    Messages:
    296
    it seems that this games biggest problems in rendering all those pollys so its basically the GPU that is the restricting part. and due to a lack of optimisation it seems that even very good graphics cards can struggle. so shutting down processes (for most) will probably do next to nothing.
     
  28. joebopie Apprentice Engineer

    Messages:
    296
    I really wish I knew how to program for this game I would happily spend hours to get this working for all objects.
    it would still be a massive help im sure if its only armour blocks as you said its most of a ship anyway.
     
  29. voicesdark Senior Engineer

    Messages:
    2,208
    Yeah but there are a few of the programs like that one that can offset some of the load to the CPU instead. don't remember off the top of my head if Game Booster does or not.
     
  30. joebopie Apprentice Engineer

    Messages:
    296
    if that is the case that is very interesting, especially for people like me with a good CPU but average GPU, I will have to look into that.
     
Thread Status:
This last post in this thread was made more than 31 days old.