Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Large-Small Rotor "trick" No longer working?

Discussion in 'General' started by Captain Broadstairs, Sep 2, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Captain Broadstairs Apprentice Engineer

    Messages:
    469
    Recently I noticed that a ship which I had been building to fire small grid torpedoes had a part missing when I copied and pasted. Whenever I pasted the blueprint the small rotors, which had previously been in place quite in a stable fashion for hundreds of previous copy and paste instances, simply fell off and with the small rotors the projectors and launchers fell off with them.
    Which is very frustrating because it makes a major point of the ships design and function redundant, although I am sure other weapons systems can be installed instead with a little applied effort.

    Has anybody else noticed any similar problems or is it just me?
     
  2. DDP-158 Master Engineer

    Messages:
    3,748
    With my understanding of what is being conveyed here, everything small ship that is attached to a small rotor is not appearing on a large grid ship correct?

    Answer 1: each part is a seperate grid and must be pasted seperately. Copying a ship with multiple grids will only paste the main body of the ship.

    Anewer 2: if you are pasting them seperately and they aren't sticking try clicking the attach button for the large rotor in question (in the menu), then click it again. The external part should then attach.
     
  3. tankmayvin Senior Engineer

    Messages:
    2,864
    Mine are pasting in fine but promptly exploding........
     
  4. Loues S. Cat Apprentice Engineer

    Messages:
    143
    Hmm. All seems to be working for me... Oh hold sweet mother of all rotor explosions!
    ...
    Yeah, working the same as always.
     
  5. DDP-158 Master Engineer

    Messages:
    3,748
    Answer 3: bring your unseething rage to the forum and unleash it in a 8 paragraph long post. Be sure to include phrases like 'do the devs even know about this?','this game is unplayable', and 'this game will go the way of mw'. Wait for this is alpha comments.
     
    • Funny Funny x 7
  6. tankmayvin Senior Engineer

    Messages:
    2,864
    But seriously....is anyone else having issues with rotor/piston multi grids exploding on paste?
     
  7. KingdomBragg Junior Engineer

    Messages:
    544
    I've not tried it with large and small multigrid but when copy pasting there is a bug whereby the pasted stator tries to attach to the original rotor head. The super-magnet like attraction between the original and copy pasted ship promptly summons Clang to destroy both. It has been reported in the bug reports section.
    This gif by @Whiplash141 demonstrates the problem better:

     
    Last edited: Sep 2, 2016
  8. Phoera Senior Engineer

    Messages:
    1,713
    Copy paste always worked, projectors limited to one grid, not copy-paste.
    that bug was make me nuts one time, when i builded train.
    cuz i cannot attach second pair of wheels to it on earth.
    (nearly 10 tryes it took for me in space, but even then, huge force was applyed and i was forces to catch my train :D)
    --- Automerge ---
    about topic, i think there is still bug with rotor attachments:(
     
    • Agree Agree x 1
  9. Captain Broadstairs Apprentice Engineer

    Messages:
    469
    I've seen this happen as well, one of two things happens when i paste the Ship, the rotors fall off, or the ship is possesed by clang and hurled violently into the next solar system.

    To be honest I'm sort of glad its not just me, because I wan't sure if it was a mod set up or a block ownership issue.
     
  10. tankmayvin Senior Engineer

    Messages:
    2,864
    I'm getting this on pretty much every rotor build right now. It's well behaved in the game world but it goes clang if you try to work on it with copy/paste. I cannot have two of the same rotor turret in a world, or two of the same rotor merged missile printer or the ship explodes.
     
    • Agree Agree x 1
  11. KingdomBragg Junior Engineer

    Messages:
    544
    Seems the only workaround till the bug is fixed is to use cut and paste instead of copy and paste.
     
  12. tankmayvin Senior Engineer

    Messages:
    2,864
    Doesn't work so well if you're designing a multi-cell missile launcher or trying to place several turrets on a ship, which is mostly what I use rotors for.
     
    • Agree Agree x 1
Thread Status:
This last post in this thread was made more than 31 days old.