Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Local Hosted Game: Different Version Of Game Bug

Discussion in 'Bug Reports' started by ThatSuspiciousGuy, Jul 17, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. ThatSuspiciousGuy Trainee Engineer

    Messages:
    1
    I hosted a game for me and my friend to play on, and it seemed to work fine. But when we tried to play on it the next day, he got this error message:

    "Server has different version of the game. Your version: 01_110_008; Server version: 00_000_000"

    We tried restarting the game, Steam, and even our computers, but to no avail. I created a new save, but he got the same error message. So, I told him to host a server. And guess what?

    "Server has different version of the game. Your version: 01_110_008; Server version: 00_000_000"

    Does anyone know what causes this bug and how to fix it? My friend and I can no longer play on any saves together because of this error, so any help would be very appreciated.
     
  2. Veritas Apprentice Engineer

    Messages:
    143
    This bug is back in version 01_183_301. Roughly 50-60% of the time I try to join my friend's locally hosted game, I get this error. Reloading sometimes fixes it, sometimes not. Some days I can join just fine, other days I am locked out for the whole day. Any suggestions?

    We play on one specific save that he hosts (a Mars Easy Start that we ignored the starting base on).
     
  3. w0lf3y Apprentice Engineer

    Messages:
    151
    When I join a hosted MP I occasionally encounter this as well. When it happens, i ask the host to reload the map. It has always 100% reliably fixed the issue and I am able to join normally after he reloads.
    Only suggestion I could offer is to go a bit further and restart steam, and SE before trying to rejoin the map.
     
  4. I23I7 Tester Staff

    Messages:
    3,584
    Does this happen regularly on that save?
     
Thread Status:
This last post in this thread was made more than 31 days old.