Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version [Extra] --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Merged pistons, weird visual

Discussion in 'Bug Reports' started by vampsnit, Jul 16, 2017 at 11:32.

  1. vampsnit

    Joined:
    Jul 28, 2014
    Messages:
    6
    Trophy Points:
    47
    I originally posted for some help here: https://forums.keenswh.com/threads/merging-pistons-explode-what-am-i-doing-wrong.7396058/

    Conclusion was me mainly being stupid, but also a strange bug (i think)

    See picture below. I was building a simple door with 2 pistons, which I merged together with merge blocks. I had accidentally left Piston 1 on a 3m limit, but told the piston group to extend fully (which the group thought was 10m)

    When Piston 2 went above the 3m limit, it caused a really strange visual issue of both piston heads sliding off their respective pistons, and the door attached to those (rightly) skewed. However, neither of them broke/detached. When I lowered it back to 0, they sort of slid back in to place and I could fix the limits

    So there are 2 bugs here I think:

    1. The piston heads are not breaking/detaching even when they are being heavily bent by the higher piston, which causes a visual bug of them being detached, while still being technically attached

    2. The default limits when creating group of pistons should probably be the lowest for the upper limit and highest for the lower limit

    [​IMG]