Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Need help with Merge="Append" to ProceduralEnvironment please.

Discussion in 'Modding' started by Köbi 2, Dec 6, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Köbi 2 Apprentice Engineer

    Messages:
    135
    So I want to update my plants mod, but I cant make them spawn. I dont just want to overwrite the original ProceduralEnvironment again, but use that beautiful new thing you made. But I dont can get it to work... I dont know whats wrong. Please help.

    I tried like this. (And alot of other ways.)

    <Definition xsi:type="MyObjectBuilder_ProceduralWorldEnvironment" Merge="Append">
    <Id Type="ProceduralWorldEnvironment" Subtype="SecondEarthEnvironment" />

    <!-- Maximum lod until sectors are synchronized -->
    <MaxSyncLod>1</MaxSyncLod>
    <SectorSize>40</SectorSize>

    <ScanningMethod>Random</ScanningMethod>

    <ItemTypes Type="MyObjectBuilder_EnvironmentItemTypesDefinition" Subtype="Default"/>


    <!-- My Group whit the moded plants I want to add to the procedural environment. -->

    <ItemGroup Density=".09" Name="PlantsModWorld" LodStart="-1" LodEnd="1">

    <!-- Subarctic belt (tundras) -->
    <Mapping>
    <Biome>140</Biome>
    <Material>Woods_grass</Material>
    <Item Type="Gatherable" Subtype="WildLeek" Density="0.0005"/>
    <Item Type="Gatherable" Subtype="WildGarlic" Density="0.0005"/>
    <Item Type="Gatherable" Subtype="WildMangold" Density="0.0005"/>
    </Mapping>

    etc...
    --- Automerge ---
    So maybe I have to unlock them via Tutorial too? I will try that... you never know.
     
  2. Sir_Moodz Apprentice Engineer

    Messages:
    377
    You use Merge and a new Subtype, how does it know what the original is? You have to use Copy
     
  3. Köbi 2 Apprentice Engineer

    Messages:
    135
    Thanks SirMoodz. I didnt wanted to create my own new definition but add to the original. (I think I tried copy merge too.)

    However I am pretty sure, that merge, copy append etc. only work on the new Definitions (like research) and all the others would need to be rewritten first. (If someone confirms that it is possible, I will try again.)

    Oh. Btw. The pallets for the ingots still dont work for me. :)
     
  4. Sir_Moodz Apprentice Engineer

    Messages:
    377
    I fixed that ingot pallet :)

    The only problem is that the new ingots are positioned and rotated completely different.
    The artist did not set the origin and rotation correct I think... :(
     
  5. Köbi 2 Apprentice Engineer

    Messages:
    135
    I still cannot find that ingot pallet... Dont know where. It is in the g-menu though.
     
Thread Status:
This last post in this thread was made more than 31 days old.