1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

No Asteroids, Dedicated Server

Discussion in 'Groups & Dedicated Servers' started by Amorean, Oct 2, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Amorean

    Amorean Trainee Engineer

    Messages:
    5
    Downloaded Space Engineers Dedicated Server from Steam>Library>Tools and am able to get a game to run just fine. However, When I select Star System as a map there are no Asteroids! I have searched everywhere with no luck. I have changed the "Procedural Seed" to a random number and even changed it to "0" with no success as well "Procedural Density" to 0.5 and even tried 1.0 still no success. I even tried changing "Asteroid Amount" to random number trying to get Asteroids to spawn I have tried many combinations with these three settings. My research shows these are the settings that control asteroids. When I use the UI for Dedicated server and select Star System I can see the first two settings in the Environment tab, but no matter the values I put it in it will not generate asteroids. Even the default values will not work. Am I missing something important? What am I doing wrong or is this just broken?
    --- Automerge ---
    I have tried changing these values in both the Dedicated UI and the SpaceEngineers-Dedicated.cfg in my appdata. Nothing seems to work to get asteroids into star system map.
     
  2. Roxette

    Roxette Senior Engineer

    Messages:
    1,546
    Are you searching in spectator mode ? You won't see them that way, they only render when you are physically there.
     
  3. Amorean

    Amorean Trainee Engineer

    Messages:
    5
    No I log into the game as any normal player would. All I see is the planet and their moons.
     
  4. Roxette

    Roxette Senior Engineer

    Messages:
    1,546
    Shut down the server, then verify the procedural density setting is the same (between 0.5 and 1) and the seed number (0 - 65535) in all three places:

    SpaceEngineers-Dedicated.cfg
    Sandbox.sbc
    Sandbox_config.sbc

    the "Asteroid Amount" setting should be 0 or unexpected results may occur, because Keen - although I've never seen that cause a problem.
     
  5. Amorean

    Amorean Trainee Engineer

    Messages:
    5
    Thank you! That worked the settings where not saving to:

    Sandbox.sbc
    Sandbox_config.sbc

    They did save to:

    SpaceEngineers-Dedicated.cfg

    Also the Seed values where very helpful, thank you again!
     
Thread Status:
This last post in this thread was made more than 31 days old.