Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version [Extra] --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

No more Backups (Filename too long)

Discussion in 'Bug Reports' started by ko2i4s, Jan 7, 2017.

  1. ko2i4s

    Joined:
    Jan 6, 2017
    Messages:
    1
    Trophy Points:
    1
    Hi all,

    First of all, thanks to KSH for this great game !

    But, me and my friends are experiencing an annoying "bug" :

    The backups of our dedicated server won't work properly (since the last update?), only the two first files are copied : "Alien-612...000.vx2" and Asteroid_4_4...996.vx2"
    So seeing this, we have tried to manually copy the third file who is : "Earthlike-50....0-0.vx2" complete name here : https://gyazo.com/1450d9ba16f6a747ed59e1a5d89cff2a, and we had the "filename too long" error from Windows 10 (255 caract). Screenshot : https://gyazo.com/16b304907c72ef8d3a50b46778547f82 :(

    - We have tried to enable longfilesnames with gpedit.msc : no success
    - Delete some "0" from the file : no success, really ? :D
    - Modify <LoadWorld> option in the SpaceEngineers-Dedicated.cfg, for something like this : <LoadWorld>C:\SEBackups\World Dedicated</LoadWorld
    but the server was still loading the world in the %appdata% folder... :(

    [Edit] : Maybe another interesting information : We launch our server with -console argument

    Any Ideas ? Thanks and sorry for bad english :p
     
    Last edited: Jan 7, 2017
  2. damien207

    Joined:
    Jul 5, 2017
    Messages:
    2
    Trophy Points:
    1
    You can try "Long Path Tool" program that fixes file name too long issues effectively.