Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Pressurization lag - need advise to resolve

Discussion in 'General' started by Veritech, Jan 2, 2019.

  1. Veritech Trainee Engineer

    Messages:
    21
    Ok, I didn't know if this would be considered a bug, so I felt General discussion was my best bet. So here's the situation. I'm building a carrier in space (Interior is about 2/3 done). Recently, when I closed up another room to be pressurized, the game has started to lag when ever I open/close a door with a pressurized room on one side or both sides. When i disable Airtight Pressurization in world settings this corrects the issue. What can I do to resolve this and still keep pressurization enabled?
     
  2. Burstar Apprentice Engineer

    Messages:
    394
    How big is this Carrier? Are you playing SP or MP? Mods?
     
  3. Veritech Trainee Engineer

    Messages:
    21
    It's a big carrier, I don't even have all its dimensions flushed out yet. I'm currently playing a single player game (Not online). Try taking one of Keen's vanilla fighters (The ones you start with in some worlds) and multiply it by 9, side by side and you have the carrier's approximate width. The biggest room in the ship are the cargo bay, production and engineering, each about the same width as the carrier. Current pcu is 92,327. As for mods, I have several mods in the game but only 1 is currently physically on the ship and that's the Conveyor air vent by Digi.
     
  4. J-Cataclism Trainee Engineer

    Messages:
    16
    I dare to say the computer resources needed to calculate the amount of time - and - oxygen needed to pressurize a room follow the same pattern of that used to search for ores in a greater distance. In this latter case, I´ve seen textures going messed, blocks becoming invisible and a bunch of lagging while the ore detector (overclocked, in this case) is active. And I play only SP-offline. I believe it´s most likely the same case with your airtighting issues: to many PCUs to calculate every time. In that case, maybe there is no solution except more RAM memory. Maybe.

    You might try and perform some kind of test, if you haven´t already made it: deactivate the air vent(s). Then, close all the doors and just after go there and re-activate the vent. Maybe it will help to see if the lag comes for the calculation for pressurization itself, or if it has something to do directly with the doors.
     
  5. Burstar Apprentice Engineer

    Messages:
    394
    Hhmm. Your ships PCU count is below the 100k specification for MP so I'm tempted to call this a bug. My only reservation is that the mod that you're using is an air vent mod directly related to pressurization. I'd save a backup, disable that mod, and test to see if ugly intrusive vanilla vents solve the lag. If so, there's your culprit. If vanilla still has the problem, post a bug on their support site (link stickied in these forums) and be sure to include the world save.
     
    • Agree Agree x 3
  6. Veritech Trainee Engineer

    Messages:
    21
    Ok, I'll remove the air vent hub and see if that works. Shouldn't be hard since I only use them so it doesn't look like a dent in the walls. Never actually use them as a hub.

    Edit: Ok, removed the air vent hubs, but was little or no change in performance on doors connected to the big rooms on my carrier. I did notice however that, at doors between smaller rooms, that the lag was non-existent when opening/closing doors. So, I now believe the vents are just pressurizing rooms that are too big for the game to handle without having a frame rate drop.
     
    Last edited: Jan 4, 2019
  7. mojomann71 Junior Engineer

    Messages:
    754
    I am not certain this is a bug either, as Keen does specify if you use pressurization this can cause issues. Not trying to say your machine is low end for the game, but have you tried to see your memory usage when the game is running with a world that you do not have any lag on versus this one? Maybe you have another program running in the background that normally does not affect the game but with this world your memory cannot handle both running? There are many variables that can be at play here.