Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Savegame issue ( I believe), Lost a starsystem :(

Discussion in 'Bug Reports' started by der_versorger, Jun 7, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. der_versorger Trainee Engineer

    Messages:
    2
    due to crap piling up on my HD I had run into the problem there was not enough discspace for autosaving the game, accordingly I got the ingame massage (in german it said "Fehler beim Laden von ....", I'm sure you know what amssega I am talking about.). So left the game and cleard my HD and made some room, lost only a few minutes of gametime, so I am ok. A few minutes gametime later I get the ingame message anew (with enough disc space at hand). I was able to reload the game from where I were, but wasn't able to save ever after. Next I tried to load a backup (3 of 5 I think) and still was in my station that I was drilling into my earthlike Planet but not anly the planet was gone, my building had ended up in an empty world setting.....I have no idea how I might have triggerd this and wish to learn where my starsystem went and at best how to get it back ;)

    *edit* haven't lost the system, just the planet is gone (voxels, gravity and air)...WTF?

    I must say I am not too upset, but surprised.
     
    Last edited: Jun 8, 2018
  2. Zhiila Tester Staff

    Messages:
    486
    Hi,

    Can you send us the world? (also with backups)

    I remember same or similar issue, which was caused by use of voxel hand. Voxel hand changes made voxel file too long and at certain moment game couldn't be saved and sometimes even planet disappeared. If that's the issue, I would recommend to use following procedure:

    1. open your saves folder. change the file names of all your planets and remove all the -1-0 crap so it looks like the below example
    change from
    EarthLike-784751276d120000-0-2-0-4-5-2-1-3-7-11-22-3-9-15-1-0-1-2-4-7-11-15-19-20-23-0-0-3-0-5-9-1-4-7-0-0-0-5-12-0-3-3-0-0-0-3-0-2-3-1-5-1-0-0-2-0-3-8-2-1-5-8-0-0-1-6-0-6-0.vx2
    to this
    EarthLike-784751276d120000.vx2

    2.take note of the new file names
    now you have to alter the world save to point to the new file names

    3. using notepad or preferably notepad++ open the file SANDBOX_0_0_0_.sbs

    4. do a find/search using the term <StorageName>earthlike
    using the above example the search should take you to the line
    <StorageName>earthlike-784751276d120000-0-2-0-4-5-2-1-3-7-11-22-3-9-15-1-0-1-2-4-7-11-15-19-20-23-0-0-3-0-5-9-1-4-7-0-0-0-5-12-0-3-3-0-0-0-3-0-2-3-1-5-1-0-0-2-0-3-8-2-1-5-8-0-0-1-6-0-6-0</StorageName>

    5. as with the file name from before delete all the -0-2 stuff so it matches the file name you edited earlier so it looks like the below example
    <StorageName>earthlike-784751276d120000</StorageName>

    6. now do the same for the rest of planets one by one
    below are the search terms for the standard solar system.
    <StorageName>europa
    <StorageName>alien
    <StorageName>moon
    <StorageName>titan
    <StorageName>earthlike
    <StorageName>mars

    7. hit save and start your server

    Hope it helps, if not, let me know please.

    Thanks!
     
  3. der_versorger Trainee Engineer

    Messages:
    2
    I will mind this should I run into that problem again. I killed the savegame and started over (now I know that I cannot just place a structure into the voxels and then dig it out :( ), so I cannot send it over, but I will when it accours again. For the time beeing I am happy that you are aware of this problem and know how to troubleshoot and maybe this post is helpful for others with such a problem :)
    Thank you.
     
Thread Status:
This last post in this thread was made more than 31 days old.