Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

SE SP Survival 01.124.007 x64. ulocking connector causing turrent engage my structure (block)

Discussion in 'Bug Reports' started by crazy_bad, Mar 5, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. crazy_bad Apprentice Engineer

    Messages:
    152
    unlocking connector on my ship caused small interior turred (attachet to same ship) to engage (attack) my structure (base) on which ship was landed.

    looks like was tartgeted advanced rotor. it was placed (crying) on piston that was carried complex solar panels and weapons block. Turret firing even throught collisions (other my blocks).
    One steel block (collision on target path) was destroyed. After that converyer was destroyed, on which (complex structure) solar panels and weapons was placed are getting down.

    save file reverted for earler version. some hours lost...

    I suppose, that you can add crane (magnetic or other) to give ability to connect broken (deattached) parts in survival mode.

    * Cyberhound & spiders disabled.

    To prevent this bug - now weapon disarmed (ammo removed). But this makes weapons useless...


    if you need save file - please write to PM - and i will try to recover it from backup.
     
    Last edited: Mar 5, 2016
  2. crazy_bad Apprentice Engineer

    Messages:
    152
    unlocking landing gear - made a second target (looks it made same issue).
    do mage thing, that i'm enemy to myself, or i have extreamly danger rotors, which shoud be elemenated bofore they make any problems ???? :-D

    [​IMG]

    [​IMG]

    looks like game save\load - resetting (remove) targeting.
     
  3. druppi Apprentice Engineer

    Messages:
    179
    make sure to have ownership of the rotor (better all parts) on the base and the small ship

    you can also disable "attack neutrals" in the turrets menu.
     
  4. crazy_bad Apprentice Engineer

    Messages:
    152
    Can you tell me please, how could i not be a owner of thease rotors?

    caption tells - that this SP - sinle player. That means - only i can made it.
    no deaths was from time i was build it....
    How it could be neutral\or not under my ownership ?
     
  5. Teravisor Apprentice Engineer

    Messages:
    398
    It could be bug, it could be creative(or spacemaster) pre-124 version, just check it already.
     
  6. crazy_bad Apprentice Engineer

    Messages:
    152
    thnks for suggestions. i will try check ownership - but this game was newer in creative mode. Some changes on this map was made from builded from source game (cause of pachfinding lockup). But i don't remember all changes i was made from unofficial version.
     
Thread Status:
This last post in this thread was made more than 31 days old.