Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[SOLVED] Updates 01.100.024...01.102 - Game Won't Start Issue

Discussion in 'Bug Reports' started by buckshot158, Sep 23, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. buckshot158 Trainee Engineer

    Messages:
    14
    Game does not start and does not create any log files. Windows displays "Space Engineers has stopped working" right after clicking the Play button from Steam. I've tried just about every obvious fix I could think of or find on the forums but to no avail.

    My system runs Windows 10 Pro 64-bit. Here is the Event Log with the .NET runtime error.

    Application: SpaceEngineers.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.TypeInitializationException
    Stack:
    at SpaceEngineers.Game.SpaceEngineersGame.SetupPerGameSettings()
    at SpaceEngineers.MyProgram.RunInternal(System.String[])
    at SpaceEngineers.MyProgram.Main(System.String[])
     
  2. Grantorino Trainee Engineer

    Messages:
    7
    This helped for me: ( i could start and close the game today without errors)

    Number one problem solver is switching to DirectX 11 if you're running Win 10.

    You can switch it trough the appdata SE folder and change it in CFG file trough the editor.
    C:\Users\usernamel\AppData\Roaming\SpaceEngineers\SpaceEngineers.cfg

    Search for:

    <Key xsi:type="xsd:string">GraphicsRenderer</Key>
    <Value xsi:type="xsd:string">DirectX 9</Value>
    </item>

    Change the 9 in 11 and save
     
  3. buckshot158 Trainee Engineer

    Messages:
    14
    @Grantorino Just tried that solution yesterday that you posted, but it still crashes the same. Has the same event log info as well.
     
    Last edited: Sep 27, 2015
  4. buckshot158 Trainee Engineer

    Messages:
    14
    Update 01.101 just launched and still having the same problem.

    Here is the Dxdiag report in case you guys need that for hardware specs.

     
  5. Legotaz Trainee Engineer

    Messages:
    26
    ok guys ive found a work around : it seems that its something to do with antialiasing fxaa and msaa in direct x11. what you need to do is go to your config file in C:\Users\YOURNAME\AppData\Roaming\SpaceEngineers then open up SpaceEngineers.CFG file
    now scroll all the way to the bottom and look for the line that says:

    <Key xsi:type="xsd:string">AntialiasingMode</Key>
    <Value xsi:type="xsd:string">1</Value> the value >1< might vary depending on what fxaa or msaa you have it set to, just change the value to: 0 then save the file and fire up the game...... HEY PRESTO game fires up like a charm in DX11:) :) :)
     
  6. buckshot158 Trainee Engineer

    Messages:
    14
    @Legotaz Just tried your fix but had no effect. Game still won't start, doesn't produce any log files, and the event log has the same info.
     
  7. TheDuke540 Apprentice Engineer

    Messages:
    201
    I've got a fix:
    Windows 7!

    JK. but seriously that sucks for you.
     
    • Like Like x 2
  8. buckshot158 Trainee Engineer

    Messages:
    14
    Ok! I think I'm getting somewhere now...

    I uninstalled SE and manually deleted the C:\Users\[USERNAME]\AppData\Roaming\SpaceEngineers folder before reinstalling the game through Steam.

    The game still crashes the same with the same event log info BUT NOW it creates a crash log.

     
  9. buckshot158 Trainee Engineer

    Messages:
    14
    So reading through the crash log...it looks like this line is where the problem is...
    I've done some googleing around and it looks like a few others are having the same issue with this "Infinario" thing.
    Looks like this is something only the devs can fix. :(
     
  10. Phand Master Engineer

    Messages:
    9,650
    Hi,

    checking with guys. Thank you for letting me know! Sorry for inconvenience.
     
    • Like Like x 1
  11. buckshot158 Trainee Engineer

    Messages:
    14
    Figured out a fix!

    After uninstalling SE I found that a couple files were being left behind which one of them was an XML document that seems to be related to what was causing the crash.
    So, what I did was I went into the Program Files (x86)\Steam\steamapps\common file and manually deleted the SpaceEngineers folder before reinstalling the game.

    Now the game loads and can be played again! If anyone else is having this problem this could be a potential fix for them.
     
Thread Status:
This last post in this thread was made more than 31 days old.