Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[SOLVED] Visual Studio - IMyTimerBlock missing

Discussion in 'Programming Questions and Suggestions' started by marandus, May 22, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. marandus Trainee Engineer

    Messages:
    2
    Hi everyone.

    I am using Visual Studio Communiy Edition to write code for programmable blocks in SE. I set it up using the guides found here on the forums and imported the required assembly files from my SE installation folder. But for some reason, VS will not recognize the IMyTimerBlock interface, showing errors on them and having no auto completion (which makes starting with SE programming quite difficult). Auto completion works for all other interfaces I tried until now, only these two are missing.

    Am I missing an assembly file I forgot to include? Or are those simply not avalable currently? Code using it works ingame after all, thus I guess I am missing something. Information on my setup following below.

    Included assemblies (from steamapps/common/SpaceEngineers/Bin64):
    • Sandbox.Common.dll
    • Sandbox.Game.dll
    • VRage.dll
    • VRage.Game.dll
    • VRage.Library.dll
    • VRage.Math.dll
    Imported namespaces in VS class file:

    using System;
    using System.Collections;
    using System.Collections.Generic;

    using Sandbox.Common;
    using Sandbox.Common.ObjectBuilders;
    using Sandbox.Definitions;
    using Sandbox.Engine;
    using Sandbox.Game;
    using Sandbox.Game.Components;
    using Sandbox.Game.EntityComponents;
    using Sandbox.ModAPI.Ingame;
    using Sandbox.ModAPI.Interfaces;
    using VRage;
    using VRageMath;
     
    Last edited: May 22, 2017
  2. Wicorel Senior Engineer

    Messages:
    1,242
    It's in SpaceEngineers.Game.ModAPI.Ingame
     
  3. Inflex Developer Staff

    Messages:
    397
  4. marandus Trainee Engineer

    Messages:
    2
    Thank you both, will fix my setup with this new guide
     
Thread Status:
This last post in this thread was made more than 31 days old.