Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version [Extra] --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.
  3. Apologies for enabling the dark skin as the forum default. This was unintentional and the light theme that we've been using for the last couple of years will remain the default.

    For anyone who hasn't noticed:
    We've enabled a dark skin on the forums called Keen Software House - Dark. It's not perfect but it gets the job done for anyone who doesn't enjoy white backgrounds. Go to your preferences page https://forum.keenswh.com/account/preferences or click the skin name at the bottom left of any forum page to switch

Timer Block Ghost Block Issue

Discussion in 'Bug Reports' started by eagledude4, Feb 17, 2017.

  1. eagledude4

    Joined:
    Jan 15, 2014
    Messages:
    12
    Trophy Points:
    81
    When placing a timer block, the ghost block or preview alpha block does not show the control panel, so placing the proper orientation is a matter of trial and error.