Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.040 - Pistons, Blast door blocks

Discussion in 'Change Log' started by George.Mamakos, Jul 24, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. OracleTX Apprentice Engineer

    Messages:
    196
    I was very excited about the pistons (still am, mostly), but wow they shear off easily. I tried using them with merge blocks on the end, and the ends of the pistons broke right off trying to connect a large ship to a station.
     
  2. Tisdan Trainee Engineer

    Messages:
    37
    Just got an update a few minutes ago. 63 MB in size but can't find a changelog.
     
  3. ManIkWeet Trainee Engineer

    Messages:
    26
    No changelog for random Tuesday update?
     
  4. SONce Trainee Engineer

    Messages:
    19
    EDIT 07/29/14:
    Update 01.040.016
    - fixed issue when clients were able to save the game even with "client saving" disabled
    - fixed issue when the game was saved after selecting "no" when leaving the game
     
  5. Enea Trainee Engineer

    Messages:
    13
    it's on the first page.
     
  6. MrHohenheim Trainee Engineer

    Messages:
    88
    no too much thing fixed :/
     
  7. xxjcxx89 Trainee Engineer

    Messages:
    93
    Was the pause game when empty feature there before??? In dedicated server clients because i just noticed it...
     
  8. Neotician Apprentice Engineer

    Messages:
    440
    Indeed, it came last Thursday or Friday, It's not very useful though, since you'll be stopping all refineries/assemblers :p.

    Anyhow, Keen! Why u no fix rotors?
     
  9. fevfev Apprentice Engineer

    Messages:
    122
    fixing rotors and pistons or any thing that moves on server is not a easy fix since the bugs are mostly due to lag(lag being the time it takes the server to update the postion of the item and movement then send it to each client in game)
     
  10. Joschi Trainee Engineer

    Messages:
    8
    If yes again a really great update, which no one needs again.
    Fixes but ändlich times the cargo ships.
    Or you have no more that the people playing the game, or are still people buy goat this game. So you get to safety not a good evaluation or recommendations
     
  11. Chris204 Trainee Engineer

    Messages:
    39
    @Keen

    Thx for the fix!! :)



    Google Translate is never a good idea for a coherent text :)
     
  12. entspeak Senior Engineer

    Messages:
    1,744
    Thanks for the save fix!
     
  13. Rosenkranz Apprentice Engineer

    Messages:
    135
    Those are great fixes. Honestly, I didn't know those were broke.

    But... no fix for mod loading? Man, they must have really borked it good. :(
     
  14. Zwitsal Trainee Engineer

    Messages:
    2
    Yesterday i laid out my solarpanel-field using multiple rotor's. Halfway through i saved and stopped playing. Today, after the update, the rotor's i used shake like grazy, damaging my ships, my base and instantly killing me. Since I play survival i would like to continue without dying, repairing all broken stuff and rebuilding my solar pannels.

    Is this a bug or is there something changed with rotor's so i do not have a choise but to do all the crappy repair work?
     
  15. MSI Junior Engineer

    Messages:
    636
    How far are you from the center of the map? This can sometimes cause ridiculousness. However, you're playing survival so I would venture to guess not very far at all as you'll need the Asteroids. Did you set all of the rotor heights to < 0 ? It could be a collision mesh bug where things are colliding but might not look like they're touching.
     
  16. Zwitsal Trainee Engineer

    Messages:
    2
    Thanks for replying! Yesterday all was fine. All rotors have like 20cm space and none of the construction nor anels are touching anything. Like I said, yesterday all was well, i was welding away but with 10 or so solarpannels left to weld i quit to finish it today.

    It looks like the construction might be to big for 1 rotor? But like i said, yesterday it worked and i tweaked all rotor's for maximum capacity on my panels and all was fine.

    If you know what I should do, i'm open for suggestions

    (ps excuse my English its not my 1st nor 2nd language)
     
  17. MSI Junior Engineer

    Messages:
    636
    That's alright, I butcher the Russian language from time to time - I completely understand.
    Are the rotors and solar panels a part of a station? If yes, station parts should not be affected by things such as mass-stress which would be mighty peculiar. If it's a part of a ship it could be a physics "freak-out" from there being too many objects? I have found that Physics "freak-outs" are much more likely to happen on weaker CPU's (or even high grade ones) if there are too many objects being accounted for. When I have to travel for work I use my laptop - I've seen similar things happen. I would suggest as a first try to resolving this - reduce the maximum number of objects in the world settings in the load save menu (edit settings).
    I would avoid trying to use SE tool on the modern build of the game, only worlds created and edited with it give me crashes. Hopefully Thursday can sort that out.
    If the last step doesn't work try reducing the number of objects (vessels) in a separate save (in the loading screen press "Save As" to make a copy): after you're done, save this new file and restart the game. And if that doesn't work either I would try copying and pasting your station(s) / vessel(s) into a new world and see if you can reproduce the same issues there. Sometimes specific worlds get weird. I know it seems like a pain in the arse but those are the best troubleshooting methods I can think of.
     
  18. CookeRS92 Trainee Engineer

    Messages:
    24
    Pistons don't seem to be working on Dedicated servers yet. Working fine in Creative Mode, but on my dedicated server the piston's 'Top' seems to elevate, but there are no arms holding it up, and it will not retract back down. Additionally they seem very unstable (shaking & glitching with lots of sparks)

    Still cool addition though. GJ.

    CookeRS
     
  19. lyle sonders Apprentice Engineer

    Messages:
    342
    I am having similar issues with pistons. When i place a merger block on top and match them with ones on ship the will not extend, also when I try to use them to build a ship elevator they extend beautifully but when they are retracted, they will not move together or as you said the Top seems to pop off and the piston stops working. I mostly work in creative mode designing large ships.

    On a different note the Rotors seems to work perfectly for me. when I want to adjust them simply install them set the adjustment level then give them a 360 rotation and they set themselves to the level without saving and exiting the game.
     
  20. count23 Trainee Engineer

    Messages:
    70
    Pistons only seem to merge together if you have a rotor on top of the upper piston plate and the merge block above that, doesn't seem to be very space effective and you lose a block, but it does appear to at least work even on a dedicated server for the time being. Fingers crossed the next patch will increase the impact tolerance and/or stability of the pistons so we dont need that "buffer" piece. Also while pistons go up and down on teh ded server with this method, the telescoped parts dont always appear.
     
  21. mefsh Trainee Engineer

    Messages:
    11
    Please make it so that the damage of things you hit chang depending on size and speed ow and a new tip of turent thanks
     
  22. MSI Junior Engineer

    Messages:
    636
    Uh oh, no F5 party comments?? It'll be better this week!! Knock on wood!!
     
  23. DJDemyan Trainee Engineer

    Messages:
    9
    u wot m8
    [ANTICIPATION INTENSIFIES]
     
  24. MSI Junior Engineer

    Messages:
    636
    [​IMG]
     
  25. Mortisfire Apprentice Engineer

    Messages:
    148
    [​IMG]
    This is red leader, all F5 squads... report in!
     
  26. MSI Junior Engineer

    Messages:
    636
    This is Han Cholo, reporting in.
    [​IMG]
     
  27. Mortisfire Apprentice Engineer

    Messages:
    148
    1.040 is still stickied. I think this one is going to be a bit later. Oh well, back to Voyager.
     
  28. Wolf Apprentice Engineer

    Messages:
    162
    hope they fix the damn pistons. The head on the pistons is broken. comes off all the time.
     
  29. Leatherneck Apprentice Engineer

    Messages:
    336
    [​IMG]
     
  30. Xocliw Public Relations Staff

    Messages:
    2,615
    Hahah.... and so it begins :thumb:!
     
Thread Status:
This last post in this thread was made more than 31 days old.