Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.151 DEV - Realistic Sounds, Improvements and Bugfixes

Discussion in 'Change Log' started by Drui, Sep 1, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Spets Master Engineer

    Messages:
    3,214
    same here :/

    also, I want to know more about this too, more information "- improved control for thrusters on subgrids (controlling a subgrid grants you control over the thrusters now)"
    because this is not what I thought it was, you can not control thrusters that are in a subgrid. If this means you can use WASD keys, which I guess it is not what it means?
     
  2. Sanquira Trainee Engineer

    Messages:
    10
    Try remove GPS from file
     
    • Informative Informative x 1
  3. Replic TuaniOne Apprentice Engineer

    Messages:
    485
    Thank you for finding out, so I was not the only one at least (saw more have this problem).

    Is there also a way to find out what mod that has and does not have? how to rule it out or fix it?
     
  4. Zinlu Trainee Engineer

    Messages:
    10
    Having not been a big fan of the Realistic Sound buildup, I have to admit, I am impressed. Quite the implementation! I am enjoying it a lot more than I thought I would.

    As for the glass:
    Mojomann71 has the right of it. The scratches were my biggest problem. Structural weakness and all that. A little more scrubbing with Windex and some newspaper in the central portions of the windows and they'll be perfect!

    As for things not mentioned in the patch notes, the highlighting on text entry boxes... i.e. when you right click drag something and when you drop it pops up a dialog to enter the number, or ctrl clicking on a field in the control panel. I noticed tonight it's prehighlighted in the text entry area. I LOVE THIS!!!! No more backspacing/deleting out the maximum amount that is already filled in, just type in the amount you want and enter key, done. Very nice QOL enhancement!

    That's all i have found in the 15 or so minutes I have played so far, had one crash when I ESC'd out of a monitor color entry, bug report sent.

    Playing this last couple weeks after a few months of not playing, I have remembered how much I really do love this game. Thank you KSH. Keep up the good work.
     
    • Agree Agree x 2
    • Like Like x 1
    • Informative Informative x 1
  5. Aiadel Trainee Engineer

    Messages:
    32
    Verify if you are in the development branch: last week they changed the name, now it's called [develop]. If in your Steam Library you see Space Engineers[development], then it's actually the stable branch, and you need to re-enable it.
     
  6. Bad Humour Apprentice Engineer

    Messages:
    116
    My strange scrolling issue is fixed now it was only on one world where it happened. Very strange.
     
  7. EmperorDragon Apprentice Engineer

    Messages:
    113
    +1000000000000000000000000000000000000000000000000000000000000000000000000000000 for this!!!

    I shall send the pope to bless your harddrives!
     
    • Agree Agree x 1
  8. Leaping Tortoise Apprentice Engineer

    Messages:
    212
    Anyone else having issues leaving the earth like planet? My game keeps crashing when I got 14,025m or something very close to that.
     
  9. RayvenQ Moderator

    Messages:
    562
    You put a remote control on the subgrid that you want to fire the thrusters on, control it and wasd etc will work like normal depenidng on the orientation of your remote control. But only one subgrid at a time, not controlling all the subgrids at once
     
    • Informative Informative x 2
  10. Shuro Apprentice Engineer

    Messages:
    114
    [​IMG]
     
    • Agree Agree x 1
    • Funny Funny x 1
  11. McTraveller Apprentice Engineer

    Messages:
    118
    Sweet - this means my large block ship designs that use small ship thrusters on a separate grid can now fly with WASD instead of having to use thruster overrides. They even already have the remote control blocks... although I may have to check the orientation*.

    *Although this is moot, because I can't play on the new branches, because DX11 is still not available in Parallels. Or any other VM from what I've been able find, actually.
     
  12. RayvenQ Moderator

    Messages:
    562
    As long as they're all on the same subgrid, you'll be able to do that.
     
  13. KingdomBragg Junior Engineer

    Messages:
    544
    @RayvenQ Thanks for the info but I've definitely used a remote control block in the way you describe prior to this update. Has something changed under the hood for modders as I can't figure out how it's different now.
     
    • Agree Agree x 1
  14. Shuro Apprentice Engineer

    Messages:
    114
    I thought ships connected via Connectors wouldn't cause trouble anymore while flying and jump-driving. Something like that. But Remote Controlling is fine too i guess.
     
  15. Bad Humour Apprentice Engineer

    Messages:
    116
    Wait but didn't this already work before hand. I have built a prototype once with this idea in mind and it worked even before the update... Or is there more to it.
     
  16. Spets Master Engineer

    Messages:
    3,214
    my game crash at 7,000 meters Alien Planet
     
  17. DigitalStone Apprentice Engineer

    Messages:
    273
    Thanks for the tip, but it does not change the outcome for me.
    I also tried to compare the GPS format of a new game from the new update but they are exactly the same.
     
  18. Gwindalmir Senior Engineer

    Messages:
    1,006
    Any mod that uses BlockVariants (has a + overlay on their icon) is suspect. My FTL mod was one that contributed.
    The hotfix fixes it.
     
  19. Syncaidius Junior Engineer

    Messages:
    824
    Sadly this is not fixed. Still happening when a friend joins my MP session.

    EDIT: Disabling realistic sound stopped the crash. From the crash log it looks like MySoundPair is either null or the 2nd sound for realistic mode is missing from some mod sounds.
     
    Last edited: Sep 2, 2016
  20. Greystar Trainee Engineer

    Messages:
    18
    did you happen to try to reduce your sound quality in your windows control panel? (doubt it'll make a difference) I had an issue where since the update I had NO SOUND, none at all, tried updating drivers, audio and everything else. Multiple computer restarts, etc. No fix, then I saw someone mention they changed their audio settings in windows from 19200 hz, 24bit to 48000 hz, 24bit and I had sound again. Maybe try tweaking that number on both you and your friends machine and see if you still have the crash. I think there is still an issue in SE with the new sound system especially with the sound sampler to the hardware itself which yes the driver is supposed to handle but something in the game isn't working as intended.
     
  21. DigitalStone Apprentice Engineer

    Messages:
    273
    This doesn't sound like it's going to be fixed anytime soon, seeing what Keen is working on at the moment.
    So i'll just start a new survival. This time with all of the experience i gained from the first one.
    And hopefully without save game screwups :)
     
  22. Syncaidius Junior Engineer

    Messages:
    824
    Nope. But playing without any mods works fine with realistic sounds enabled. That's what makes me think its just a missing null check for something associated with mods. :eek:ops:
     
  23. Le Inquisitor Trainee Engineer

    Messages:
    5

    I run Windows 7 and a Nvidia GTX 950
    Coincidence?
     
  24. Leaping Tortoise Apprentice Engineer

    Messages:
    212
    I turned off realistic sounds and I can exit atmo quite nicely. So bummed. I was really looking forward to realistic sounds :(
     
  25. Henrique Trainee Engineer

    Messages:
    19
    Amazing! Don`t forget the procedural generation planets, like asteroids! And the game will be perfect
     
    • Agree Agree x 1
  26. Apsyc Apprentice Engineer

    Messages:
    108
    Hey Tomas, psoriasis sucks but. Feels bro.
     
  27. Ed Frost Senior Engineer

    Messages:
    1,158
    If only rotal was here to laugh with us ;(
     
    • Agree Agree x 1
  28. Drakon Apprentice Engineer

    Messages:
    139
    Hello,
    please send us a bug report with crash log (unless you already did :) ). There is probably something in mods I did not expect. I will do what I can to have it fixed for next develop release.
     
  29. McTraveller Apprentice Engineer

    Messages:
    118
    I think before it would work with WASD only if you were controlling from a remote control console - if you "took control". What I have done in the past is if you have a connected sub grid with a remote control block, you can put the thruster overrides for the thruster on the sub grid in the shortcut bar of your main ship - so you *don't* have to "remote in" to the sub grid, but can do it right from a flight seat or whatever. I take it this this change lets you WASD from the main flight seat, instead of having to use thruster overrides.

    It did make flying my large ships more like being a helmsman than a fighter pilot though - it was kind of interesting in that sense.
     
  30. Clanner Jake Apprentice Engineer

    Messages:
    197
    glad to see somebody can make it past the main menu- mine fails to load because of version numbers being wrong. which is LOL because they've done that error before... apparently there isn't a checklist someone needs to follow when making patches...
     
Thread Status:
This last post in this thread was made more than 31 days old.