Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 1.184.0 Major - Half Armor Blocks, UI & MP Improvements

Discussion in 'Change Log' started by flexx, Sep 14, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Hyomoto Apprentice Engineer

    Messages:
    239
    Turns out I was wrong, or something. There's still a big issue going on where my station is becoming a ship. The mod was definitely causing the issue to happen more obviously, but that was just the phantom velocity, it turns out the station becoming a ship is a real, and very problematic thing.

    As for that being vanilla now, I know I thought I heard it was at some point but I can't seem to find anything about it. Info?
     
  2. viper312005 Trainee Engineer

    Messages:
    90
    Is the station attached to a asteroid/voxel, if not then your if 'unsupported stations' is NOT checked then everytime you add/remove a block on the station, it seems it converts to a ship for some reason. I've had this problem. I had to add some voxel material to the station to keep it from doing so.
     
  3. Hyomoto Apprentice Engineer

    Messages:
    239
    It's definitely odd that I haven't had this issue up until this point but it seems like you are describing the problem perfectly. Doing a smidge more investigating it seems the reason why is because, at least from my perspective, the part of the station that is becoming dynamic is wrong. The part I expect to float off into space, ie: the smaller one, stays a station and the station itself is why becomes dynamic. I'll use your tip and hopefully adding some voxel to it will be a acceptable work around. Thanks for the info!
     
  4. Devon_v Senior Engineer

    Messages:
    1,602
    Point your crosshairs at a grid and SHIFT+Z. :)
     
    • Like Like x 1
  5. sapog Trainee Engineer

    Messages:
    3
    "drain all" has worked properly now, thanks
    I can dig again!
     
  6. FoolishOwl Apprentice Engineer

    Messages:
    418
    Has there been a hotfix?
     
  7. Spets Master Engineer

    Messages:
    3,188
    there are blocks even smaller than this half block, how they doesn't have this problem?
     
    • Agree Agree x 9
  8. Optoclaw Trainee Engineer

    Messages:
    5
    I've also been having issues loading my main world as it is modded. I left my game alone for 30 minutes and still came back to the same screen saying mods were loading. I haven't been able to play in two days and was working on one of my better designs for a prototype laser mining vessel. Gods Alliance Prototype version 5 can't be finished if I can't play the game.
     
  9. Applesauce Trainee Engineer

    Messages:
    5
    For anyone who is interested in trying out how these new blocks behave on small grids, I did end up taking the above advice and made a small mod to enable them using the vanilla models and textures already in the game:
    http://steamcommunity.com/sharedfiles/filedetails/?id=1136328223

    Only played around with them a little so far, so I can't say for sure yet if there are collision issues.
     
    • Like Like x 1
    • Friendly Friendly x 1
  10. xiojade Trainee Engineer

    Messages:
    82
    So here are the results of my mod testing.

    I've been testing things today regarding mods. I play with 160 (I know you'll say that's too many, but hear me out.)

    So at first I thought I'd remove the mods that I've had issues with in the past. Skybox, planets... WILL NOT LOAD.
    Then I started removing my mods 1 by 1. I got to the end of my planets, after removing 20 mods before them... LOADED!
    I went back, refreshed my mod list and took out just the planets... WILL NOT LOAD.
    I started taking out Random mods, and when I eventually took out about 45 of them... LOADED.

    I could not understand what was happening because it did not seem to matter which mods I removed. But after some tinkering, I think I understand now.

    I don't think it has anything to do with any single mod, I think it has to do with the filesize of all the mods collectively. It seemed that if it was trying to load a batch of mods that is over 2.0GB in size, then it would not download the mods. I took out the largest filesize mods that I use, and it would load. If I added something that tipped the collective size of all mods over the 2GB point, the world would not load, and just hang at "downloading mods".

    Has a cap or limit been imposed, purposefully or accidentally? If the former, could you please tell us? If the latter, could you please look into it?

    Thanks <3
     
    Last edited: Sep 16, 2017
    • Informative Informative x 4
  11. TechNick Trainee Engineer

    Messages:
    40
    Meanwhile, multi player is broken again, sim speed down from average 0.8 to 0.2
     
  12. Thrak Apprentice Engineer

    Messages:
    402
    Yes, I have a few projectors on my big ship, including one for general repair, one to create an optional mining arm. They appear to be triggering when blocks are separated from the main ship and become their own grid. May be glitching out and appearing at other times, too. Turning them on and off helps. Annoying and a major sim speed hit. I have not tested this in vanilla, just in my normal mod-laden world.,

    So far, in terms of this update, I've seen:

    1) The above-mentioned projector glitch.
    2) Deleted block groups in the control menu coming back from the dead/duplicating when updated.
    3) The preview images of certain small armored blocks are not positioned correctly. They phase through nearby blocks. They place fine and can be welded normally.
    4) Sometimes filter items will disappear from Sorter lists (this may be an old issue and it seems to go away upon restart).

    There are still some lingering issues introduced in recent updates, too, but overall, still think things are moving in the right direction. And a big thanks for the antenna broadcast state fix. :)
     
  13. Nacon Junior Engineer

    Messages:
    591
    No... it's not. Did you completely missed out the last few years ago on this forum, where people kept asking for compound grid almost non-stop?
     
  14. Malware Master Engineer

    Messages:
    8,979
    Actually, according to the feedback site where this request was quite clearly stated and voted upon, it is. Compound blocks and the half blocks is and always was two completely different things. The one doesn't even exclude the other. It has also been discussed again and again on Xocliw's streams. They know very well that we want compound blocks, but they have also absolutely and without any way to misunderstand said "no" to compound blocks because it's too big a job. Compound blocks are a hell of a larger project than just another simple armor block.

    This was exactly what was asked for. More, actually, since we got the half slope block as well. Both which they did in their free time, by the way. This is very appreciated by those of us who asked for it... who begged for it for months if not years. If you don't like it, don't use it. The alternative would have been nothing.

    Oh, and by the way, compound blocks has it's own post on the feedback site.
     
    • Agree Agree x 2
    • Disagree Disagree x 1
  15. Hyomoto Apprentice Engineer

    Messages:
    239
    I'm pretty sure I have at least an inkling why compound blocks haven't been attempted, but it makes me wonder then what the difference is between SE and ME that makes it more plausible in one situation than the other.
     
  16. Malware Master Engineer

    Messages:
    8,979
    Static vs dynamic grids.
     
  17. Arcturus Senior Engineer

    Messages:
    1,647
    RE: screenshot contest => potential loading screen changes

    I would love it if they remove the "impossible" loading screens from the current selection - in particular the ones with very heavy ships hovering/flying in atmosphere with barely any thrust from ION thrusters.
     
  18. Hyomoto Apprentice Engineer

    Messages:
    239
    While I do believe this is related and maybe even the root when boiled down to 4 words, I'm pretty sure that's like saying my lack of wings is why I cannot fly. More specifically what about the dynamic grids causes that specific limitation is more where my interest lies.
     
  19. Malware Master Engineer

    Messages:
    8,979
    I'm simply parrotting what the devs have said.
     
  20. Stardriver907 Senior Engineer

    Messages:
    2,366
    I'm writing this about an hour after I first attempted to load a world. I have not loaded SE since 1.184 went live.

    As with every update since 1.181, I start every "First Session After an Update" by making a "Save As" of my last session, then I check the Mod list to see if anything got pulled. I remove any "red" mods and save. At this point I assume what's left will be successfully downloaded. So, imagine my surprise when I waited 15 minutes for even one mod to download? I'm using version 1.184.005 and it says the "crash when downloading worlds with mods" has been fixed. Perhaps, since the game didn't crash and just didn't do anything instead.

    A quick perusal of this thread showed me I was not alone. The problem seems to be related to a hopefully unintentional cap on space allocated to mod files. I say unintentional because Space Engineers has more mods on Steam in any other game. In my opinion, 80% of them are cosmetic. 80% of the mods I believe I need to load in a world so that the constructs I have made will also load (intact) are cosmetic. As such I load a minimum of (currently) 210 mods. This way the ships I build look and, more importantly, work the way I believe they have to.

    There has been a lot of talk in this thread about the blocks Keen will not make. I understand their reasoning. Keen cannot possibly provide every single block that every single player wants, and if all those blocks were vanilla your computer couldn't hold the game. The best compromise is for Keen to make basic models and then let Modders modify them. It's just natural, then, that modded blocks would far outnumber vanilla blocks. Grinding down vanilla blocks will only get you so far. The number of blocks I have in a world should only be limited by my hardware, not the game.

    So, this limit was a mistake soon to be corrected, right?

    While I wait for your response I'll go back to watching @rexxar playing KSP.
     
  21. Admiral_peck Trainee Engineer

    Messages:
    11
    Can you fix those freaking black clouds that appear when welding/grinding a block through a build state, and randomly when drilling? Because I have just experienced my 20th crash due to that particular issue since I started counting, which was right after the parachutes and skins were added, and I haven't even been playing SE that much where it is an issue since then (I've spent about 70% of my time since then in creative, and it is not an issue in that mode for me as I avoid those three actions, and I have only logged another 70 hours in that time).
    It has happened in FULL vanilla about 7 times, the rest were with less than 30 mods(usually about 20-22) in play, and no super huge mods, so yes it does happen more frequently with my usual mod list, but not by much.
    I have encountered these issues with both handheld and ship-based tools, none of which were modded tools, and it does happen more with ship-based tools.
     
  22. Arcturus Senior Engineer

    Messages:
    1,647
    They cause crashes now? I have been modding out the "construction smoke" GPU particle effects for a while since they caused lag spikes for me in single player (while other particle effects are perfectly OK). There was a bug report a few versions ago related to this:
    https://forums.keenswh.com/threads/big-and-pixelated-smoke-dust-effect.7396455
     
  23. Arturo Cofresi Trainee Engineer

    Messages:
    53

    I do not get "black smoke" but the effect of depressurization plays, the white particles blow around and I do not play with pressurization on. It happens whether grinding or deleting blocks and even gets triggered while painting... If it loops on it own on the same spot while moving the grid, then the game crashes...

    Another thing is deleting some block will delete stuff behind it. Happens mostly (but not exclusively) in small grids with small hydrogen thrusters, conveyors and the 2x1x1 ramp slabs.
     
  24. Optoclaw Trainee Engineer

    Messages:
    5
    If they have invoked some form of limit then they need to remove it. I play with close to 500-600 mods and use every single one of them weather it be me who built the ship or something I have been using off of the workshop. I don't want to remove every single one of them because that would render a large portion of my own builds absolutely useless.
     
    • Like Like x 1
  25. rexxar Senior Engineer

    Messages:
    1,530
    It's a bug. There was an integer hiding in the mod download code and I didn't notice :( The integer will overflow at 2GB, causing the download thread to fail silently. I fixed it today, but I don't know yet if there will be a hotfix or it will have to wait until Thursday.
     
    • Informative Informative x 2
    • Like Like x 1
    • Friendly Friendly x 1
  26. xiojade Trainee Engineer

    Messages:
    82
    @rexxar That's awesome, I'm glad that I was on the right track with it, thanks for looking into it :)
     
  27. Roxette Senior Engineer

    Messages:
    1,044
    Ironically, there are so many issues that could be resolved by using integers instead of floats where it make more sense to do so :p
     
    • Funny Funny x 1
  28. JTrevail Trainee Engineer

    Messages:
    7
    The texture mismatch on the bottom of the half armor block bothers me, same with the 2x1x1 blocks.
     
  29. GrindyGears Senior Engineer

    Messages:
    1,787
    useless as a block to whom??? The substantially smaller hitbox would be a significant upgrade to a large number of moving parts, and mechanisms ESPECIALLY when you have put fixing the hit boxes of small grid blast door blocks on the back burner.... I usually stand behind most things keen does, but this is not one of them, it may be quote on quote "useless" as armor, but as a block to fill in certain voids, or create covers where a blast door is even too big, they have no parallel. Would it not make more sense to just include a warning that the small size can POTENTIALLY have problems? I mean lets take a look at the precedent by your introduction of the physical limits bit:

    We've added a warning to a hard limit in the game, but we have no issue with you exceeding that limit at your own peril. This came about after people went ballistic over the creations suddenly being at these limits...

    I'm going to sound like the bad guy here, but who are "you" (keen) to decide what is useless and what is not? a collective 99% of the community has deemed rotors and pistons useless, but look to the few that can use them, we can do fantastic things, taking away tools from us (or not giving us) when previous things directly contradict the reasoning is frustrating and frankly in poor taste.

    It's been said in the thread already that there are smaller blocks, which I agree.

    Frankly I'm tired of getting a short end the stick when it comes to this game.
     
    • Agree Agree x 3
  30. Thrak Apprentice Engineer

    Messages:
    402
    Glad the mod loading thing is being addressed. Hope memory crash issue and "projectors gone wild" (I wonder if they're related?) get resolved ASAP, too.
     
    • Agree Agree x 1
Thread Status:
This last post in this thread was made more than 31 days old.