Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[Update 1-185] SimSpeed RIP'd [Offline SP No Mods]

Discussion in 'Bug Reports' started by Commander Rotal, Nov 17, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Commander Rotal Master Engineer

    Messages:
    4,979
    Unfortunately the new update has killed SimSpeed for some people, including myself on this old build.
    Basically: SimSpeed starts at 0.5, gradually goes down to 0.3, remains somewhat "stable" in between 0.3 and 0.4 simspeed. The ship isn't doing anything; before this update this would have yielded a beautiful 1.0.

    Workshop Link: (if you really need one at this point -.- ): http://steamcommunity.com/sharedfiles/filedetails/?id=501767620
    Log:
     
  2. suicideneil Apprentice Engineer

    Messages:
    223
    Glad to see Keen staying on top of QA testing as per usual...

    :woot:
     
    • Agree Agree x 1
    • Funny Funny x 1
  3. Ondřej Nahálka QA Lead Staff

    Messages:
    88
    Thanks for this tip.

    We will fix it.
    --- Automerge ---
    Fixed.

    Please update your game (1.185.015).

    [​IMG]
     
    • Friendly Friendly x 1
  4. Commander Rotal Master Engineer

    Messages:
    4,979
    @Ondřej Nahálka hey, just tested it!
    First things first: SUPER HUGE improvement! However, we're not entirely there yet.
    The World starts with a shakey but somewhat stable 0.8-ish SimSpeed. Moving the vessel brings it down to 0.5, after a few seconds it goes back up to the 0.8-0.9 range. That seems fairly stable as-is.
    I tried turning the ship into a Station (result: 1.0 SimSpeed, as expected), turning it back into a Ship has so far yielded two results; once it stayed at 1.0, the second time it went back to 0.8 after a while.

    Definitely playable and a super big change! But not quite where we were before the Major.




    Edit: while we're at it... ships are still sinking through a planet's surface. At least a ship of the Tapping's size / complexity.
    On my stream just now we noticed that the ship was taking a lot more damage than usual, but still a lot less than everyone else's little ships. Consequently, the Tapping eventually started phasing through the surface, until she got stuck about 90 percent through; we killed it there as the crash had taken well over an hour by that point - which is actually kind of a secondary bug report; crash performance is horrible compared to what it was in the last Major, and that was already worse than before.

    Here's a cheeky little Log for that session containing the crash:
    And here's the video on demand from Twitch; should be saved for a few days at least:

    Note the ridicioulously bad SimSpeed even before the ship actually touches the planet.
    Also note: for some reason Space Engineers sees fit to revert Workshop Worlds to default settings, turning on options like Block Limits and the goddamn Wolves, so some of the SimSpeed issues might come from Wolf-spawning. We didn't notice them at first because we watched the crash in Spectator.

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited: Nov 19, 2017
  5. Ondřej Nahálka QA Lead Staff

    Messages:
    88
    Hey,

    ad Fluct. Sim speed: this problem was hot-fixed. The proper fix is a part of the minor release. Performance on this scene is exactly the same as it was on 184 (in unreleased minor update 185.1).

    ad Tapping under voxel: It looks like a bug. Addressed to next major.

    ad Ridicioulously bad SimSpeed before the collision: voxel issue. Addressed to next major (new voxels). :)

    Thank you!
     
    • Informative Informative x 1
    • Friendly Friendly x 1
  6. Forcedminer Senior Engineer

    Messages:
    2,227
    ooh! next major new voxels. sounds delightful. :)
     
    • Like Like x 2
Thread Status:
This last post in this thread was made more than 31 days old.