Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

New! Important Update 1.189 - Major Overhaul of Survival, Ladders, Leaving Early Access

Discussion in 'Change Log' started by Drui, Feb 28, 2019.

  1. KissSh0t Master Engineer

    Messages:
    3,394
    Aaaaaaaaand I'm stuck.... installed the game after not having playing it since last year and thought I'd try the new game mode where you have to defend against drones attacking you, and couldn't do anything on the first wave because I couldn't fix anything because "unknown technology".

    How do I research?

    [​IMG]
     
  2. mojomann71 Senior Engineer

    Messages:
    1,269
    @KissSh0t start building things that are not greyed out on your G screen. Also there is a progression tab on the G screen that shows you what blocks you have to build first to unlock other blocks. Or just turn progression off in the options.
     
  3. Jonas Schiller Trainee Engineer

    Messages:
    2
    Can someone tell me where I can find Uranium, please?!
     
  4. Roxette Senior Engineer

    Messages:
    1,222
    It is only on asteroids now. Asteroids in a cluster all have the same restricted set of ores, so if you don't see Uranium, travel to a more distant cluster and look again.
     
    • Informative Informative x 2
  5. Pie Apprentice Engineer

    Messages:
    115
  6. mojomann71 Senior Engineer

    Messages:
    1,269
  7. howardxu23 Trainee Engineer

    Messages:
    32
    Dry nice update, although I’m definitely not a fan of uranium removal on planets either. It is possible to have that as an option, or available on certain planets only?

    Either that or increase uranium found on astroid by a large amount
     
  8. DJL Trainee Engineer

    Messages:
    18
    Comes with the territory. Anyone who mods knows that mods get broken on updates. Just one of those facts of modder life.
     
    • Agree Agree x 2
  9. Roxette Senior Engineer

    Messages:
    1,222
    Amongst other new features to troll players, some of the new encounter ships contain dead astronauts, the only way to remove these is by shooting them, it takes several clips, and then they explode, damaging surrounding blocks...
     
    • Funny Funny x 4
  10. Cetric Junior Engineer

    Messages:
    725
    Zombies confirmed in SE. Shoot the dead.
     
  11. mojomann71 Senior Engineer

    Messages:
    1,269
    "On this episode of The Floating Dead...." :D
     
    • Like Like x 1
    • Funny Funny x 1
  12. Stardriver907 Senior Engineer

    Messages:
    2,546
    You wanted content. ..
     
  13. PH0ENIX Trainee Engineer

    Messages:
    2
    Still waiting for larger planet sizes...
     
  14. Paxroy Trainee Engineer

    Messages:
    3
    Great update, lovely to see we're out of Early Access!
     
    Last edited: Mar 8, 2019
  15. Allammo Apprentice Engineer

    Messages:
    329
    Anyone knows where mods are currently stored? It isn't mod folder at appdata, however i can place my mods over there, I would like to know where are those downloaded from workshop.

    Edit: I've found it, currently mods are stored at: steamapps\workshop\content\244850\
     
    Last edited: Mar 11, 2019
  16. Dabombinable Trainee Engineer

    Messages:
    33
    They also remain as part of a blueprint. I've found that you have to manually replace the block that they are on (though in my ship....I just have that room locked and ignore it).
     
  17. Pie Apprentice Engineer

    Messages:
    115
    Is the voxel LOD bug back in todays fix, or have I just been very unlucky? Coming down from space, I still have the ~5km planet detail.
     
  18. Pyromaniacal Trainee Engineer

    Messages:
    3
    can this issue be addressed please our server is stuck with autorespawn on and it very much breaks the game.
     
  19. Ronin1973 Master Engineer

    Messages:
    4,532

    Is there any info on today's fix? I'm not finding any documentation.
     
  20. captainbladej52 Apprentice Engineer

    Messages:
    230
    Posting here as it didn't do this before the minor hotfix that went out. I booted up one of my testing worlds like I normally would to do some testing planet side. As I loaded in the planet had completely vanished and the starting station along with everything else was now in space. The planet had been there the previous night and nothing was changed beyond saving and logging out. One mod was in use on the world however this is a shield mod I've used for some time. To eliminate it as a possible cause the mod was disabled and the world reloaded, but the planet never reappeared. I took some screenshots for viewing below. Unfortunately after attempting to reload it from one of the previous backups the world itself corrupted and I was no longer able to do anything with it. If it does it again I will try to backup a copy of it for testing if need be. In the mean time below are 4 screenshots taken to demonstrate I was indeed in space.

    [​IMG]







    [​IMG]

    [​IMG]

    [​IMG]
    --- Automerge ---
    For some reason the photos glitched out on my end when I tried to post them. If one of the mods would be kind enough to tell me where i screwed up trying to get the photos to display it would be greatly appreciated.









    Let's try this again.
     
  21. Cetric Junior Engineer

    Messages:
    725
    The author of your planet (assuming it is a mod planet) may have killed his mod on workshop. You checked if it is still there? I had cases like this surprising me, sadly, with all related parts of a mod disappearing when loading a save game. So I think this could also happen to whole planets.
    Because of this, I do from time to time backup copies of my SE folder somewhere else, to prevent save games from becoming corrupt by failed loading attempts.
     
  22. captainbladej52 Apprentice Engineer

    Messages:
    230
    that would've been the first thing I checked ordinarily. the only problem is that it was an easy start earth planet. all I did was slap a turret tower on it using vanilla blocks and a shield generator mod. i tried loading back in with the mod on and the mod off. same result each time, the planet was gone.
     
  23. Gatekepp3r Trainee Engineer

    Messages:
    9
    @captainbladej52 Try loading a backup of your world. The same thing happened to my world once, and it turned out that the save file was corrupted.
     
  24. captainbladej52 Apprentice Engineer

    Messages:
    230
    @Gatekepp3r I tried that one and it ended up corrupting the backup save. I ultimately ended up having to scrap the save. I was however able to pull out the bits I needed and save some refit prototypes I was working on. It was a basic world I created for testing so I didn't lose too awful much. I basically wanted to report it incase others were having the same issue.
     
  25. Cetric Junior Engineer

    Messages:
    725
    Another rescue attempt would be the use of SE toolbox.
    1. create new game with the same scenario. So this one with easy start earth planet. Save this new game after defining the basic parameters and what mods to use with.
    2. start SE toolbox and try to load one save game of the old easy start earth planet scenario, and parallely, the new scenario you just created in step 1 in another instance of SE toolbox.
    3. copy creations you find in the list of the old save game over to the new scenario by dragging items from one list to the other. Save the world in SE toolbox after each copying operation, it can crash sometimes or when you copy too much at a time.
    4. start SE and load the manipulated save game. It should now have the builds from the ancient save game in this new world, even at correct position. What you still need to do, however, is caving out the necessary holes on the planet. No problem with admin tools over alt+F11 where you can move through things like a ghost. I think this has to be done in creative mode though. Later, when you are finished with adaptation, you can still switch over to survival mode if that is the aim.
    --
    I could secure occasionally things this way.
     
  26. yotazama Trainee Engineer

    Messages:
    21
    Should have added more planets
     
  27. Cetric Junior Engineer

    Messages:
    725
    Workshop has dozens, if not a hundred (I did not count them). You can copy them all into your world.
     
  28. DigitalStone Apprentice Engineer

    Messages:
    260
    Uhm did someone from KSH (can't remember who) say there is another huge update coming our way in the end this month?
     
  29. Thrak Apprentice Engineer

    Messages:
    475
    Don't remember seeing that. Hopefully they're hard at work fixing what got broken in DS multiplayer. Crashes are becoming the norm on official servers.
     
  30. lordNorc Trainee Engineer

    Messages:
    9
    Mouse movement are no longer working after last mini update. When I got in the game, menu, everything works, than when you load a game (save or new), mouse in not responsive. And when ESC back to menu mouse is working only partially, you can move cursor but you cannot click anything.