Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

version 1.186.5 single player wheeled vehicles exploding

Discussion in 'Bug Reports' started by Wolfish Barley, Mar 18, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Wolfish Barley Trainee Engineer

    Messages:
    1
    have been playing single player on the Mars- like world, enjoying the recent updates to wheeled vehicles, when i noticed something strange.

    having my wheeled vehicles at a main base, i traveled 30 km away from them using a flying vehicle, to another place on the same planet. but whenever i returned to the main base, one or both of the wheeled vehicles seemed to have suffered an explosion. i tested this a few times, and it happened every time, whether the rovers had power or not. the only mods i installed were a speed mod, increasing the speed of vehicles to 200m/s.

    hopefully i provided enough information here about the bug to lead to a conclusion

    thanks Keen Software, keep up the dedicated work :)
     
  2. Zhiila Tester Staff

    Messages:
    487
    Hi,

    we know about the issue. It is just really hard to reproduce with some reliability. Could you provide the world so we can test it there? It would help so much to have a world where it is happening often (every time in perfect world :) )

    Thanks!
     
  3. Calaban Junior Engineer

    Messages:
    907
    I have had it happen as well, twice, both during similar situations, that may be helpful:

    I rolled up to an ore patch, parked my rover, and started digging down. So the wheels were on the edge of a voxel deformation. as I got down deep (100m or so, deeep gold) I'm guessing the voxel LoD changed and I hear the BOOM!

    I emerge from my gopher hole to find vehicle gone... maybe a part here or there in the distance.

    So mayyyybe wheels on voxel deform changes?
     
  4. Forcedminer Senior Engineer

    Messages:
    2,225
    it does tend to happen rather randomly might be hard to nail down. :/
    i don't think its related to voxel deform.....i remember that...*shutter* happening with landing gears ages back. fixed now though

    i made a large grid 5x5 rover base drove around for a while locked handbrake and the thing did a 90 degree rotation.
    I have idea what could be causing it from a players point of view.
    must be something to do with the physics update on wheels.
    maybe.....wheels could relax when they're parked up with handbreak on?
    i mean part of me believes it happens because whe..........oh.......part of me believes it happens because wheels tend to be tense when parked.
    .
    maybe it happens because voxel changes quality at distance and the wheels freakout thinking a big drop is coming so they brace for a big impact but then they are ready for a powerful landing but hit normal ground then explode??
    >Epiphany.jpeg

    im going to try disabling that brace for a drop feature...part of my now believes thats causing it.
    maybe for testing try create two rovers and disable that brace for drop feature on one but leave the other with it on and see what happens?
     
    Last edited: Mar 19, 2018
    • Agree Agree x 1
  5. Calaban Junior Engineer

    Messages:
    907
    Has it ever happened to someone right in front of their face? or like me: safely beyond my point of view, either when i was more than 2km away it blew up back home, or deep in a hole, as mentioned above.

    I'm just curious if someone else's wheeled vehicle has spontaneously detonated without requiring a grid load update/LoD update triggering it
     
  6. Forcedminer Senior Engineer

    Messages:
    2,225

    yes, this ugly duckling did the 90 degree snap rotate when i locked its landing gears.
    after i reloaded i willingly hold x to see how high it could jump.
    on landing the wheels all exploded off and launched me into the air like so....
    tbh i spent most of time my time fearing the trees would rip it apart.
    [​IMG]
     
  7. ExpendableGrunt Trainee Engineer

    Messages:
    9
    And to make it harder, detonation doesn't seem to be time-based nor guaranteed. When I was having the problem, I could load an old save game, and continue on past where my vehicle had exploded. By save-scumming, I could keep using the vehicle indefinitely, even though it kept exploding.
     
  8. Zhiila Tester Staff

    Messages:
    487
    If some of you would have a video how it happens and would be willing to share it, it could help as well. We are still trying to figure it out but as was mentioned above it seems to be quite random and it mostly happens out of sight. :( So far I saw 1 video with the issue and it didn't tell us much.
     
  9. Forcedminer Senior Engineer

    Messages:
    2,225
    was it this one?


    its hard to get a recording because it seems to random that by the time i've hit record im already hitting the ground or have reached 200 gb's of recordings. :p

    that was going good for me until auto save laughed and me and saved when i was flying though the air in my imagine.
    Thankfully i was able to survive by pointing my rover upwards.............and me and the cockpit survived....nothing else. on my third try. heh
     
  10. Zhiila Tester Staff

    Messages:
    487
    Yes, that's the one. :)
     
  11. Telquel Trainee Engineer

    Messages:
    45
    Had same problem on DS, tho it happens only on the moon.

    Not sure if that amount of wheels what causes it. Have 4 wheeled on earth like planet, been there like 2 weeks or so and it is still in one piece.
    Made couple 6 wheeled on moon and both wheels exploded randomly. Should test to make 4 wheeled on moon and check what happens.

    Cant say much about what causes it, because totally random and no matter if on grid or on voxels in my case. Both times those cars stand still without driver or passanger.
    --- Automerge ---
    That Earth like planet vehicle have 3x3 wheels and had never any problems. On moon every exploded vehicles had 5x5 small grid wheels. Trying to make 3x3 wheel versions to moon and see if those explode too.

    Made 4 wheel 5x5 and 6 wheel 5x5, so far that 4 wheeled one exploded little after when I drive it off to platform to voxel ground. But currently that 6 wheeled one is ok and it is also in voxel ground.

    Survival DS where this happens.
    --- Automerge ---
    No matter how much wheels or what size, Every wheeled vehicle blew up after while moved to voxel ground on the moon.

    EDIT: And world is modded one, so maybe need to make vanilla world too and test some more...
     
  12. Arcturus Senior Engineer

    Messages:
    1,649
    Not my video, but a recent one where an entire vehicle was eaten:
     
  13. Zhiila Tester Staff

    Messages:
    487
    @Arcturus Thanks a lot! I've already sent it to the programmers to look to see it.
     
Thread Status:
This last post in this thread was made more than 31 days old.