Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

World Failed to Save...

Discussion in 'Bug Reports' started by Rikerwota, Dec 20, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. NikolasMarch Junior Engineer

    Messages:
    923
    i will remove the extra characters from my Escape From Mars planet vx2 filename and its reference in the sbs file and will let it save a number of times :)
     
  2. I23I7 ME Tester Staff

    Messages:
    3,817
    Alright it had a fix implemented so if anything happens please do tell.
     
  3. jemccro Trainee Engineer

    Messages:
    97
    Its been fixed?! Awesome, now I can play again! --glad I was watching this thread, handy feature
     
  4. I23I7 ME Tester Staff

    Messages:
    3,817
    If it fails please send me the world ASAP
     
  5. Erynn Trainee Engineer

    Messages:
    26
    Yeah, I'm getting this message whenever I first start a new game world. No idea what's going wrong. The above fix suggestions about modifying the save file won't work if it's not generating one to begin with....
     
  6. I23I7 ME Tester Staff

    Messages:
    3,817
    Hello,

    Did you try and go into you %appdata% folder and check if deleting other save files will enable you to create new save games? Does it specify why it failed to save? Are you able to send us a video of the issue?

    Thank you!
     
  7. Alexander Schneider Trainee Engineer

    Messages:
    2
    Hi, I am running into this problem in Update 1.184.700. I have checked file names, and they are not unreasonablly long. There are no memory issues or hard drive issues that I’ve been able to diagnose using my system’s administrator’s tools. Any advice?
     
  8. I23I7 ME Tester Staff

    Messages:
    3,817
    can you please send the save files support@kswh.com ?
     
  9. Apsyc Apprentice Engineer

    Messages:
    108
    Kinda tired of seeing this[​IMG]

    Here's the log.
     
  10. Silverwing Trainee Engineer

    Messages:
    37
    For what it's worth this is still an issue. I was able to fix my problem with the information provided in this thread, but I don't understand why the file name continues to be appended with additional characters that don't have anything to do with the data in the file itself. Renaming the file, and updating the sandbox works but why, and I don't think should, a normal user have to do this.
     
    Last edited: Feb 17, 2018
  11. NikolasMarch Junior Engineer

    Messages:
    923
    yes i helped a couple players out with this problem over the past week :(
    @I23I7 i know you have moved on to mainly ME testing but i also know, that you know who is best to fix this again :)
     
  12. Robbie Trainee Engineer

    Messages:
    56
    I am having this issue for a few days now, game is unplayable since the tool deletes my planet and i am unable to save the game. Please fix this problem asap.
     
  13. Silverwing Trainee Engineer

    Messages:
    37
    Follow the steps above, after step 7 though you still need to delete the Sandbox_0_0_0_.sbsPB file. I recommend that you backup your files first. The *.sbsPB file is a binary duplicate of the Sandbox. If you don't delete this file the steps above will not work because the original file name is still being referenced. The binary file will be recreated the next time you load and save.

    Make note do not delete the Sandbox_0_0_0_.sbs (notice no "PB" in the extension). If you do you will lose the save file.
     
    • Informative Informative x 1
  14. Robbie Trainee Engineer

    Messages:
    56
    I did try this but upon entering the game my planet is gone. I tried the tool from Duckroll, same thing happend. Tried the Regedit fix that makes windows allow long pathfile names, didn't work. I am out of ideas.
    Here is a link to my world save files.
    Any help would be greatly appriciated.
    https://drive.google.com/open?id=1QEc-RWA8jAPTBrLoQefiIP7V7j1Ndynp

    Edit: I forgot the last step, i deleted the Sandbox_0_0_0_.sbsPB file now and my planet is still there upon loading into the game, Lets see if i can save, will report back shortly.

    Edit 2: At the moment i am able to save my game, i will be playing today and tomorrow.
    If it happens again i will report back, for now this seems to work.
    Thank you!
     
    Last edited: Feb 18, 2018
  15. NikolasMarch Junior Engineer

    Messages:
    923
    make daily manual backups is also probably a good idea, ive had planets go missing within various save games and didnt even know it as i was not near the planet at the time, SE toolbox can be used to open 2 games at a time, one you are playing, and one you created just to take the planets from, then you can drag and drop the planet you need to the savegame that the planet disappeared on... and could well be linked to this long/invalid planet name thing
     
  16. Silverwing Trainee Engineer

    Messages:
    37
    It will happen again I assure you. Until a permanent fix is provided the planet file names do have the potential of growing. I have noticed that this seems to happen more often after you have modified the voxels of a planet (mining, voxel hands, hand drill, explosions, etc...). This may not be the only reason that this occurs however. I have begun the practice of manually backing up my files once a week (takes only minutes), and viewing the saves files to be sure I am not approaching the name length limit again.
     
  17. Zhiila Tester Staff

    Messages:
    487
    Hi, I was just asking about this here in the office and it was told me, we already have a ticket it the system and it will be fixed.

    Sorry for the delay and thanks!
     
  18. Silverwing Trainee Engineer

    Messages:
    37
    Good news indeed.
     
  19. SlobbishHalo Trainee Engineer

    Messages:
    8
    I started getting this bug last week when i started to play with voxel hands. Seems like they cause this problem still.
     
  20. Veidebreij Trainee Engineer

    Messages:
    9
    Worked for me as well! A great thanks!
    But I had to change sbs and sbsPB File.
     
  21. Artax Trainee Engineer

    Messages:
    27
    I have had this problem over the last few days. It happens when I edit voxels close to blocks, primarily animated blocks, turrets, pistons, rotors, etc. I'm guessing that whatever fix that was implemented to prevent blocks from sinking through voxels also caused a number of issues when you want to embed/hide blocks in voxels.
     
  22. usswat64 Trainee Engineer

    Messages:
    4
  23. Tim Wilson Trainee Engineer

    Messages:
    7
  24. usswat64 Trainee Engineer

    Messages:
    4
    That Link doesn't provide a fix. Its just a link saying that someone is working on a script that might help.
    Thanks for dashing my hopes on the rocks by the Sea.
     
  25. Tim Wilson Trainee Engineer

    Messages:
    7
    Might want to read that again -- it's a "script" aka command line program that I wrote.. that does fix it. I know, because I had the same problem. You could run it right now by downloading Visual Studio Express and opening it up. I'll compile it into an exe when I get some time.
     
  26. usswat64 Trainee Engineer

    Messages:
    4
    I did in the link you gave it never talks about how to run it. The author says he might make it into a script. He said, "I'll compile this into a command line program and post a link later on to make it a bit easier if you actually desire to use the program as-is"

    But never said how to use it and I know nothing about coding. So saying a tool works without saying how to use it, doesn't help. Like some of my Marines. When you teach someone. You teach them steps 3 and 4. When before teaching them steps 1 and 2. You are assuming they know steps 1 and 2. When you assume. You only make and ASS of you and me.
     
  27. Royale98 Trainee Engineer

    Messages:
    57
    So I was curious if I would run into this issue soon, so I started digging... and fortunately my EarthLike isn't extensively drawn out in name... But I noticed something else...
    I figure this is the best place to ask cause y'all talking about .sbc's and .sbs's.
    Um, should my SANBOX_0_0_0_.sbs be 1.3 million lines of code (file is over 68MB)? No idea what the file does but that seems extensive... At least compared to ones from that dropbox which was 418KB. I'm noticing it's seemingly defining blocks for a portion and I do have currently about ~960MB of mods on the world, if that effects anything.

    For further reference my Sandbox.sbc is 3400+ lines at 134KB

    Also can someone tell me what the heck this is (from sandbox.sbc): *WARNING: CONTAINS FOUL LANGUAGE*
    Cause that seems like things I wrote, but I don't remember ever writing them at any point... I don't know why I would, it's singleplayer...
     
  28. Duarte Matos Trainee Engineer

    Messages:
    1
    I am having this issue right now. Same thing. Every time I place any kind of voxel material I get this error. If I log off and log in again and just use anything that is not voxel it works just fine. I did not have this proble before, as I have place voxels before without having this problem (error does happen if you remove voxel material as well).
     
  29. Meat Wagon Trainee Engineer

    Messages:
    1
    I just started having this issue this weekend. I Had done some Voxel work on earth and started getting this error message. It seems to be caused by the earthlike storage name issue since the file name is massive. I tried a few fixes I found around the net very briefly before I had to leave for work. Will update with what, if anything, worked for me later on. I do wish this would get fixed for good though.... It seems like an old bug that severely limits the use of the voxel hands.


    Edit: I used the above method and changed the earthlike file name and changed the sandbox_0_0_0_.sbs file and deleted the sandbox_0_0_0.sbsPB file and it worked. The world now saves normally
     
    Last edited: Apr 5, 2018
  30. Hickowolf Trainee Engineer

    Messages:
    2
    Cheers this helped and the world of which i am in now can save when voxel is edited.
     
Thread Status:
This last post in this thread was made more than 31 days old.