Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186.33] Cars randomly exploding while parked

Discussion in 'Bug Reports' started by Dazeuh, Feb 8, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Dazeuh Trainee Engineer

    Messages:
    77
    My server has lost many cars to this space madness, all my cars were parked and had no interaction with anything, seems like every 30 minutes one of my parked cars blows up.

    I have observed that the wheels have always popped off, one of my car wrecks shows that all wheels have popped off, and additonal damage to the grid originated from one of the wheels, killing the suspension and a cargo box it was close to.
     
    • Agree Agree x 6
  2. UncleCletus Trainee Engineer

    Messages:
    30
    We have this on our server too, it seems insanely random and doesn't happen for days or happens rapidly in a 3 hour time span. Sometimes entire cars would blow up and essentially be gone
     
  3. Capt. Hazzard Trainee Engineer

    Messages:
    2
    I've had the same problem. Whatever it is, it seems to only effect the body of the car and leave the wheels sitting on the ground undamaged.
     
  4. Dazeuh Trainee Engineer

    Messages:
    77
    Definitely needs to be hotfixed, we're trying to do an all-cars world and having more than half blowing up every hour isnt good.
     
  5. Morphik Apprentice Engineer

    Messages:
    186
    Can confirm, wheels randomly cause the vehicle to self destruct if left with parking brake on (only tested on the moon).
    This is on a single player game too.
     
    • Agree Agree x 1
  6. Auhrii Apprentice Engineer

    Messages:
    274
    Exactly what happened to me. Locally hosted game set to friends-only, but only me in the world. Left a rover parked, perfectly still, on flat terrain while I went to fetch a supply crate. Came back to find it exploded. Earthlike moon, no mods.
     
  7. SimGroot Trainee Engineer

    Messages:
    4
    same here
     
  8. Kezat Trainee Engineer

    Messages:
    19
    Same here offline single player.
    I had a small rover parked near my base (not connected) I had my back to it assessing a connector, i hear a large explosion and turn around to find a small crater and my rover missing its front half. Another time I parked it and was walking around and under when it again just exploded for no reason killing me.
     
  9. kittle Senior Engineer

    Messages:
    1,086
    same here, also offline single player. vehicle was parked while I was doing something else, and I heard explosion sounds. when I investigated, the rear 2 wheels had vanished and the vehicle was turned upside down.
    This was a large grid vehicle with 4 3x3 wheels. it weighed about 150k. I restored the game from a backup, and the problem did not re-occurr.
     
  10. Brian Yilmaz Trainee Engineer

    Messages:
    27
    Just keep telling yourself that they have FIXED WHEELS - as they want to make us believe :) then everything should be fine.
    There is just one wheeled vehicle on my server atm and it is parked for some weeks now.. I will look after it today, but I think it's okay yet.
     
  11. Silvrav Trainee Engineer

    Messages:
    89
    can confirm happening on our DS's as well
     
  12. Inflex Developer Staff

    Messages:
    397
    Good evening everyone,
    we are aware of this issue and we are searching for reliable steps to reproduce it (Does not mean "play 30 mins and it might eventually happen")
    If you have any useful info that could help us find the repro, please share it with us.

    Till then, please be patient as we are working hard to find this bug and fix it.
    Thank you
     
    • Like Like x 1
    • Informative Informative x 1
  13. Outfrost Apprentice Engineer

    Messages:
    273
    I have found, on my survival server, that someone connecting to the server, after the server has been idle with no players for some time (anywhere between a few hours to a day), has a high chance of making wheels explode on parked rovers. The same does not seem to hold true for rovers suspended in the air (not wheels-to-ground / wheels-to-platform contact). Also, building more than a few wheel suspensions with wheels and putting them down on the ground seems to destroy multiplayer performance with horrible sim speed drops occuring periodically every minute or a few. It seems like it gets a bit better when parking brakes are released.

    Here's a world backup from my server. The backup saves demonstrate it going from all good to wheels exploded. around 12:59-13:00 is when someone joined the server after it had been running but empty for about 10 or so hours.
    https://drive.google.com/file/d/1Fq3vfGWp0-pKb8dBSlsHUtApQY91dqz-/view?usp=sharing
     
  14. Silvrav Trainee Engineer

    Messages:
    89
    Thank you.

    As @Outfrost pointed out it does seem to be when parking brakes are on and the vehicle is left unattended. I can confirm though its not a loading issue as we had one explode right next to us last night while working on a base. It definitely seems to be wheels on voxels thats causing it
     
  15. jmang98 Trainee Engineer

    Messages:
    1
    I have the same issue, although the most I can offer is a screenshot. Spawned in from a few hours of downtime, and found this:
    [​IMG]
    Wheels are gone, but rover is functional with thrusters. The wheels explode from the rover. Happens when people are in and out of server. I've experienced the issue with myself just exiting the rover, hearing an explosion, and seeing this:
    [​IMG]
    Only wheels left with no other parts of the ship left. I've lost many good rovers to this issue. Platform is suspended above voxel, so no voxel contact involved. Just explosions.
     
  16. Outfrost Apprentice Engineer

    Messages:
    273
    More precisely, I don't think it has to be wheels on voxels, as we've had it happen with rovers parked on top of station grids (as the attached world files demonstrate).

    We have also found that lifting a parked rover up from its wheels onto a landing gear pad on a piston on a rotor appears more stable and predictable than simply leaving it on parking brake (though it's jittery and rubber-bands a lot visually).
     
  17. Forcedminer Senior Engineer

    Messages:
    2,227
    if i could add 2 experiences to this.
    i have no idea what caused it. it was an unmodded world
    but a large grid 4x4 with the biggest wheels i was driving around it detected some iron ore which i needed.
    i put the handbrake on locked the gyroscopes and the thing just teleported into a 90 degree angle embedding itself into the ground sorta bouncing around. i hate to say it but it felt....clangish.
     
  18. Outfrost Apprentice Engineer

    Messages:
    273
    If that was in multiplayer as well, it might've been local glitches that didn't 'actually' happen on the server. As a (very temporary) workaround, you can always try rejoining the multiplayer session or - if the server's running Torch with Essentials - use !entities refresh in global chat.
     
  19. Artax Trainee Engineer

    Messages:
    30
    Playing Escape From Mars scenario, mostly vanilla with EFM Mod, Easy inventory Mod, and Text HUD API, single player game only. When parking brake on while parked in or very near altered voxels, small grid vehicle with 5x5 suspension x6, would spontaneously jump on occasion and eventually exlploded the last time. Not sure if it was while hitting "P" or a period of time after doing so. Instances happened only once per time parked until the explosion.
     
  20. gnif Trainee Engineer

    Messages:
    2
    If it helps I have a local game on 1.186.500 that I saved with a vehicle and base in good working order which upon loading my base is all damaged and my vehicle has exploded on the pad I made for it. The save was made manually before selecting exit, I verified nothing had failed/exploded, and then exited, without saving a second time, so I know my save state was of a game in a good condition. This will provide a reliable way for the developers to reproduce this problem if it is wanted.

    I will not be playing this game at all until this bug is fixed, it is completely unplayable.
     
  21. Zhiila Tester Staff

    Messages:
    487
    Hi,

    could you share the save? I believe it could help. I would pass it to the programmer who is responsible for wheels so he can look at it.

    Thanks!
     
  22. gnif Trainee Engineer

    Messages:
    2
    Here it is :)
    https://megadrive.co/01ccfhaqf5ks
     
Thread Status:
This last post in this thread was made more than 31 days old.