Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Another problem, game doesnt open

Discussion in 'Technical Help' started by leandro, Apr 18, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. leandro Trainee Engineer

    Messages:
    4
    Well previously i had a problem that was when i was playing the game and suddently the game closed itself when i was playing but now my new problem is that i cant open the game, for example when i press start on steam to open the game the luncher doesnt open and i can wait for 20 minutes but nothing happens and also the computer gets slower for a wihle, i tried unistalling the game, steam and i havent got any result. Also i want to mention that its only with medieval engenieers beacuse i tried opening other games and i didnt have any sort of problem, and i have a modest computer that allows to run the game without any problem, i been playing medieval engenieers for 3 years without any problem so i hope to have a solution.
     
  2. I23I7 ME Tester

    Messages:
    3,827
    Can you please send us your logs after attempting to launch the game please? They can be found by opening your explorer and typing %appdata% in the right corner. It will take you to the ROAMING folder in there go into the MEDIEVAL ENGINEERS folder. There you will find the logs.
     
Thread Status:
This last post in this thread was made more than 31 days old.